DS Lite not powering on..

Discussion in 'NDS - Flashcarts and Accessories' started by loaky, Dec 25, 2008.

Dec 25, 2008

DS Lite not powering on.. by loaky at 10:16 AM (1,059 Views / 0 Likes) 4 replies

  1. loaky
    OP

    Newcomer loaky Member

    Joined:
    Nov 22, 2008
    Messages:
    16
    Country:
    United Kingdom
    I hope this is the right place to be posting this. i've got a DS Lite that i've had about 18 months, anyway always been fine until yesterday. After playing about with the G6 card (See thread in G6 subforum, didn't fix it btw!) it wouldn't turn on again. I don't think the card had anything to do with it really as it's the same after removing the card. What happens is the green power light turns on and stays on after switching on, but the screens are both blank, and no sound. I've had the battery out and case off to check fuses F1 and F2 which some sites suggest for powering up problems, and they're both fine.

    Also I switched it on this morning after a night of not touching it, and it got to the white startup screen. then went back to black screens when I clicked the screen.

    And have a Merry Christmas everyone! [​IMG]
     
  2. loaky
    OP

    Newcomer loaky Member

    Joined:
    Nov 22, 2008
    Messages:
    16
    Country:
    United Kingdom
    Any tips anyone? [​IMG]
     
  3. gamma93

    Member gamma93 GBAtemp Regular

    Joined:
    Jan 20, 2008
    Messages:
    115
    Location:
    United States
    Country:
    United States
    Perhaps it is bricked? If you ran any shady homebrew then you could have bricked it.
     
  4. kimit

    Newcomer kimit Advanced Member

    Joined:
    Jun 1, 2008
    Messages:
    70
    Location:
    Surrey
    Country:
    Canada
    i Remember when i thought my ds was bricked after i put my friends top toy in it (it started working ten minutes later lol)
     
  5. loaky
    OP

    Newcomer loaky Member

    Joined:
    Nov 22, 2008
    Messages:
    16
    Country:
    United Kingdom
    I think a smilar thing to that happened to me, using the [i'm now almost convinced] duff G6 card seemed to lock it up so it wouldn't turn on. After a whole day of leaving it be wih the battery out it started up ok, though using the G6 card made it happen again.

    So at least the DS is alright, time to hunt for a new card now then! Cheers guys! [​IMG]
     

Share This Page