DS Lite - Getting Warm - Battery Losing Charge

Discussion in 'NDS - Console and Game Discussions' started by D4nny26, Apr 30, 2014.

  1. D4nny26
    OP

    D4nny26 Member

    Newcomer
    24
    2
    Apr 30, 2014
    Hi All,
    Wondering if anyone can help me solve a problem,
    I had 2 DS Lites, with broken hinges but both worked fine.

    I've changed the cases, they both work fine.

    But now, both of them have the same problem, they seem to be getting wram where the XYAB buttons are.

    I've took them back apart and it seems to be a chip that says "Mitsumi" or something like that, after fully charging the battery, it lasts about an hour before going off again, both consoles work fine though, but they never got warm like it before, i've swapped the batteries, swapped the little wifi board things over but still the same problem. Also the water indicator isn't showing any signs of them having got wet before,

    Any suggestions on how to fix or ideas on what is causing the problem ?
     
  2. D4nny26
    OP

    D4nny26 Member

    Newcomer
    24
    2
    Apr 30, 2014
    I've narrowed the problem down, it's either the top LCD screen or the housing casing itself.

    Both new housing cases are metallic rose pink
     
  3. D4nny26
    OP

    D4nny26 Member

    Newcomer
    24
    2
    Apr 30, 2014
    Well well you know i've fixed the problem, i've fixed problem.
    The replacement housings had a bit of plastic that was miss shaped, so i sliced it with the knife to make it the same shape as on the original housings, the bit of plastic was located on the top section below where the speakers are soldered to the LCD screen.
    All working perfect now.
     
    Schizoanalysis likes this.