DS Firelink 2G (NCard clone) ROM compatability

Discussion in 'Other Flashing Hardware & Software' started by baz74, Aug 31, 2009.

  1. baz74
    OP

    baz74 Newbie

    Newcomer
    2
    0
    Aug 31, 2009
    I have been offered the DS Firelink 2G fire card for a good price and I am tempted to get a few for my family but it appears that there has not been any firmware updates for a long time. The last one is v1.45. Are all the latest roms going to work OK or am I best avoiding the DS Firelink? And is the internal battery problem, some people have had, a common problem? Is it likely to happen to the DS firelink cards I buy?

    Thanks in advance
     
  2. bog500

    bog500 Member

    Newcomer
    40
    0
    Jul 29, 2008
    Canada
    No. Many newer games won't work. The N-Card (and all clones) are outdated. Get an Acekard or something similar.
     
  3. baz74
    OP

    baz74 Newbie

    Newcomer
    2
    0
    Aug 31, 2009
    Thanks for your reply. It looks like Im pobably being offered them cheap because they're out of date then. What about the M3 real, do they still have a good compatability with new ROMS.
     
  4. jackdanielchan

    jackdanielchan GBAtemp Advanced Fan

    Member
    539
    0
    Mar 15, 2009
    Yes they do, but I would consider getting a M3 I Zero, which has a DSi compatibility, and a bootloader, just incase you may need to upgrade to a DSi...
     
  5. Matt140

    Matt140 GBAtemp Fan

    Member
    345
    0
    Mar 1, 2009
    England
    If you intend on upgrading to the DSi, I'd consider getting an M3i Zero (for about £26) like jackdanielchan said above. But if you just want to use it on the DS/DS Lite, I'd go with the M3 Real (which you can get for £18 here, which also includes the rumble cart)