Hacking Downgrade Updates on Wii U Games?

BeRnYGP

Well-Known Member
Member
Joined
Jul 1, 2015
Messages
159
Trophies
0
XP
143
Country
Mexico
I have installed v1.1.1 in the BotW game, but I want to return to the v1.1.0 version. Its possible to do this? I mean, I have tried to install again the v.1.1.0 version but now it doesnt let me launch the game cause it seems the system already thinks you have the last version ready for install. So inmediately launch an error and try to download the new version. Maybe deleting some files can fix this?

Thanks in advance :yaywii:
 

ThunderbInazuma

Well-Known Member
Member
GBAtemp Patron
Joined
Aug 31, 2015
Messages
491
Trophies
0
Location
Under Your Bed
XP
1,351
Country
Portugal
I have installed v1.1.1 in the BotW game, but I want to return to the v1.1.0 version. Its possible to do this? I mean, I have tried to install again the v.1.1.0 version but now it doesnt let me launch the game cause it seems the system already thinks you have the last version ready for install. So inmediately launch an error and try to download the new version. Maybe deleting some files can fix this?

Thanks in advance :yaywii:
Delete the update on the system settings storage management ( dont remember the exactly name) and download the update you want via WiiU USB Helper and install it using homebrew launcher and a app that lets you install it
 

BeRnYGP

Well-Known Member
Member
Joined
Jul 1, 2015
Messages
159
Trophies
0
XP
143
Country
Mexico
Delete the update on the system settings storage management ( dont remember the exactly name) and download the update you want via WiiU USB Helper and install it using homebrew launcher and a app that lets you install it

I already tried that but it didnt work. It seems the system thinks you have the last version already and just want to install it again :(
 
D

Deleted User

Guest
So my Wii U refuses to update BotW anyways. [Not even nagging me to do it]
Just use Wii U USB Helper and update it back to v1.1.0. Should work just fine.
 

EclipseSin

Ignorant Wizard
Member
Joined
Apr 1, 2015
Messages
2,063
Trophies
0
Age
32
Location
221b Baker Street
XP
1,695
Country
United Kingdom
I have installed v1.1.1 in the BotW game, but I want to return to the v1.1.0 version. Its possible to do this? I mean, I have tried to install again the v.1.1.0 version but now it doesnt let me launch the game cause it seems the system already thinks you have the last version ready for install. So inmediately launch an error and try to download the new version. Maybe deleting some files can fix this?

Thanks in advance :yaywii:
If you are having the trouble I think you are, there is a way to fix it but it is dangerous to modify the file. I am unsure what happens if you mess up the modification, but it is likely possible to brick if the file is modified incorrectly.

The file you will need to modify is on the Wii U nand at slc/security/versions.bin

This file is a database containing the latest version numbers for games as retrieved from the net/via install. Once you modify the file, restart your Wii U by turning it off and then back on. If you update to 1.1.1 again, you will not be able to launch the game without updating again.

To edit the file you will require a hex editor. You will search for the title id (US 0E101C9400 / EU 0E101C9500 / JP 0E101C9300)

I do not recommend inserting or removing data from the file, simply replace the existing data.

so for example

48 is 30 in hexadecimal, so for v48 you would for example change the following line in that file
Code:
FFFF000000300005000E101C94000000203A0000003000050000101C95000000203900
to v33, 33 is 21 in hexadecimal
Code:
FFFF000000210005000E101C94000000203A0000002100050000101C95000000203900

I take no responsibility if you fuck something up.


Meh, someone beat me to it, oh well. Have known about this since day 1 of getting slc access.
 
Last edited by EclipseSin,

BeRnYGP

Well-Known Member
Member
Joined
Jul 1, 2015
Messages
159
Trophies
0
XP
143
Country
Mexico
:)Wow, I didnt expect the answers so fast.
Thanks everyone, It seems its too much risk if you mess something and you are not using RedNand. I know how to use hex editor and FTP Client but... I dont know; with my luck... I prefer waiting until I can adquire a 64GB SD Card and try it over RedNand. Anyway, thanks again!
 

EclipseSin

Ignorant Wizard
Member
Joined
Apr 1, 2015
Messages
2,063
Trophies
0
Age
32
Location
221b Baker Street
XP
1,695
Country
United Kingdom
:)Wow, I didnt expect the answers so fast.
Thanks everyone, It seems its too much risk if you mess something and you are not using RedNand. I know how to use hex editor and FTP Client but... I dont know; with my luck... I prefer waiting until I can adquire a 64GB SD Card and try it over RedNand. Anyway, thanks again!
I could like, modify your file, youd still have to download/upload it though. I still use an old iosuhax i compiled from FIX94/dimok repos and FTPii U Everywhere, so anything newer should work fine/better.
 

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
16,942
Trophies
1
XP
15,874
Country
United States
I have two versions of Breath of the Wild installed: the USA version and the European version. The USA version is on 1.1.1, and the European version is on 1.1.0. I use Saviine to move my save file between them if need be. I only did this to unlock some Amiibo exclusives.
 

BeRnYGP

Well-Known Member
Member
Joined
Jul 1, 2015
Messages
159
Trophies
0
XP
143
Country
Mexico
I could like, modify your file, youd still have to download/upload it though. I still use an old iosuhax i compiled from FIX94/dimok repos and FTPii U Everywhere, so anything newer should work fine/better.

Thank you but it will be not necessary, Im going to test some stuff first and if It doesnt work, Im gonna try this option. Thanks again :)
 
  • Like
Reactions: EclipseSin

lordelan

Well-Known Member
Member
Joined
Jan 4, 2015
Messages
5,160
Trophies
1
Age
41
XP
4,769
Country
Germany
I have two versions of Breath of the Wild installed: the USA version and the European version. The USA version is on 1.1.1, and the European version is on 1.1.0. I use Saviine to move my save file between them if need be. I only did this to unlock some Amiibo exclusives.
So a 1.1.1 savegame is definitely compatible to 1.1.0?
 

season_of_ages

New Member
Newbie
Joined
Aug 20, 2017
Messages
4
Trophies
0
Age
32
Location
Antelope Valley, CA
XP
21
Country
United States
I will be attempting the hex edit solution in a bit. I forgot to change the DNS settings when we set up a new router and now I have 5.5.2 AND 1.3.1. All because my 3 year old kid loves playing Mario Maker. Sheesh
 

season_of_ages

New Member
Newbie
Joined
Aug 20, 2017
Messages
4
Trophies
0
Age
32
Location
Antelope Valley, CA
XP
21
Country
United States
Aaaaand it worked! Changed the Title ID version number as well as all the Update version numbers (I noticed that all three JPN USA and EUR versions were listed with v112 [1.3.1]) and reverted everything back to v97 (1.3.0) ! Of course I had already deleted the update data on my Wii U and installed the old update data that was still on my SD Card from when I had the card prepared by Wii U USB Helper awhile back. I was afraid my save file wouldn't load since I saved on v112 (1.3.1) without knowing about the update all this week, but I successfully loaded my save file on v97 (1.3.0) just now! Infinite item glitch, here I come!!
20170820_161535.jpg
 

Site & Scene News

General chit-chat
Help Users
    Swagboi308 tempBOT: Swagboi308 has joined the room.