Downgrade for System Menu 4.0

Discussion in 'Wii - Hacking' started by Aurora Wright, Apr 7, 2009.

Thread Status:
Not open for further replies.
Apr 7, 2009
  1. Aurora Wright
    OP

    Member Aurora Wright GBAtemp Maniac

    Joined:
    Aug 13, 2006
    Messages:
    1,391
    Country:
    Italy
    Requisites:
    - this archive;
    - WiFi connection/LAN Adapter! (if you want to do it offline, see here but it's really dangerous...)
    - BannerBomb.
    - Your Wii MUSTN'T have a serial number starting with LU64 or LU65. Use the HackMii Installer to install The Homebrew Channel, but you can't downgrade (yet).
    No cIOS required!

    1) Unpack the archive linked above.
    2) Do a full backup of your SD card on the PC, and DELETE everything from the card.
    3) Copy BannerBomb to the SD card.
    4) Copy the content of the "SD Root" folder in the archive to the root of the SD card.
    5) On the Wii, launch boot.dol using BannerBomb, then go to "downgradetools" in the SD and choose notDVDX34.dol. Pick "Downgrade IOS35", wait for it to end and come back to the menu, then exit.
    - If it says that "you're a pirate" delete also all your VC/WiiWare pirated channels (with AnyTitle Deleter or WAD Manager), execute NandClean.dol, choose to delete "dvdx 3.4's gift" and try again [​IMG]
    6) Launch PatchMii IOS Downgrader.dol, you may need to launch it from LoadMii 1 or 2 times, until it's needed [​IMG]
    7) When it says "IOS 249 (Rev 5) loaded successfully", install all of the IOSes except IOS35 (with trucha patch). If you want, you can also install System Menu 3.2 or 4.0, but MAKE SURE that its IOS has been installed correctly:
    - System Menu 3.2 requires IOS30;
    - System Menu 4.0 requires IOS60.


    Note: The cIOS that is now installed on your console doesn't have "backup loading" capabilities, use cIOS Installer by Waninkoko to get this.

    Thanks to comex for DVDX 3.4 and BannerBomb, to WiiPower for providing a version of the WAD Manager source compatible with the latest devkitPro and libogc, to WB3000 for NUS Downloader and to tona for IOS50&WiiShop Installer and PatchMii cIOS Installer.
     


  2. gloscherrybomb

    Member gloscherrybomb GBAtemp Regular

    Joined:
    Apr 1, 2009
    Messages:
    107
    Country:
    United Kingdom
    Is this proven to work? Surely the wii will block stage 9?
     
  3. Aurora Wright
    OP

    Member Aurora Wright GBAtemp Maniac

    Joined:
    Aug 13, 2006
    Messages:
    1,391
    Country:
    Italy
    No, IOS35 is downgraded by DVDX 3.4 to a trucha-friendly version [​IMG]
     
  4. gloscherrybomb

    Member gloscherrybomb GBAtemp Regular

    Joined:
    Apr 1, 2009
    Messages:
    107
    Country:
    United Kingdom
    Interesting, I'd love to test it out, is it brick proof? Bit worried about being the first. If you're correct though I love you like a fat kid loves cake.
     
  5. Aurora Wright
    OP

    Member Aurora Wright GBAtemp Maniac

    Joined:
    Aug 13, 2006
    Messages:
    1,391
    Country:
    Italy
    It has been tested successfully [​IMG]
     
  6. gloscherrybomb

    Member gloscherrybomb GBAtemp Regular

    Joined:
    Apr 1, 2009
    Messages:
    107
    Country:
    United Kingdom
    One more question, I'm on linux so cant use the bat. Is the file definitely called cios_fix.wad and is there only one version?
     
  7. nl255

    Member nl255 GBAtemp Advanced Maniac

    Joined:
    Apr 9, 2004
    Messages:
    1,998
    Country:
    Would this work on a stock 4.0 wii assuming a way could be found to run a .dol file, such as Comdex's BaNNeRBoMB?
     
  8. Aurora Wright
    OP

    Member Aurora Wright GBAtemp Maniac

    Joined:
    Aug 13, 2006
    Messages:
    1,391
    Country:
    Italy
    Yes, and this way we could also install the HBC wad (unfortunately, the exploit that the HBC installer used has been fixed).
    @gloscherrybomb: yes, it's called "cios_fix.wad" [​IMG]
     
  9. Brian117

    Member Brian117 GBAtemp Psycho!

    Joined:
    Oct 1, 2007
    Messages:
    3,249
    Location:
    Cleveland, OH
    Country:
    United States
    I just used AnyRegionChanger from on 4.0 and went back to 3.2U and my Wii was fine.
     
  10. gloscherrybomb

    Member gloscherrybomb GBAtemp Regular

    Joined:
    Apr 1, 2009
    Messages:
    107
    Country:
    United Kingdom
    Thats because you already had a cios Brain! Some of us have been desperate for this!
     
  11. Aurora Wright
    OP

    Member Aurora Wright GBAtemp Maniac

    Joined:
    Aug 13, 2006
    Messages:
    1,391
    Country:
    Italy
    If you have trucha-enabled IOSes/cIOS (you probably used waninkoko's tool to upgrade to 4.0) that's perfectly normal.
     
  12. Brian117

    Member Brian117 GBAtemp Psycho!

    Joined:
    Oct 1, 2007
    Messages:
    3,249
    Location:
    Cleveland, OH
    Country:
    United States
    Well yeah...but to be honest, who would NOT use the cIOS? Wouldn't you want to look more into the firmware first than to update right away?

    Meh. Sorry.
     
  13. gloscherrybomb

    Member gloscherrybomb GBAtemp Regular

    Joined:
    Apr 1, 2009
    Messages:
    107
    Country:
    United Kingdom
    It's not necessarily our fault... younger siblings and stuff! And anyway so what if people were stupid and moved the homebrew channel to sd or upgraded without a cios.
     
  14. nl255

    Member nl255 GBAtemp Advanced Maniac

    Joined:
    Apr 9, 2004
    Messages:
    1,998
    Country:
    It will be far more useful once a new save exploit or the bannerbomb exploit is released, as you will be able to softmod a brand new, just purchased, wii with system menu 4.0. It will also be useful for people who sent their systems in for repair, as nintendo will update to 4.0 before sending it back.
     
  15. BIG MOE

    Member BIG MOE ๔*๖ LORD BIG MOE ™

    Joined:
    Oct 19, 2008
    Messages:
    1,253
    Location:
    Wiiland Hills
    Country:
    Syria
    good work Davi92 , now the missing link is the HBC installation on new ver4.0 SM with a new exploit [​IMG] so Comdex work is the one I'm waiting for [​IMG] , Davi92 keep it up buddy
     
  16. nl255

    Member nl255 GBAtemp Advanced Maniac

    Joined:
    Apr 9, 2004
    Messages:
    1,998
    Country:
    You can prevent upgrading (via the offical updater) by turning on parental controls, even if you set everything to unrestricted. Also, you can re-install the homebrew channel by using a wad of it, though you must either have preloader (to load a wad installer) or cioscorp/modchip (to boot a hbc installer iso). Note that you can't use the normal installer ISO, you have to use the one designed for 4.0 available by searching this forum.
     
  17. AmitZ

    Newcomer AmitZ Advanced Member

    Joined:
    Feb 15, 2008
    Messages:
    69
    Country:
    Israel
    Can it be done without the HBC?
    My friend wants to downgrade just so he could install the HBC.
     
  18. Hells Guardian

    Member Hells Guardian GBAtemp Maniac

    Joined:
    Dec 25, 2008
    Messages:
    1,113
    Country:
    United States
    There is currently no way to execute homebrew code on an unmoded wii with version 4.0 on it yet. There should be a new exploit out soon enough...... I hope..... Either way it does happen to be true that the banner bomb exploit is looking quite promising... If nothing else there will likely be another exploit released soon enough.

    BTW Does anyone know exactly what Nintendo did to actually block the Twilight hack this time around?
     
  19. gloscherrybomb

    Member gloscherrybomb GBAtemp Regular

    Joined:
    Apr 1, 2009
    Messages:
    107
    Country:
    United Kingdom
    I'm getting a ret -1 error when I try to find the wad in WMIOS254/boot.dol what am I doing wrong?
     
  20. gloscherrybomb

    Member gloscherrybomb GBAtemp Regular

    Joined:
    Apr 1, 2009
    Messages:
    107
    Country:
    United Kingdom
    I misnamed the wad folder, however now I get a ret -1035 when I try to install the wad!
     
Thread Status:
Not open for further replies.

Share This Page