DOP-IOS MOD 11.3 syscheck bug??

Discussion in 'Wii - Hacking' started by john1010_ma, Jan 31, 2010.

Jan 31, 2010
  1. john1010_ma
    OP

    Member john1010_ma GBAtemp Regular

    Joined:
    Dec 31, 2006
    Messages:
    110
    Country:
    Brazil
    Here's hoping the developers will look into it:

    Updated to the new version of v11.3 of dop-ios mod. Like always, I'd select to use my fakesigned ios 70 as the ios of choice when prompted. Today, I decided to check out the v11.3 syscheck feature. It churned out the results alright. After that, I hit the A button and existed to the main menu of dop ios and then existed the program completely.

    Here's the nasty part: in the Wii menu, whenever I clicked on a channel, the Wii would just restart. Problem persisted even after unplugging the Wii, the USB and SD Card. I had to restore my Nand to make the problem go away.

    There was no other action I did between the syscheck and going back to the wii menu, so i am pretty sure syscheck screwed something up.

    update: there has been a few more threads detailing similar problems with dop-ios 11.3 and 11.4's syscheck. So a word of caution: DO NOT RUN SYSCHECK until there is a known fix

    update2: Lunatik has released a fix, read his post for more info

     
  2. tj_cool

    Supervisor tj_cool Stuff

    Joined:
    Jan 7, 2009
    Messages:
    9,942
    Location:
    This planet
    Country:
    Belgium
    as long as you can still access the complete wii menu, its not bricked
    so the channels not working doesn't mean it's bricked

    but it's strange cause it shouldn't mess anything up
    may I ask why you use IOS70 and not IOS36 for example?
     
  3. john1010_ma
    OP

    Member john1010_ma GBAtemp Regular

    Joined:
    Dec 31, 2006
    Messages:
    110
    Country:
    Brazil
    It was a purist habit which I caught from Zektor long ago. He and I wanted to keep as many "pure" ios as possible. Crazy but true. Therefore, I only fakesigned ios 70 when performing an upgrade from 4.1 to 4.2 using Zektor's method.

    You are right, it's not bricked but enough to cause me a complete Nand restore.
     
  4. tylerzentz

    Member tylerzentz GBAtemp Regular

    Joined:
    Oct 19, 2009
    Messages:
    206
    Country:
    United States
    v11.4 of dop-ios mod is out as of 50 minutes ago when this was posted. just saying...
     
  5. Lunatik.

    Newcomer Lunatik. Member

    Joined:
    Dec 30, 2009
    Messages:
    48
    Country:
    United States
    Hey guys. I'm looking into the Channel issue. Hopefully will have something tomorrow.
     
  6. Lunatik.

    Newcomer Lunatik. Member

    Joined:
    Dec 30, 2009
    Messages:
    48
    Country:
    United States
    OK Everyone. Sorry about the channel issue. I know what is going on now. Apparently ES_AddTitleCancel doesn't remove the bogus ticket. So if you had an IOS that was patched with FakeSign (Trucha) it was adding the extra ticket to the title. Apparently the channels are getting "confused" on which ticket to use.

    I will have this fixed in 11.5 and When you run SysCheck again it'll also automatically fix the channels as well.

    For the time being to repair the issue what you need to do is use AnyTitle Deleter and delete the IOS that the channel uses and then reinstall the IOS using DOP 11.2.

    Track Ticket status @ https://code.google.com/p/dop-iosmod/issues/detail?id=33
     
  7. john1010_ma
    OP

    Member john1010_ma GBAtemp Regular

    Joined:
    Dec 31, 2006
    Messages:
    110
    Country:
    Brazil
    Woohoo! Thank you Lunatik!
     
  8. tylerzentz

    Member tylerzentz GBAtemp Regular

    Joined:
    Oct 19, 2009
    Messages:
    206
    Country:
    United States
    follow these steps to replare your broken channels.
    1. go to http://wiibrew.org/wiki/Preloader/Priiloader and click the "Website" button under the "Links" section on the right information box. In this website, click the "Downloads" tab at the top of the page and then click Priiloader_v0_3b.zip and save it to your desktop or wherever you please. Now extract the "boot.dol" file from the archive and place it in your "apps" folder on you SD card. Now load up the homebrew channel (see below if your homebrew channel reboots the wii) and boot up the Priiloader app and install it. Ta-DA! channel problem solved. I have no idea how the hell this fixes it, but it worked for me perfectly.

    if homebrew channel reboots wii, try navigating to it via BootMii. if you already have priiloader installer, use it to boot directly to the homebrew channel and then install priiloader again with the homebrew app. if neither of these methods work for you, you can always resort to the bannerbomb exploit.

    hope this helps.
     
  9. Lunatik.

    Newcomer Lunatik. Member

    Joined:
    Dec 30, 2009
    Messages:
    48
    Country:
    United States
  10. tj_cool

    Supervisor tj_cool Stuff

    Joined:
    Jan 7, 2009
    Messages:
    9,942
    Location:
    This planet
    Country:
    Belgium
    So if you run SysCheck again with this new version, everything starts to magically work again?
    Great [​IMG]
     
  11. Lunatik.

    Newcomer Lunatik. Member

    Joined:
    Dec 30, 2009
    Messages:
    48
    Country:
    United States
    Correct. I have it set so that ES_DeleteTicket is called right after ES_AddTicket if successful. The bogus ticket is what was causing the channels to be broken.
     

Share This Page