Do i need a certain firmware to install prometheus?

Discussion in 'PSP - Games & Content' started by Dark, Jul 7, 2010.

  1. Dark
    OP

    Dark GBAtemp Advanced Fan

    Member
    2
    Jul 6, 2008
    United States
    Just wondering if I need anything to install prometheus, I'm using GEN-D3Final.
     
  2. Goli

    Goli RPG

    Member
    1
    Jul 16, 2008
    Cote d'Ivoire
    I'm pretty sure you need GEN-D3, I'm just about to install Prometheus myself and I'm on GEN-D3.
    EDIT: I just installed it, just a press of a button and it was done in less than a second. Surprisingly easy, compared to other CFW installations!
     
  3. Helveteskuken

    Helveteskuken Member

    Newcomer
    3
    Oct 18, 2006
    You don't need D3, I just installed from D2 and it works perfectly.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice