Confused about PSX2PSP

Discussion in 'PSP - Hacking & Homebrew' started by solidsnake13, Feb 10, 2011.

  1. solidsnake13
    OP

    solidsnake13 Member

    Newcomer
    1
    Jun 23, 2009
    United States
    I just got a PSPGO [​IMG] so obviously I am new to the scene and I have been doing my own research on how to play converted PSX games on it. It currently has OFW 6.20 (loaded, not upgraded) on it and I don't see any method (without huge risk of bricking it) to lower the OFW to use a CFW.

    Anyway, my question is, is there currently a CFW that can play converted PSX games on it for a 6.20 PSPGO?
     
  2. Schlupi

    Schlupi Gbatemp's Official Earthbound Maniac™

    Member
    4
    Aug 31, 2007
    United States
    Rozen Queen Co, Chicago Branch
    You need to use a HEN + Prometheus ISO loader OR 6.35 PRO-A in order to play backups. At the momet, there is no support for POPS (PSX loading) but there will be in 6.20 TN-D and 6.35 PRO-B.

    DO NOT DOWNGRADE from 6.20. No reason to, and you can't on the Go anyways (to anything useful, at least).

    Just use TN-C or upgrade to 6.35 and use PRO-A. Check out their feature and see which you prefer.
     
  3. demonicstrife

    demonicstrife *INSERTGENERICTITLE*

    Member
    2
    May 22, 2008
    United States
    Somewhere in the middle
    There's a 6.20 TN-D and 6.35 PRO-B being worked on which are going to include POPS support, so you just have to be patient and wait for those.
     
  4. solidsnake13
    OP

    solidsnake13 Member

    Newcomer
    1
    Jun 23, 2009
    United States
    Thanks schlupi, that is what my research was showing me, but I just wanted a straight answer. I have decided to try out TN-C first and wait for TN-D I guess.

    Also, will the emulators work with TN-C?
     
  5. Jolan

    Jolan Unlimited Bear Works

    Member
    2
    Mar 20, 2010
    Netherlands, currently
    You don't need an emulator to play PSX games on the PSP, just popsloader support.
     
  6. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    6
    Jul 14, 2008
    You don't even NEED popsloader support, just the ability for the HEN to utilise pops.
     
  7. solidsnake13
    OP

    solidsnake13 Member

    Newcomer
    1
    Jun 23, 2009
    United States
    Sorry, I guess I should ahve specified, I actually meant the retro emulators (N64, Genesis, etc) not a PSX emulator.
     
  8. wrettcaughn

    wrettcaughn Misunderstood Moral Elitist

    Member
    7
    Mar 14, 2009
    United States
    You shouldn't have any problems running the emulators from the sticky if you're using 6.20 TN-C
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice