Confused about DSi XL behaviour

Discussion in 'NDS - Flashcarts and Accessories' started by Flicker, Mar 18, 2019.

  1. Flicker
    OP

    Flicker Member

    Newcomer
    1
    Mar 18, 2019
    Brazil
    Hello, everyone! :)

    So, I wanted to give both my nephews a DS. I got a really good deal on a used DSi XL, so I looked for another used DSi XL so both nephews would have the same version and there would be no fight. :P

    So I've got the two DSi XL here, I'll call one Blue and the other Black. Blue is on version 1.4.1U. Black is on version 1.4U.

    I have 3 different flashcarts here: R4iTT (came with Blue), R4i3d (came with the 3DS I bought for myself, a long time ago - never used it) and R4i drive (got it from a friend). Apparently they're all clones, and their website don't exist anymore.

    Thing is, all 3 work with Blue, but none of them work with Black. The message that appears is "An error has occurred. Press and hold the Power Button to turn the system off." etc etc.

    So, I'm not very knowledgeable with these things, but if they work on a DSi XL on version 1.4.1U, shouldn't they also work on another DSi XL with an older version (1.4U). Or am I failing to see something here?

    Thanks in advance for any insight you all might have.
     
    Last edited by Flicker, Mar 18, 2019
  2. maorninja

    maorninja GBAtemp Advanced Fan

    Member
    5
    Feb 7, 2016
    United States
    Do any other cartridges work on your other DSi?
     
  3. Flicker
    OP

    Flicker Member

    Newcomer
    1
    Mar 18, 2019
    Brazil
    Yes, it runs original games (tried a few of them).
     
  4. Flicker
    OP

    Flicker Member

    Newcomer
    1
    Mar 18, 2019
    Brazil
    Someone suggested to update the DSi, but that'll bring it to the latest version (1.4.5 I think). That would lower the chances of the carts to work, right? Especially since they're clones and I might not find updated kernels to them anymore.
     
  5. migles

    migles All my gbatemp friends are now mods, except for me

    Member
    14
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Sep 19, 2013
    China
    Earth-chan
    blue having the firmware higher, most likely there is a issue with the contacts...
    does not make sense the cards not working in a lower firmware version
     
    Flicker likes this.
  6. Flicker
    OP

    Flicker Member

    Newcomer
    1
    Mar 18, 2019
    Brazil
    Would they be listed on the main menu, though? By "not working", I mean when you run it, "An error has occurred" message appears. It's not like it's not detecting the cart. Also, original carts work without any problem. Any other clue? I'm really puzzled by this.

    I can take pictures/make videos if necessary.
     
  7. alexander1970

    alexander1970 GBAtemp Advanced Fan

    Member
    5
    Nov 8, 2018
    Austria
    Austria
    Hello.:)
    The "An error has occurred" when booting a flashcart means,that Nintendo had changed the firmware and tell them to block your card(s).In most cases its up to FW 1.4.5.
    You have a chance when you said your FW(s) are1.4.1 to get an NEWER kernel (thats some like the operating system for your Flashcart) for your Flashcart.Please don´t update the DSi(s) to 1.4.5 !!!
     
    Last edited by alexander1970, Mar 20, 2019
  8. Flicker
    OP

    Flicker Member

    Newcomer
    1
    Mar 18, 2019
    Brazil
    I figured as much, but what doesn't make sense is that an OLDER version is blocked, but not a newer. Can the firmware 1.4U on the DSi block the flashcarts, but not the firmware 1.4.1U?

    I'll make a video when I get home. Maybe I can't see something.
     
  9. migles

    migles All my gbatemp friends are now mods, except for me

    Member
    14
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Sep 19, 2013
    China
    Earth-chan
    takes like 30 seconds to read the thread dude
     
  10. Flicker
    OP

    Flicker Member

    Newcomer
    1
    Mar 18, 2019
    Brazil
  11. Kwyjor

    Kwyjor GBAtemp Fan

    Member
    4
    May 23, 2018
    Canada
    Feeling adventurous? Since you've got two units and an an abundance of flashcarts, I believe you should be able to start up HaxxStation on one DSi, and use that to send a flashcart launcher to the other DSi. At least that way you might be able to rule out any obvious hardware problems.
     
  12. Flicker
    OP

    Flicker Member

    Newcomer
    1
    Mar 18, 2019
    Brazil
    Just to make sure I understand. What it does is put the flashcart software in the storage, so I could run it directly from there without the need to use the flashcart ever again?
     
  13. Kwyjor

    Kwyjor GBAtemp Fan

    Member
    4
    May 23, 2018
    Canada
    Using HaxxStation on one DSi just lets you run a launcher from Download Play on the other DSi, and the launcher will bypass any protections that might be present in the firmware. Like I said, it's just for ruling out any obvious problems – it's not a very convenient way to regularly access the flashcart.

    You would need to install CFW to make any persistent changes – but since you have Flipnote Studio, that is an option if you want to use it.
     
  14. Flicker
    OP

    Flicker Member

    Newcomer
    1
    Mar 18, 2019
    Brazil
    Ok, so I don't need to make persistent changes. That's good. Less chance to screw things up. :P

    I'm not really sure what to do with the info from that HaxxStation post. Also, apparently, the link for the flashcart launcher is not working.
     
  15. Kwyjor

    Kwyjor GBAtemp Fan

    Member
    4
    May 23, 2018
    Canada
  16. alexander1970

    alexander1970 GBAtemp Advanced Fan

    Member
    5
    Nov 8, 2018
    Austria
    Austria
    Hello.:)

    I have the same card as you:
    flashcart.JPG


    It have the the YS Menu from

    https://gbatemp.net/threads/retrogamefan-updates-releases.267243/

    on it.And it don´t work on any of my DSis/XLs (all have FW 1.4.5E).Only the two who had CFW and TWiLightMenu on it.

    It´s odd that it works on lower FW.But as i said DON´T update the DSi XL because then you have 1.4.5 on it and the flashcart works definetly not with it.

    You can try an Firmware update for your flashcart (i don´t know if this is a good idea,maybe the cart won´t work no longer an both DSis XL).

    http://old.r4wood.com/pages/R4iTT-Kernel.html
    (please compare your card to confirm its 100% the same)

    You can follow the suggestion from @Kwyjor

    or you can put CFW and TWiLight on the second DSi XL (i don´t see in the video that he also have FLIPNOTE on it).If yes,this one unblocks your flashcart.:)
     
    Last edited by alexander1970, Mar 21, 2019
    larrypretty likes this.
  17. larrypretty

    larrypretty GBAtemp Fan

    Member
    3
    Oct 18, 2018
    United States
    Wow, such a old card, I haven't seen it years ,can it play games with good compatibility?
     
    alexander1970 likes this.
  18. Kwyjor

    Kwyjor GBAtemp Fan

    Member
    4
    May 23, 2018
    Canada
    I think anything at this point that can run YSMenu from RetroGameFan's update ought to have the same compatibility.
     
    alexander1970 likes this.
  19. alexander1970

    alexander1970 GBAtemp Advanced Fan

    Member
    5
    Nov 8, 2018
    Austria
    Austria
    Hello.:)
    Yes the cart works without any issues thanks to YSMenu.:bow:

    Yes,that make it possible..:grog:
     
    larrypretty likes this.
  20. Flicker
    OP

    Flicker Member

    Newcomer
    1
    Mar 18, 2019
    Brazil
    I was able to install Hiya CFW + TWiLight++ Menu on it, and now I can run stuff from the SD Card. Thanks, people. :)
     
    alexander1970 likes this.
Loading...