Can't launch FBI through ReiNand

Discussion in '3DS - Flashcards & Custom Firmwares' started by Godamit, Jul 21, 2016.

  1. Godamit
    OP

    Godamit GBAtemp Regular

    Member
    134
    2
    May 5, 2009
    Hi guys,

    I have been following this guide in order to get my n3DS XL (from firmware 10.3.0-28E) hacked: https://www.reddit.com/r/3dshacks/comments/3ztqqv/all_you_need_to_know_by_popular_demand/

    I have managed to reach the section labelled "Direct Homebrew Installed to Homemenu/Eshop on Old Firmware/Unrestricted Piracy" where I am now attempting to install the FBI CIA file under the step "2) Installing FBI".

    My issue is that while running browserhax from reinand, FBI simply won't launch from the homebrew menu, I am just stuck on a blank screen. However, when I boot into the homebrew menu from my sysNand, I am able to launch FBI just fine.

    I am using both the latest version of ReiNand (4.1) and FBI.

    Does anyone know what's going wrong?

    I have tried to follow the alternative steps provided at this point, but unfortunately I am having no luck getting the files for injection created.
    I have attempted to use Universal Inject Generator (found here: https://gbatemp.net/threads/release-inject-any-app-into-health-safety-o3ds-n3ds-cfw-only.402236/) but unfortunately the go.bat script does not seem to function correctly for me. I am copying both my hs.app and FBI.cia files into the "input" folder, but the script still tells me it cannot find hs.app.

    Thanks for any help.
     
    Last edited by Godamit, Jul 21, 2016
  2. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    Follow this one instead from step 1 if you don't have an emunand yet.
    If you do, replace reinand for the newest luma3ds release.
    Also, is your sysnand 9.2?
     
  3. Godamit
    OP

    Godamit GBAtemp Regular

    Member
    134
    2
    May 5, 2009
    Thanks for the response. I have already setup my emunand, and yes, I have managed to downgrade successfully with my sysNand now on 9.2.0-20E.

    I'll try my luck with Luma3DS.

    Though your linked guide seems to be more efficient than what I was using. Is it too late for me to remove my emunand and start over, or would this be possible?

    EDIT: While I would prefer to change the exploit used to your suggestion, I have now managed to setup Luma3DS and I've installed the FBI cia. Everything seems to be ok, but I am unable to coldboot into emuNand... Is there a specific solution for getting this working somewhere?
     
    Last edited by Godamit, Jul 22, 2016
  4. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    Have you unlinked your nands?
     
  5. Godamit
    OP

    Godamit GBAtemp Regular

    Member
    134
    2
    May 5, 2009
    Just updating that I wound up restarting the whole process, and started from the beginning following your linked guide to completion. Everything is now working fine. Thank you very much for your responses!