Bricked TWL_FIRM - Restoring from 3DNUS has no effect

Discussion in '3DS - Flashcards & Custom Firmwares' started by gameking66, Mar 4, 2016.

  1. gameking66
    OP

    gameking66 GBAtemp Advanced Fan

    Member
    3
    Mar 9, 2010
    United States
    So after installing the whitelist patch and recent twlfirm_o3ds file I seem to have no luck booting DS mode anymore. I installed them onto SysNAND. I am running A9LH w/AuReiNAND.

    Both my DS Flash Cart and DS Download Play simply go to a black screen and stay there.

    I've tried the following to fix it to no avail:
    - Restore multiple versions of title 0004013800000102 (even restored the White List title 0004800F484E4841)
    - Restored a (as far as I can tell) clean TWLP/TWLN partition from an older NAND dump (restored it to EmuNAND -> pulled the TWLP/TWLN -> inject them into SysNAND)

    I'm still booting to a black screen. Any fix for this or a way to find out what exactly is screwed?
     
    Last edited by gameking66, Mar 4, 2016
  2. zoogie

    zoogie playing around in the dsiware

    Member
    19
    Nov 30, 2014
    Micronesia, Federated States of
    Restore a complete NAND dump.
     
  3. JacksonS

    JacksonS GBAtemp Fan

    Member
    2
    Feb 13, 2016
    United States
    Georgia
    Have you tried running DS games without your SD card inserted? I mean, that should have no effect, but it sounds like you've tried every relevant thing.
     
  4. gameking66
    OP

    gameking66 GBAtemp Advanced Fan

    Member
    3
    Mar 9, 2010
    United States
    I don't have one where I can verify the DS partition is working. The earliest one I have is a totally clean system and I have too much installed to throw that into SysNAND (a9lh, bunch of backups, etc).

    I only have a DS Flash Cart and Download Play to test with. No actual DS games. Both the flash cart and Download Play boot to black screen and stay there.

    — Posts automatically merged - Please don't double post! —

    Tried restoring title 00048005484E4441v1024 which is specifically the Download Play application - no change.
     
  5. JacksonS

    JacksonS GBAtemp Fan

    Member
    2
    Feb 13, 2016
    United States
    Georgia
    There are ways to backup games, saves, and everything else, so you could still do that.
     
  6. gameking66
    OP

    gameking66 GBAtemp Advanced Fan

    Member
    3
    Mar 9, 2010
    United States
    Okay so I am now getting "An Error has Occurred" when launching my flash cart - but DS Download Play still black screens.
    I'd rather not risk bricking SysNAND over DS games.

    What could possibly cause TWL not to boot if I have the proper TWL_FIRM restored from 3DNUS?
     
  7. JacksonS

    JacksonS GBAtemp Fan

    Member
    2
    Feb 13, 2016
    United States
    Georgia
    I'm referring to restoring your original sysNAND backup, which shouldn't run any risk of bricking. I have no idea why the original TWL_FIRM wouldn't be working for you, but I can suggest using BigBlueMenu to install it because that's what worked for me.
     
  8. gameking66
    OP

    gameking66 GBAtemp Advanced Fan

    Member
    3
    Mar 9, 2010
    United States
    Okay, I managed to get *SOMEWHERE*...

    So restoring an old sysNAND backup to emuNAND, then booting into emuNAND successfully boots Download Play AND the flash cart!

    Which means that something CTR related is at play here (because the 3DS reboots before going into TWL right?), but as far as I can tell everything is in place - the Whitelist wouldn't affect Download Play from launching, and if Download Play was broken the cart would still work.

    What gives? What part of the CTR would cause this behavior?
     
  9. JacksonS

    JacksonS GBAtemp Fan

    Member
    2
    Feb 13, 2016
    United States
    Georgia
    I'm pretty sure it only reboots when you exit DS mode. As for why restoring the CTR partition works, I have no clue.
     
  10. MarcusD

    MarcusD WOODMILLS!

    Member
    8
    Oct 16, 2015
    Austria
    Europe
    Have you tried going into DS profile? Your problem sounds like when I bricked my DS mode with the old DS profile exploit.

    I would suggess just letting REI boot automatically into EmuNAND without any button press, and repair DS mode there, since you can boot DS mode from EmuNAND with REI.
    You may want to uninstall TWL_FIRM and the DS cart whitelist with FBI, and get some .cias from "that ISO site" ("Proper Old DS Cart Enable") along with BigBlueMenu, and install TWL_FIRM_2.0 and DS_Whitelist_v0, and check your DS profile in the system settings, and if it doesn't freeze, it should fix itself, and try launching a DS application again.
     
  11. gameking66
    OP

    gameking66 GBAtemp Advanced Fan

    Member
    3
    Mar 9, 2010
    United States
    DS Profile works fine through the 3DS system settings ("Nintendo DS Profile" -> Message/Color options).

    Restoring TWL_FIRM and the whitelist stuff are both things I've already tried, as I stated above.

    DS Mode works ONLY in EmuNAND at this point, and I've tried updating AuReiNAND to see if that would fix it but it had no effect.
     
  12. Sir BLaDE

    Sir BLaDE GBAtemp Regular

    Member
    2
    Feb 22, 2016
    I already had that trouble, installing flashcardtimewarp.cia in sysnand fix it
     
  13. gameking66
    OP

    gameking66 GBAtemp Advanced Fan

    Member
    3
    Mar 9, 2010
    United States
    Nope. That's just the nulled blacklist.
     
    Last edited by gameking66, Mar 4, 2016
  14. gameking66
    OP

    gameking66 GBAtemp Advanced Fan

    Member
    3
    Mar 9, 2010
    United States
    $10 BTC bounty to whoever can help me solve this (preferably without restoring any backups as that would wipe all my games that I don't have copies of anymore since the issue appears to be in CTRNAND).
     
  15. GhostLatte

    GhostLatte Yet Another Shitposter

    Member
    13
    Mar 26, 2015
    Antarctica
    I'm pretty sure the only way to fix this is through a NAND restore. What version is your emuNAND dump on?
     
  16. Nimrod-002

    Nimrod-002 GBAtemp Regular

    Member
    1
    Dec 8, 2016
    Morocco
    i have a 9.2 emunand backup , can i restore that on 11.2 sysnand, and would that effect the games and saves i have on sd?
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice