bootmii does not open on boot

Discussion in 'Wii - Hacking' started by MrBananaMan, Jul 17, 2016.

  1. MrBananaMan
    OP

    MrBananaMan Advanced Member

    Newcomer
    69
    58
    Feb 15, 2016
    United States
    California
    EDIT: apparently messing with the autoboot fixed it and the menu now displays fine, no idea how it worked but my problem is solved

    yes, I am using boot2 version of bootmii

    i went through the install of hbc+bootmii and when i used the installer to open bootmii so i could backup my nand it worked fine. however, when i boot my wii with the sd card in it just goes to a black screen instead of bootmii, and i have to take out my sd card so the wii goes to the sysmenu and doesn't try to open bootmii. bootmii works fine when opening from the homebrew channel, however. anyone know how i can get my wii to launch bootmii during the boot process?
     
    Last edited by MrBananaMan, Jul 19, 2016
  2. InvoxiPlayGames

    InvoxiPlayGames Member

    Newcomer
    14
    0
    Jan 22, 2016
    Rinse and reinstall, make sure to uninstall it from IOS too, and reinstall both.
     
  3. MrBananaMan
    OP

    MrBananaMan Advanced Member

    Newcomer
    69
    58
    Feb 15, 2016
    United States
    California
    it was a fresh install, and the previous install was doing the same thing too. i only have it installed to boot2, not ios
     
  4. InvoxiPlayGames

    InvoxiPlayGames Member

    Newcomer
    14
    0
    Jan 22, 2016
    You can only launch BootMii from the HBC with it installed as IOS.
     
  5. MrBananaMan
    OP

    MrBananaMan Advanced Member

    Newcomer
    69
    58
    Feb 15, 2016
    United States
    California
    that's weird, i thought i only installed it as boot2, ill run homebrew installer again and see
     
  6. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,696
    8,298
    Oct 27, 2002
    France
    Engine room, learning
    It could be an issue with the SD files version. for example, if you set your "autoboot" in the bootmii config to "HBC".
    Be sure to run the "prepare SD card" menu from the same hackmii installer you used to install HBC.
    If you use old bootmii files on your SD card with a new HBC version (or vice versa), the TitleID for HBC will be different than what bootmii knows and will not find it.

    Check your config file in bootmii folder too, you can change the timeout and the title loaded at bootmii exit. if you set the timeout to 0 it will autoboot and you won't see bootmii menu at all.
     
  7. MrBananaMan
    OP

    MrBananaMan Advanced Member

    Newcomer
    69
    58
    Feb 15, 2016
    United States
    California
    I Uninstalled and reinstalled both but it blackscreens with the SD card in. Disk drive flashes like boot mii is installed too
     
  8. InvoxiPlayGames

    InvoxiPlayGames Member

    Newcomer
    14
    0
    Jan 22, 2016
    What video mode is your TV set to and your Wii outputting to? It may help if you use A/V cables set to 480i 60Hz and make sure your TV supports it. Also may need to change your BootMii config file to a different value (as i said, 480i 60Hz)
     
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,696
    8,298
    Oct 27, 2002
    France
    Engine room, learning
    Does it work if you edit the bootmii config file and set the delay to 0?
    for example, set to autoboot (delay=0) to HBC.
    If HBC works, then you know bootmii actually works as it exited and redirected to HBC successfully.
    if you set a value, does it "blackscreen" until the delay expires or freeze indefinitely ?

    in the bootmii config file there's also a video setting, be sure it matches your current setup.
    try another SD card maybe. Be sure it's FAT32.
     
  10. MrBananaMan
    OP

    MrBananaMan Advanced Member

    Newcomer
    69
    58
    Feb 15, 2016
    United States
    California
    I'm on FAT32, and setting delay to 0 and autoboot to hbc opens the hbc fine, setting the value to 5 makes the bootmii menu actually appear with 5 dots below hbc until it opens. now trying again with autoboot off makes the bootmii menu appear again. I have no idea how messing with the autoboot fixed it, but my problem is solved.
     
    Cyan likes this.
  11. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,696
    8,298
    Oct 27, 2002
    France
    Engine room, learning
    Nice to see it's fixed. maybe there were a problem in the config file.

    there's a homebrew to edit the bootmii config file, it's useful to change the autoboot option without removing the SD card and using a computer.
    http://wiibrew.org/wiki/BootMii_Configuration_Editor
     
    MrBananaMan likes this.