Bizarre Official update gone wrong.

Discussion in '3DS - Flashcards & Custom Firmwares' started by SketchyPixel, Nov 1, 2016.

  1. SketchyPixel
    OP

    SketchyPixel Ignore what I say

    Member
    348
    134
    Jul 4, 2016
    Korea, North
    Idk, a Black Hole maybe?
    So I bought this o3ds from a friend today, and turning it on and checking the FW raised some red flags. My friend knows absolutely nothing about 3ds exploits. He never exploited this or anything. Completely stock. And well... here are some pictures, what should I do?
    Warning: Spoilers inside!
     
    Last edited by SketchyPixel, Nov 1, 2016
  2. Boogieboo6

    Boogieboo6 @realDonaldTrump

    Member
    957
    1,310
    Jul 30, 2015
    United States
    Is it a franken-firmware? If so, I think the only thing to do is update it and then DsiWare downgrade it.
     
    Last edited by Boogieboo6, Nov 1, 2016
  3. dragon_from_iso

    dragon_from_iso GBAtemp Regular

    Member
    122
    64
    Dec 24, 2011
  4. Exavold

    Exavold lol

    Member
    1,004
    1,061
    Nov 9, 2015
    France
    lol
    Can you run browserhax ?

    (btw , that's a frankenfirmware)
     
  5. SketchyPixel
    OP

    SketchyPixel Ignore what I say

    Member
    348
    134
    Jul 4, 2016
    Korea, North
    Idk, a Black Hole maybe?
    I guess, but this system was 100% stock. No mods.
     
  6. Hking0036

    Hking0036 GBAtemp Fan

    Member
    403
    194
    Sep 15, 2015
    United States
    has to be because it has theme menu on <9.0.

    Do a downgrade/ctrnand transfer if you can and it'll be normal again, not a huge problem.

    Is your friend the original owner?
     
    Arkansaw likes this.
  7. SketchyPixel
    OP

    SketchyPixel Ignore what I say

    Member
    348
    134
    Jul 4, 2016
    Korea, North
    Idk, a Black Hole maybe?
    I think so.
     
  8. Boogieboo6

    Boogieboo6 @realDonaldTrump

    Member
    957
    1,310
    Jul 30, 2015
    United States
    I thought if you tried downgrading a frankenfirmware, that only worsened the problem. I'm probably wrong though.
     
  9. Hking0036

    Hking0036 GBAtemp Fan

    Member
    403
    194
    Sep 15, 2015
    United States
    There's no real explanation, it has to have been downgraded to have the theme menu on anything less than 9.0. the browser version is wrong too, it should be -17 not -10. My bet is it has a downgraded browser (and presumably settings) for MSET (4.5.0-10), but that doesn't explain the theme menu (9.0.0-20) being there, or the amiibo options (9.6.0-24), or even why the system settings is showing 7.x.x because as far as I know there's nothing interesting that goes on there. Whoever's that was really did it up for you.

    if you downgrade again, it'll only change the titles it missed the first time around. Either way, it cleans up the rest of it. Frankenfirmwares just make it a little weird to get into the browser sometimes if I recall.
     
    Last edited by Hking0036, Nov 1, 2016
    Boogieboo6 likes this.
  10. gnmmarechal

    gnmmarechal Kirigiri > Naoto

    Member
    GBAtemp Patron
    gnmmarechal is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,771
    2,903
    Jul 13, 2014
    Portugal
    https://gs2012.xyz
    depends on how screwed up the frankenfirm is. I mean, I've used a frankenfirmware as a daily driver before I had CFW so that I could continue to go online on purpose. Back then, my /r/3dshacks flair was "Proud FrankenFirmware User". Some frankenfirmwares can make the system unable to boot, some screw one app, some screw the browser.... frankenfirmware is any firmware with a mix of titles from different versions, I suppose. Anything can be wrong if you don't know which titles are wrong.
     
  11. Tenshi_Okami

    Tenshi_Okami GBAtemp Maniac

    Member
    1,405
    580
    Nov 3, 2015
    Puerto Rico
    Most probably is a Franken-firmware made by a half update. He can try to run Decrypt9, if it does not boot, then try Browserhax :)

    Better yet. On the Browser go to the settings and try to find the Browser version. Post it in here to see what browser does it have!
     
    Last edited by Tenshi_Okami, Nov 1, 2016
  12. SketchyPixel
    OP

    SketchyPixel Ignore what I say

    Member
    348
    134
    Jul 4, 2016
    Korea, North
    Idk, a Black Hole maybe?
    So I tried browser has with no luck. Connects to WiFi fine outside of browser. opening browser greets me with the, "You must accept user agreement"-blah blah blah screen twice, once the browser opens it tries to connect to the last page I opened, and fails because it disconnected from WiFi. I've tried re-configuring my WiFi, clearing browser save data, and other stuff. But nothing works.
    BTW:Agreement screen shows up twice EVERY time i open the browser.
     
  13. Tenshi_Okami

    Tenshi_Okami GBAtemp Maniac

    Member
    1,405
    580
    Nov 3, 2015
    Puerto Rico
    Uh, maybe its trying to open 2 browsers? This is really weird now. Only way i can see out from this is trying to install Ninjhax 1 since it does not need a browser(Hoping that the update wasnt pass 9.2)...
     
  14. SketchyPixel
    OP

    SketchyPixel Ignore what I say

    Member
    348
    134
    Jul 4, 2016
    Korea, North
    Idk, a Black Hole maybe?
    Can't get on Ninjhax 1 website, link?
     
  15. Hking0036

    Hking0036 GBAtemp Fan

    Member
    403
    194
    Sep 15, 2015
    United States
    since they have a -10 browser they might have downgraded settings too, and then they should be able to use MSET to load decrypt9 and do an update that way. Worth a shot, at least.

    do you have cubic ninja or a DS flash cart?
     
  16. SketchyPixel
    OP

    SketchyPixel Ignore what I say

    Member
    348
    134
    Jul 4, 2016
    Korea, North
    Idk, a Black Hole maybe?
    Cubic Ninja, yep.
     
  17. Tenshi_Okami

    Tenshi_Okami GBAtemp Maniac

    Member
    1,405
    580
    Nov 3, 2015
    Puerto Rico
  18. SketchyPixel
    OP

    SketchyPixel Ignore what I say

    Member
    348
    134
    Jul 4, 2016
    Korea, North
    Idk, a Black Hole maybe?
  19. Hking0036

    Hking0036 GBAtemp Fan

    Member
    403
    194
    Sep 15, 2015
    United States
    maybe you could try ocarina of time 3D, but I'm not entirely convinced you can open the homebrew launcher at all. I think the best bet is a DS flash cart for right now, but I'm beginning to see why this was up for sale :toot:
     
  20. SketchyPixel
    OP

    SketchyPixel Ignore what I say

    Member
    348
    134
    Jul 4, 2016
    Korea, North
    Idk, a Black Hole maybe?
    I actually do have a Ds flashcart. What do I do with it, does it have to be a specific kind? it's some kind of of r4 clone.