1. hekatmosphere.png

    It's here! @SciresM and the rest of his team have just released a new version of Atmosphère, their popular free and open-source Switch CFW.

    Version 0.9.4's main highlight is full OFW 9.0.0 support, both for SysMMC and EmuMMC. However, if you plan on updating, there are a few important things to keep in mind. First off, Nintendo's latest firmware changed how HID works, which breaks libnx button input detection. This has been addressed in newer versions of the library, but will require homebrew to be recompiled in order for it to be fixed properly. As such, a temporary measure has been put in place to make old homebrew detect input properly while developers recompile their apps, but this will be removed in later releases as it could introduce further issues with HID MITM. Be sure to update everything you use when new versions pop up!

    Secondly, the game card ASIC has also been updated in 9.0.0, which will cause the GC slot to stop working if you downgrade or run an earlier firmware in EmuMMC until you update. To prevent this, Atmosphère will now apply the nogc patch automatically if you boot into 9.0.0 on consoles with a lower fuse count. You can force disable this if you wish by setting nogc = 0 in BCT.ini.

    Finally, USB cannot be IPS patched or MITM'd correctly due to some initialization changes, but a solution is currently being looked into.

    There are also some general fixes and improvements, including correct BIS key generation for newer unpatched units and hbl 2.2 + hbmenu 3.1.1. You can read the full changelog below:
    @CTCaer's Hekate mod has also been updated, and full 9.0.0 support here is just the beginning! Version 5.0.2 adds a forced autoboot via ID key option, which will prove particularly useful with Android and Linux distros - and staying on topic, CPU/GPU warmboot reboot has been fixed for said OSes as well. A bug that made SaltyNX hang under 8.X.X EmuMMC has also been fixed, so apps and mods that depend on it (such as ReverseNX) will now work properly again. The nogc patch will be applied automatically when running pre-9.0.0 firmware in EmuMMC on a console with a higher fuse count: this is different than the previously described Atmosphère autonogc feature as this is an error prevention measure, while AMS' own tries to avoid game card slot ASIC updates.

    Hekate Nyx has also some new goodies, such as archive bit support for EmuMMC folders and proper AutoRCM detection after restoring an eMMC backup. The version included in this release is 0.8.2.

    Several other bugs and smaller issues have been fixed, all of which are listed in the changelog below:
    If you are a homebrew developer and wish to fix the broken button input issue found in 9.0.0, you can use dkp-pacman to update libnx to its latest version.

    UPDATE: A bug affecting games with vibration support has been found and a hotfix has been released. Please redownload Atmosphère if this affects you.

    :arrow: Atmosphère: Source / GBAtemp Thread
    :arrow: Hekate CTCaer: Source / GBAtemp Thread
     
  2. Discussion (126 replies)

  3. NoNAND

    NoNAND Give me back my legions!
    Member

    Joined:
    Aug 22, 2015
    Messages:
    2,152
    Country:
    Albania
    At last. I hope this will relieve the grief and sorrow of those who updated to 9.0.0.
    There's hope now folks...assuming you didn't get mad and break your switch after the update.
     
    Last edited by NoNAND, Sep 14, 2019
  4. TamarindoJuice

    TamarindoJuice GBAtemp Regular
    Member

    Joined:
    Jan 30, 2016
    Messages:
    264
    Country:
    Brazil
    USB cannot be IPS patched or MITM'd correctly due to some initialization changes, but a solution is currently being looked into.

    Can we still using tinfoil/goldleaf USB solutions to instal NSPs?
     
    NoNAND likes this.
  5. x65943

    x65943 Dr. Rabbi Prince X, Sr., Ed. D.
    Global Moderator

    Joined:
    Jun 23, 2014
    Messages:
    4,778
    Country:
    United States
    Quick work SciresM

    I expect a new SXOS version any time now :9
     
  6. Reynardine

    Reynardine The Villagefox
    Member

    Joined:
    Aug 14, 2018
    Messages:
    448
    Country:
    Germany
    Hey, that's great news!
     
    NoNAND likes this.
  7. NoNAND

    NoNAND Give me back my legions!
    Member

    Joined:
    Aug 22, 2015
    Messages:
    2,152
    Country:
    Albania
    Soon™
    ~Team Xecutor stealing code from 2019 and beyond, and getting sued by Nintendo~
    jk jk
     
    Last edited by NoNAND, Sep 14, 2019
  8. XorTroll

    XorTroll Tired of classic HOME menu
    Developer

    Joined:
    Dec 28, 2017
    Messages:
    635
    Country:
    Spain
    Patches for NSP installs are just FS and ES, so if I'm correct nothing has changed regarding installs (never heard of USB patches anyway...?)
     
  9. PikachuPrincess23

    PikachuPrincess23 GBAtemp Advanced Fan
    Member

    Joined:
    Jun 22, 2015
    Messages:
    740
    Country:
    Norway
    Finnaly, it was about time:)
    Now i can enjoy new DLC of Fire Emblem Tree House.
     
    NoNAND likes this.
  10. NoNAND

    NoNAND Give me back my legions!
    Member

    Joined:
    Aug 22, 2015
    Messages:
    2,152
    Country:
    Albania
    Did that crash the system on 8.1.0 all the time or only on some occasions?
     
  11. Deleted User

    Deleted User Newbie

    You mean like how SXOS released 8.1 support before Atmo?

    I get it tho. lol XD steals codes XD
     
  12. mathew77

    mathew77 Lovin' life.
    Member

    Joined:
    Jan 19, 2019
    Messages:
    597
    Country:
    Kazakhstan
    Good news!..

    By the way, where one can find fw 9.0.0 zip for the choidujournx?.. Or it's a copyrighted matter?..
     
  13. OneAngryGamer

    OneAngryGamer Banned
    Banned

    Joined:
    Aug 19, 2019
    Messages:
    87
    Country:
    United States
    No. The DLC Pack seems to be the same one that posted earlier when the game came out. That means only Pack 1 (Officers Academy Uniform) is there, and the rest are placeholders. Look at the file size. The new DLC is no where to be found yet. Only the 1.0.2 Patch.
     
    mathew77 likes this.
  14. Robmane77

    Robmane77 Member
    Newcomer

    Joined:
    Sep 14, 2019
    Messages:
    19
    Country:
    United States
    Hey guys question I have atmosphere what do I use to update to 9.0 fw do I use the Nintendo update or the choidurnyx?? Please let me know

    Thanks
     
  15. OneAngryGamer

    OneAngryGamer Banned
    Banned

    Joined:
    Aug 19, 2019
    Messages:
    87
    Country:
    United States
    I have a question as well, my CFW is 8.1.0 and Atmosphere 0.9.3. Do I need to update my stuff to 9.0.0 and get 0.9.4 Atmosphere in order for future games to run smoothly or not?
     
  16. smf

    smf GBAtemp Psycho!
    Member

    Joined:
    Feb 23, 2009
    Messages:
    4,735
    Country:
    United Kingdom
    If you want to play a game that needs 9.0.0, yes

    https://twitter.com/NintendoAmerica/status/1171128737573662720

    We are aware that some users who recently purchased the Expansion Pass for Fire Emblem: Three Houses are unable to start the game. A system update will be available later today to fix this. We apologize for the inconvenience.
     
    Last edited by smf, Sep 14, 2019
  17. Mythical

    Mythical GBAtemp Addict
    Member

    Joined:
    May 11, 2017
    Messages:
    2,048
    Country:
    United States
    this is great because last night I updated my switch like a fool :rofl2:
     
  18. OneAngryGamer

    OneAngryGamer Banned
    Banned

    Joined:
    Aug 19, 2019
    Messages:
    87
    Country:
    United States
    Sucks. Here I thought keeping the lowest FirmWare was the way to go.
     
  19. gbablackrain

    gbablackrain Member
    Newcomer

    Joined:
    Aug 18, 2017
    Messages:
    23
    Country:
    United States
    First time Atmos beat SX OS in speed. :lol:
     
  20. Mythical

    Mythical GBAtemp Addict
    Member

    Joined:
    May 11, 2017
    Messages:
    2,048
    Country:
    United States
    um what?
    also usually but you need master keys for each firmware level basically so to play any 5.x game you need 5.0 or higher, same with 6.x games needing 6.0 or higher keys
     
  21. OneAngryGamer

    OneAngryGamer Banned
    Banned

    Joined:
    Aug 19, 2019
    Messages:
    87
    Country:
    United States
    Makes sense, though some of my games don't work now. Some do. What gives?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Atmosphère, released, Hekate