anytitle deleter gives es_identify error ret=-1017

Discussion in 'Wii - Hacking' started by Kevin578, Nov 15, 2009.

  1. Kevin578
    OP

    Member Kevin578 GBAtemp Regular

    Joined:
    Nov 13, 2006
    Messages:
    114
    Location:
    USA
    Country:
    United States
    after updating a few ios versions with dop-ios, anytitle deleter now gives the es_identify error ret=-1017 upon startup. afterwards, it seems to load correctly. i heard downgrading ios36 would fix the error, but when trying to downgrade, it gives me another error. how can i fix this?
     


  2. Kevin578
    OP

    Member Kevin578 GBAtemp Regular

    Joined:
    Nov 13, 2006
    Messages:
    114
    Location:
    USA
    Country:
    United States
    would es_identify patching ios36 fix this error?
     
  3. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    ES_Idenitfy patching could help, maybe not. For me for example it works, for others it's reported that the 2nd ES_Idenitfy fails with a patched IOS.

    Anyways, you want AnyTitle Deleter? How about using AnyTitler Delter mod that allows which IOS to use. And just use an IOS that works for it. The cIOS for example works for ATD mod, but also a fully patched IOS36 you can install with Trucha Bug Restorer.

    A downgrade of IOS36 would help, but i won't tell what's required for it, as a downgrade of higher IOS does not work on new Wiis. (IOS15 downgrade does)

    Also, if you want a patched IOS36, but get the upside-down HBC issue, install the latest unpatched IOS61 and reinstall the HBC.
     
  4. Kevin578
    OP

    Member Kevin578 GBAtemp Regular

    Joined:
    Nov 13, 2006
    Messages:
    114
    Location:
    USA
    Country:
    United States
    i tried using any title delter mod but no matter which ios i cohse to load, it gives me the same ret=-1017 and then seems to load properly.
     
  5. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada

    this happens 2 me to, after getting the error, u just need to hit any button twice to get past the error and it should load up fine
     
  6. Kevin578
    OP

    Member Kevin578 GBAtemp Regular

    Joined:
    Nov 13, 2006
    Messages:
    114
    Location:
    USA
    Country:
    United States
    right, it's kind of annoying to see that error message all the time, but my main concern is that I can't install/update any ios as it leads the the ret=-1017 error too,
     
  7. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    huh? that made no sense to me. Any title deleter does not install/update IOSs.... r u having more than 1 problem here?
     
  8. Kevin578
    OP

    Member Kevin578 GBAtemp Regular

    Joined:
    Nov 13, 2006
    Messages:
    114
    Location:
    USA
    Country:
    United States
    oh sorry, i meant installing IOSs through dop-ios or using anytitle deleter results in an error
     
  9. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    ok, like i said, the error in any title deleter probably means nothings, just press any button to get past it (i think home exits the apps even at this point)

    if u are using dop ios and getting an error i suspect your CIOS 249 wasn't installed properly. U can try using dop ios mod and load a different ios, but u should still fix your IOS249, as this is very widely used.
     
  10. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
  11. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    I get this error with any title deleter db, and i know i have the trucha bug in IOS 36 and 249 for a fact. I can also confirm that after this error, the app runs just as it is supposed to (ie. it successfully deletes whatever i tell it to)
     
  12. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    oh on ATD thats a different story.

    I think it has something to do with NAND permissions

    but the app will still work fine like you said.
     
  13. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    That's why i said AnyTitle Detler mod, that takes advantage from the nand permissions and only uses one ES_Identify. Using it 2 times(like original ATD does) seems to only work properly with the old IOS36.
     
  14. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    so you recommend using any title deleter mod why? Besides an annoying error msg, whats wrong with any title deleter db? And if using any title deleter mod, u recommend we use an IOS that has the trucha bug and the ES_Identify bug (and nand permissions?)? So probably IOS36 for most of us right?

    EDIT:nvm, I'll just keep using any title deleter DB (if it aint broke, dont fix it right?)
     
  15. Kevin578
    OP

    Member Kevin578 GBAtemp Regular

    Joined:
    Nov 13, 2006
    Messages:
    114
    Location:
    USA
    Country:
    United States
    ok, i successfully restored the trucha bug again (thanks for the help btw), but when loading anytitle deleter mod, it still loads with a ret=-1017 error and then proceeds to load correctly. I'm pretty sure ios36 is trucha patched.

    edit: ios36 should also have the es_identify patch too
     
  16. Kevin578
    OP

    Member Kevin578 GBAtemp Regular

    Joined:
    Nov 13, 2006
    Messages:
    114
    Location:
    USA
    Country:
    United States
    after searching around, is it possible that the latest ios36 produces this error in anytitle deleter mod, and I should downgrade the ios?
     
  17. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Did you try a cIOS or a FULLY patched IOS36 from Trucha Bug Restorer? For me that even works in the original AnyTitle Delter which is strange. But ATD mod should really work with it.

    Downgrade is not an option, because IOS36 downgrade does not work on half the Wiis.
     
  18. Kevin578
    OP

    Member Kevin578 GBAtemp Regular

    Joined:
    Nov 13, 2006
    Messages:
    114
    Location:
    USA
    Country:
    United States
    I'm pretty sure my ios36 is fully patched, there's only the es_identify and the trucha bug right? However, my ios36 is updated so is it possible that anytitle deleter/ anytitle deleter mod displays the error message if your ios36 isn't v1042?
     
  19. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    I said FULLY patched IOS36 from Trucha Bug Restorer.
     
  20. Kevin578
    OP

    Member Kevin578 GBAtemp Regular

    Joined:
    Nov 13, 2006
    Messages:
    114
    Location:
    USA
    Country:
    United States
    when fixing the trucha bug, I followed the guide here. I remember TBR giving 3 patch options, and I said yes to all of them. is there more to patch besides those three?

    edit: after using tbr 1.1 and enabling all 3 options, and then running atd mod; it seems to load with an error, but then goes on to load correctly very fast that I can't read the message (I'm not sure if its an error, but I don't remember seeing that before updating ios36) previously, I had to press "a" a few times to get atd mod to load.
     

Share This Page