Any ideas whats gone wrong with this Wii?

Discussion in 'Wii - Hardware, Devices and Utilities' started by DarkMario616, Jul 10, 2013.

  1. DarkMario616
    OP

    DarkMario616 GBAtemp Advanced Fan

    Member
    2
    Mar 19, 2008
    United States
    New York
    Sister has a Wii. It's not modded and never has been (although I tried convincing her way back when :P)

    Anyways, I updated it a few days ago and downloaded Netflix, they wanted to use it for that.

    A few days later of netflix watching, they try turning the Wii on and BOOM. Black screen.

    No audio, no video. Green LED on and blue illuminated disc slot.

    What gives? This wii was BARELY used.
     
  2. Speedster

    Speedster Hack ALL THE THINGS

    Member
    2
    Apr 13, 2013
    United States
    It may be a power problem. Try unplugging the power cord on both ends and the other cables on the Wii and leave it for a while, then try it again.
     
  3. DarkMario616
    OP

    DarkMario616 GBAtemp Advanced Fan

    Member
    2
    Mar 19, 2008
    United States
    New York
    Sure, I'll try that, although I think I might have already <_<
     
  4. natkoden

    natkoden Not a New Member

    Member
    4
    Jul 25, 2006
    Argentina
    It's the second time I hear that a Wii died after using netflix and restarting it.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice