Animated Boot Screen for Nintendo 3DS

Discussion in '3DS - Flashcards & Custom Firmwares' started by martinjamesccorpuz, Apr 29, 2017.

  1. martinjamesccorpuz
    OP

    martinjamesccorpuz Member

    Newcomer
    49
    0
    Aug 13, 2016
    Can you guys help me with this? I wanted to have an animated boot screen but if I move the a9lh.bin to the anim folder I'd be getting the my ds to not turn on. what and how should I do it?
     
  2. Dude1452

    Dude1452 Advanced Member

    Newcomer
    56
    14
    Oct 7, 2016
    Canada
    can we see what's at the root of your sd card?
     
  3. martinjamesccorpuz
    OP

    martinjamesccorpuz Member

    Newcomer
    49
    0
    Aug 13, 2016
    oh i cant at the moment :(
     
  4. martinjamesccorpuz
    OP

    martinjamesccorpuz Member

    Newcomer
    49
    0
    Aug 13, 2016
    Last edited by martinjamesccorpuz, Apr 29, 2017
  5. Dude1452

    Dude1452 Advanced Member

    Newcomer
    56
    14
    Oct 7, 2016
    Canada
    rename the "arm9loaderhax.bin" to "arm9loaderhax_si.bin" that should fix your problem
     
  6. martinjamesccorpuz
    OP

    martinjamesccorpuz Member

    Newcomer
    49
    0
    Aug 13, 2016
    then which one should i put in anim folder?
     
  7. Dude1452

    Dude1452 Advanced Member

    Newcomer
    56
    14
    Oct 7, 2016
    Canada
    the arm9 that plays the animation should be at the root, and the arm9 that launches Luma should be in the "anim" folder renamed as "arm9payload.bin"
     
  8. lonewolf08

    lonewolf08 GBAtemp Fan

    Member
    416
    134
    Feb 4, 2016
    United States
    If that doesn't work you will need to update your a9lh.
     
  9. martinjamesccorpuz
    OP

    martinjamesccorpuz Member

    Newcomer
    49
    0
    Aug 13, 2016
    and rename it to "arm9loaderhax_si.bin" right?
    — Posts automatically merged - Please don't double post! —

    should I update Luma to 7.0.4?
     
  10. lonewolf08

    lonewolf08 GBAtemp Fan

    Member
    416
    134
    Feb 4, 2016
    United States
    Yes, bootanim9 payload should be renamed to arm9loaderhax_si.bin on the root and luma payload should be renamed arm9payload.bin in anim folder.
    Root:
    arm9loaderhax_si.bin----------bootanim9 payload
    - anim/---------folder
    - 0/----------folder inside anim
    - anim
    - bottom_anim
    - config​

    - 1/-------another folder if you have more
    - anim
    - config​
    Arm9payload.bin----------lumas payload inside anim folder​

    And no you don't need to update luma if you don't want a9lh not the same as luma, luma is just the cfw
     
    Last edited by lonewolf08, Apr 29, 2017
    Ridge likes this.
  11. martinjamesccorpuz
    OP

    martinjamesccorpuz Member

    Newcomer
    49
    0
    Aug 13, 2016
    I just renamed the the one at the root and nothing will show on screen and it only flash a blue light
     
  12. lonewolf08

    lonewolf08 GBAtemp Fan

    Member
    416
    134
    Feb 4, 2016
    United States
    Is your file structure the same as above? If it is try redownloading the animations to make sure it isn't corrupt.
    Edit: each animations will have its own folder my example stops at two but if you have say 4 then you need 4 folders inside anim named 0,1,2,3,4 you can't leave one folder empty meaning you can't jump numbers. Try without the config file. That's all I can think off at the moment.
     
    Last edited by lonewolf08, Apr 29, 2017
  13. martinjamesccorpuz
    OP

    martinjamesccorpuz Member

    Newcomer
    49
    0
    Aug 13, 2016
    i should just redownload the anim9 again

    — Posts automatically merged - Please don't double post! —

    where do i get the config?
     
  14. lonewolf08

    lonewolf08 GBAtemp Fan

    Member
    416
    134
    Feb 4, 2016
    United States
    I don't think that's necessary but the steps for troubleshooting should be:
    1. Make sure folders and files are in right place and named correctly meaning no .bin.bin etc
    2. See if naming bootanim9 to arm9loaderhax works.
    3. If above don't work try arm9loaderhax_si
    4. Download the animations again maybe they got corrupt.
    5. Download payloads again maybe they got corrupt
    6. If none of the things work than you have super old a9lh that doesn't have screen init and need to update a9lh
    I don't think you need to do the last one since your screen flashed and most likely has to do with your animation files/structure.

    Edit: the config file usually comes with the animations some won't have it though.
     
    Last edited by lonewolf08, Apr 29, 2017
  15. martinjamesccorpuz
    OP

    martinjamesccorpuz Member

    Newcomer
    49
    0
    Aug 13, 2016
    its working fine now thank you alot! :D
     
  16. martinjamesccorpuz
    OP

    martinjamesccorpuz Member

    Newcomer
    49
    0
    Aug 13, 2016
    oh god i accidentally deleted everything on the root of the card what would happen? I mean literally everything except for the folders
     
  17. lonewolf08

    lonewolf08 GBAtemp Fan

    Member
    416
    134
    Feb 4, 2016
    United States
    How you manage to delete everything but the folders... Anyway just put the stuff back that you use. You're on your own on this one since I have no idea what you use and what you don't use and this blew my mind or you can just look at the blurry ass photo that you uploaded earlier and find those files again. Anyway I'm out goodbye.
     
  18. Jacklack3

    Jacklack3 ( ゚ヮ゚) buddie was here

    Member
    1,494
    1,914
    Oct 6, 2015
    Canada
    In your basement Dick Size: 5 meters.
    Check your recycle bin.