Acekard 2.1 compatible with DSi?

Discussion in 'Acekard' started by Bloodgod, Mar 26, 2009.

  1. Bloodgod
    OP

    Bloodgod 嵐の王

    Member
    1
    Mar 25, 2007
    United States
    So I'm in a market for a new DS and DSi is about to be released here in the US. SO is the normal acekard compatible with a DSi? I already know they have a DSi ver of acekard but I already bit the bullet and purchased a 2.1.
     
  2. Takeshi

    Takeshi GBAtemp Addict

    Member
    3
    Jun 1, 2004
    Germany
    The Acekard 2.1 is not compatible with the DSi.
     
  3. c0pE89

    c0pE89 Member

    Newcomer
    1
    Jan 2, 2009
    United States
    HI
    ya well u might not want to wasted money on the dsi acekard they already blocked that one to im hope it just needs a firmware update but its not looking good
     
  4. Bloodgod
    OP

    Bloodgod 嵐の王

    Member
    1
    Mar 25, 2007
    United States
    ok thanks. mods can delete this topic now
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice