1. fotuwe

    OP fotuwe Member
    Newcomer

    Joined:
    Jun 10, 2018
    Messages:
    35
    Country:
    Germany
    Hi,

    so usually I load my sx pro payload via Mac-Google Chrome (my switch is in RCM mode)
    This time I have to run it with Windows.

    I wanted to change the APX Driver with "Zadig driver installer" but before I uninstalled the APX windows driver via device manager (dont ask me why).
    Before the switch was recognized as APX in the device manager. Now there is a question mark :(

    The Zadig installer wont let me install the libusbK-Driver cause the device is not being recognized.

    I guess I have to reinstall the "original" APX driver somehow to make the Switch appear again as APX.
    Could anyone give some advice on how to accomplish this?
     
  2. Cubuss

    Cubuss GBAtemp Advanced Fan
    Member

    Joined:
    Aug 4, 2017
    Messages:
    504
    Country:
    Netherlands
    Go to device manager > select your switch in the usb list > press look for updates online,
     
  3. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08
    Member

    Joined:
    Mar 17, 2010
    Messages:
    20,907
    Country:
    Norway
    If the driver was autodetected originally then a reboot (followed by an unplug/replug if necessary) should make it be detected again.
     
  4. fotuwe

    OP fotuwe Member
    Newcomer

    Joined:
    Jun 10, 2018
    Messages:
    35
    Country:
    Germany
    Manually checking for updates tells me: the best driver is already installed (no action).
    This is how it looks. After plugging in the Switch I get a notice that the device is not working properly (and the "?" appears in the device manager).
    2.png
    Rebooting and replugging doesnt change anything.
    I tried to manually install the drivers via the TegraUI.
    When I check with Zadig the following shows up:
    1.png
     
  5. Cubuss

    Cubuss GBAtemp Advanced Fan
    Member

    Joined:
    Aug 4, 2017
    Messages:
    504
    Country:
    Netherlands
    uninstall the driver first then check online for updates
     
  6. fotuwe

    OP fotuwe Member
    Newcomer

    Joined:
    Jun 10, 2018
    Messages:
    35
    Country:
    Germany
    The moment I uninstall the device disappears. There is no way to check for updates afterwards.
    Re-plugging makes the device appear again with the same "?" in the device manager
     
  7. fotuwe

    OP fotuwe Member
    Newcomer

    Joined:
    Jun 10, 2018
    Messages:
    35
    Country:
    Germany
    hmmm .. cant get to the point my switch is listed as APX again.
    Any other guesses?
     
  8. Akira

    Akira I'm not a SHRIMP!!!!
    Member

    Joined:
    Apr 28, 2013
    Messages:
    1,249
    Country:
    United States
    Download tegrarcmgui and install the driver using it
     
  9. fotuwe

    OP fotuwe Member
    Newcomer

    Joined:
    Jun 10, 2018
    Messages:
    35
    Country:
    Germany
    Already did.
    Installation went through - restart. The switch appears as a "?" in the device manager
     
  10. Cubuss

    Cubuss GBAtemp Advanced Fan
    Member

    Joined:
    Aug 4, 2017
    Messages:
    504
    Country:
    Netherlands
    Try just uninstalling the drivers then reconnect the switch, it should install the driver amautomaticly,

    If not mak sure you have

    also make sure this is enabled

    upload_2018-10-20_16-26-39.png
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Accidentally, removed, Windows