Hacking A9LH - Can I restore A9LH v1 when I'm using v2?

Ev1lbl0w

Well-Known Member
OP
Member
Joined
Dec 19, 2014
Messages
280
Trophies
0
Age
34
XP
2,301
Country
Portugal
Basically, I thought today of something:

I have a SysNAND backup with arm9loaderhax v1. Recently I updated to v2.

So, I'm asking, is there a problem if I restore the backup with the old A9LH?
 

The Real Jdbye

*is birb*
Member
Joined
Mar 17, 2010
Messages
23,375
Trophies
4
Location
Space
XP
13,982
Country
Norway
That will erase a9lh don't do it
It won't erase A9LH if his old backup has A9LH on it...
Use Hourglass9 or "Keep A9LH" in Decrypt9. It should leave A9LH alone in that case.
I wouldn't recommend that. I'm not sure if the "Keep A9LH" option keeps all the A9LH data intact or just the FIRM partition, and if it doesn't, he'll brick his console. Logically it should, but unless you know for sure that it will, it's not worth the risk.
 

Ev1lbl0w

Well-Known Member
OP
Member
Joined
Dec 19, 2014
Messages
280
Trophies
0
Age
34
XP
2,301
Country
Portugal
Thanks guys for the help. But I think you didn't understood something:

My old backup has A9LH v1 installed. If I use restore with keep A9LH it will only keep my A9LH v2. However, if I don't use "keep A9LH", does it change my A9LH v2 to A9LH v1?

I'm asking if I brick my console by swapping A9LH versions. AFAIK, You can't use A9LH v1 on SafeA9LHInstaller v2, so that's why I'm asking.
 

Amapola62

Well-Known Member
Member
Joined
Oct 25, 2015
Messages
967
Trophies
0
Age
36
XP
557
Country
France
Why not make a back up with A9LH v2 and replace your A9LH v1 back up with the new one? That would be simpler...
 

SirByte

Well-Known Member
Member
Joined
Dec 30, 2012
Messages
524
Trophies
1
XP
1,059
Country
Canada
The only reason I can think of to be on V1 is easy compatibility with GW (the arm9loaderhax Beta #2 from June 1st). This is why I went through the trouble of going back to old versions of the guide and installing v1 on my o3DS, just have one SDcard with Luma3DS and one SDcard with GW. Maybe you can request for an A9LH tool that can do this? If ever made, we'll need an easy foolproof way to update to v3 eventually anyway (and you should have your otp.bin of course).
 
Last edited by SirByte, , Reason: typo

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    Xdqwerty @ Xdqwerty: not yet tho