A solution for gba virtual console blackscreen in rxtool2.6/3.0b2 .Maybe a bug.

Discussion in '3DS - Flashcards & Custom Firmwares' started by r4bbit, Aug 3, 2015.

  1. r4bbit
    OP

    r4bbit Member

    Newcomer
    15
    10
    Jan 20, 2015
    Switzerland
    Short version:
    If you think you did everything right(with linked nand,with valid gba cia,with right rxtools installation) but gba virtual console doesn't work(black screen with white words) in rxmode sysnand or emunand with rxtools2.6/3.0b2 (but maybe work in devmode sysnand).
    (note1: rxtools2.6 is said to be support gba without patched gba_firm . note2: devmode is available in 3.0b2 but not in 2.6 )
    Try to do as below:
    0. install FBI in sysnand
    1. run FBI,use L R button to change mode to "delete title" and destination to "nand",delete 0004013800000202 if there exists one.(it's safe.but if you delete wrong thing,this may brick your console.)
    2. install patched 0004013800000202.cia(for my oldJPN console,crc32 is 5609403D) in your sysnand (not emunand) to destination "nand"(not "sdcard")
    3. delete folder "data" and "nand" in sdcard:\\rxTools.
    4. reboot into rxtools.Rxtools will reinstall,you will see the process. Then your gba virtual console will likely work in both sysnand and emunand.

    Longer version:
    My console is JPN 4.5 with emunand 9.8. I tried rxtools2.6 and 3.0b2.
    I think I did everything right but Gba virtual console doesnt work in rxmode sysnand or emunand. I searched on Google and find some suggests.I have tried to format my console,tried emu nand 4.5,tried install gba on both sysnand and emu nand,tried install patched gba_firm(though it's said 2.6 and 3.0b2 dont need it to work).nothing helps.It always leads to a black screen on the bottom with white words. When I did the steps above problem solved.

    I have formatted my sysnand and recreated emunand several times to do some test and I am pretty sure problem exists before these steps and dispears after these steps on my console.

    I guess i found the reason. When install rxtools2.6 and 3.0b2 first time,it search gba_firm(0004013800000202) in sysnand(only sysnand,not emunand) and patch it to created 0004013800000202.bin in sdcard:rxtools/data.After installation,rxtool 2.6/3.0b2 doesnt used 0004013800000202 in sysnand or emunand any more,it use 0004013800000202.bin instead. But there exist some gba_firm versions which unexpected in rxtool 2.6/3.0b2 ,this lead to bad 0004013800000202.bin. Problem exists even though you install right version of gba_firm in sysnand or emunand,because of rxtools doesnt recreate 0004013800000202.bin. You must delete folder in rxTools to make rxtools reinstall to create new 0004013800000202.bin . It also works if i manual replace the bad 0004013800000202.bin with a right one(copy from the one when gba virtual console work) .So it is clear the reason is bad 0004013800000202.bin.
    If you used rxtools with version smaller than 2.6 to play gba virtual console successfully before,you will unlikely meet this problem after update becaused rxtools 2.6/3.0b2 can handle a patched gba_frim (i guess).


    It cost me a whole day to make gba work and half a day to find out how it works.I just want to save others' time,pardon me if i was wrong or I wasted your time.

    UPDATE1:
    I have download one unpatched v3665 gba_firm(crc E178FDA9).It runs ok with these steps(and with the unpatched v3665 one,Rxtools generate same 0004013800000202.bin with crc32 418869EC as the patched one).
    So the problem is more clear.Rxtools works well with both patched or unpatched v3665 gba_firm.But not with the original gba_firm comes with my old4.5JP console.
    There is a simple solution.We can just add suggestion to document to suggest user with old 3DS console to replace their gba_firm in sysnand with a patched or unpatched v3665 one to make sure gba virtual console game work.And tell user to let rxtools regenerate 0004013800000202.bin if they replace gba_firm after the installation of rxtool2.6/3.02b.
     
    Last edited by r4bbit, Aug 3, 2015
  2. Syphurith

    Syphurith Beginner

    Member
    641
    222
    Mar 8, 2013
    Switzerland
    Xi'an, Shaanxi Province
    So do these mean that the original AGB firm isn't so stable than the patched one?
    BTW this applies to Linked NANDs, does this also applies to Unlinked ones?
    For example if you install GBA CIAs to Sysnand (No i don't mean to the NAND, just its SD), still use a patched one and ok?
    If all these are confirmed i think you could contact @capito27 @motezazer or @AlbertoSONIC, so it may reveal more things.
    >> 1.find some bugs so it would be done more gracefully. 2.replace original one for patched. 3.Just include to tell users..
    Hope this be solved. Even i don't play GBA games on my console.
     
  3. r4bbit
    OP

    r4bbit Member

    Newcomer
    15
    10
    Jan 20, 2015
    Switzerland
    Yes.To speak more accurately,the original AGB_FRIM in my 4.5JPconsole doesnt work with rxtools2.6/3.02b in rxmode sysnand/emunand at all(but work in devmode sysnand 3.02b).I get a gba_firm which is already patched with crc32 5609403D which runs perfectly.I had only tested these two firms.
    update:an unpatched v3665 also works. see UPDATE1
    I dont quite catch what you said. I think you mean:with unlinked nand,is GBA cia playable in sysnand after install GBA cia only in rxmode sysnand after i did these steps?I didnt test this case.But in my opinion,this should undoubtly work.When system run in sysnand the system/program even don't known the existence of emunand.The state of linked/unlinked only affects the system/program in emunand.

    I created a issue in github,https://github.com/roxas75/rxTools/issues/111.
     
    Last edited by r4bbit, Aug 3, 2015
    Syphurith likes this.
  4. SirByte

    SirByte GBAtemp Fan

    Member
    494
    191
    Dec 30, 2012
    Canada
    I'm using the patched version of the AGB_FIRM patch that brings back the original colourful "GAMEBOY" startup animation. I'm guessing rxtools won't play nice with that one either?
     
  5. Koryushin

    Koryushin GBAtemp Regular

    Member
    176
    46
    Mar 26, 2015
    France
    In rxtools Devmode is for gba games. Not emunand or sysnand.
    If you want them on emunand you need to install the patched agb_firm like you did
     
  6. r4bbit
    OP

    r4bbit Member

    Newcomer
    15
    10
    Jan 20, 2015
    Switzerland
    Maybe.But my JP console never shows some "GAMEBOY" startup animation even with the patched one.

    There are three mode in rxtools 3.0b2. 1. rxmode in sysnand 2.rxmode in emunand 3.devmode(devmode not avaliable in 2.6) . Though there is no option for devmode in sysnand,devmode actually boots into sysnand. This is why I call it "devmode sysnand".
    Gba virtual console is playble in all the three mode in rxtools 3.0b2 according to my test.

    Yes.I have to do these steps to make gba playable in emunand in my case. But I shouldn't have to do that for 2.6/3.0b2 as update log for version 2.6 on rxtools.net says "Full AGB support on both sysNAND and emuNAND, without the need of installing any patched firmware".
     
    Last edited by r4bbit, Aug 4, 2015
  7. abelxcane

    abelxcane Advanced Member

    Newcomer
    99
    17
    Jan 4, 2011
    United States
    Thanks a lot for this information. I have been trying to get this to work for so long and I searched for days and nothing worked. I am grateful to you so thank you for helping me with this problem.
     
  8. xergio2011

    xergio2011 Newbie

    Newcomer
    2
    0
    Feb 6, 2016
    Colombia
    Uhmm

    I follow all i m sure

    Install FBI in Sysnand since Safe Icon in emunand
    Install and replaced the original GBA Firm for the Patched
    Delete the Nand and the data files in rxtools
    Generate and reinstall the rxtools 2.6
    and try installa GBA File but still loading a Black Icon and other a Black creen wirh "An error ocurred"

    The problem y hae unlinked my nands, someone can help me?
     
  9. pikatsu

    pikatsu GBAtemp Advanced Fan

    Member
    722
    125
    Apr 16, 2014
    Argentina
    Can you provide a working 0004013800000202.bin. I have followed all of your steps but i failed
     
  10. r4bbit
    OP

    r4bbit Member

    Newcomer
    15
    10
    Jan 20, 2015
    Switzerland
    this solution is written for linked nands. if you have unlinked nands,its another problem. try to install the gba cia in both real and emu nand .hope it works,i m not sure,i have never tried unlinked nand.
    make sure you have linked nand. PM me your email,i can send you one.my console is JP,not sure it will work for you