5.50 prometheus

Discussion in 'PSP - Games & Content' started by bioterror, Jan 1, 2011.

  1. bioterror
    OP

    bioterror Member

    Newcomer
    30
    0
    Sep 3, 2008
    United States
    Will I be able to run new games like, kingdom hearts, metal gear, valkyria chronicles 2, and persona on it?
    If it can't what update am I looking for.
     
  2. Rasas

    Rasas Banned

    Banned
    643
    28
    Apr 7, 2010
    United States
    Depending on your firmware your better off getting a plugin to run it since vhas some stability issues as well as the possibility of your old games saves not working on it.

    Also you can run those games on CFW 5.50 Prometheus 4 or 5.03 Prometheus 4 but I recommend staying on your current firmware if it is 5.00 m33 and using a plugin if 5.50 gen a-d using a plugin again would be my recommendation.
     
  3. 8BitWalugi

    8BitWalugi Taiyohhhhhh!

    Member
    3,327
    191
    Mar 22, 2008
    Side 7
    Use 5.50 Prom-4. I played MGS Peace Walker on 5.50 Prom-1, so it should work.
     
  4. bioterror
    OP

    bioterror Member

    Newcomer
    30
    0
    Sep 3, 2008
    United States
    Thanks for the response, my friend updated it for me, system software says 5.50 prome-4, he says he's been running mhp3 with no problem, but the monster hunter cat game just stopped working one day.

    Guess the best way to find out if it works is to try them.