1.4 dsi fix using an ezflash Vi as helper

Discussion in 'Acekard' started by matsurisan, Aug 20, 2009.

  1. matsurisan
    OP

    matsurisan Member

    Newcomer
    33
    0
    Aug 18, 2009
    I've got a DSi with 1.4 and an ezflash with the v12 firmware (with works on 1.4).

    I've read that, with the DSLite version of the updater, there's the possibility of upgrading a bunch of cards in a row.

    Perhaps I can load that from the ezflash, then swap with the acekard 2i and upgrade?

    I'm willing to risk trying so! But first I need two things ensured:
    - That starting the DSL upgrade tool doesn't upgrade anything *immediatly*, but rather waits for me to press some key. -> CONFIRMED using desmume (ds emulator)
    - That the DSL upgrade tool works all the same on a DSi.

    If this is confirmed, I'll try doing the upgrade and report back on the results.

    It'd also be helpful if we got the actual source code to the updater tool, so that I could just add a wait for a keypress on the DSi version before starting to check on the acekard hardware version / etc.
     
  2. injected11

    injected11 Crescent Fresh™

    Member
    1,776
    48
    Jul 17, 2009
    United States
    It's only going to work on the card it was designed to work with.
     
  3. DeltaBurnt

    DeltaBurnt I'm bored

    Member
    3,353
    2
    Feb 21, 2009
    United States
    Where intellect matters
    Wait what? Are you trying to fix a bricked acekard2i, are you trying to install the acekard2i fix, or are you trying to get old flashcarts working with the update.

    Because if it's 1 then it should work, if it's 2 then you don't need to switch you just run it on the acekard2i with a friends DS lite of a DSi with 1.3, it it's 3 then it won't work cause old flashcarts don't have updateable kernels.
     
  4. jruschme

    jruschme Advanced Member

    Newcomer
    92
    0
    Dec 28, 2008
    United States
    Jersey
    I assume that the OP wants to use the update much like the flash-killer fixer for the DSTT: Boot some usable card in a DSLite, run the updater, swap in an AK2i and update.
     
  5. matsurisan
    OP

    matsurisan Member

    Newcomer
    33
    0
    Aug 18, 2009
    What I want to do is to run the updater in an ezflash vi on the DSi 1.4, swap cards placing the acekard 2i, then update.
     
  6. matsurisan
    OP

    matsurisan Member

    Newcomer
    33
    0
    Aug 18, 2009
    I'm trying to upgrade an acekard 2i. It shouldn't matter what card is used to load the updater into ram... and most likely doesn't.

    I need to know, however, if the DSL version of the updater works all the same on a DSi. If it doesn't, I'm out of luck.
     
  7. dilav

    dilav GBAtemp Maniac

    Member
    1,230
    40
    Nov 22, 2006
    United States
    I have only read the first post. and that will not work because the dsl file does not work on a dsi. It will work on a dsl though. So if your ak2i is bricked you could repaire it on a dsl with another flashcart, and the ak2i dsl update file.
     
  8. matsurisan
    OP

    matsurisan Member

    Newcomer
    33
    0
    Aug 18, 2009
    I think I'm gonna try anyways. If it turns out to be true that the "dsl" updater won't work on DSi, and I end up with a bricked acekard 2i, I'll repeat the procedure with a dslite from a friend.

    I suspect however that the only difference between both updaters is that one allows for swapping the card and updating many acekards in a row, while the other doesn't.
     
  9. dilav

    dilav GBAtemp Maniac

    Member
    1,230
    40
    Nov 22, 2006
    United States
    Yes, i think that is the only difference, however I have been told that the code acekard used for swapping cards only works on a dsl and we dont have codes to support swapping cards on a dsi yet.
     
  10. SpaceJump

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,672
    213
    Aug 18, 2005
    Gambia, The
    Zebes
    matsurisan, I'm in the exact same situation as you. So I hope it works for you.
     
  11. Chris_Skylock

    Chris_Skylock GBAtemp Advanced Maniac

    Member
    1,501
    0
    Dec 26, 2008
    Philippines
    The DSL and DSI will work on DS/DS Lite and DSi. The DSL file is there for MULTIPLE ACEKARDS on a DS LITE.

    CANT PEOPLE READ?!!

    The Acekard fix IS MEANT TO BE RUN ON AN ACEKARD. It's like buying a BIG MAC on KFC or something.
     
  12. Tokiopop

    Tokiopop Caffeine fiend

    Member
    1,833
    169
    Apr 14, 2009
    UK
    Actually, someone did this with an M3 on a DS Lite and updated a bricked Acekard 2i onto the 1.4 firmware fix version.

    Fuckers. [​IMG]
     
  13. jak larnak

    jak larnak GBAtemp Regular

    Member
    188
    0
    Jul 21, 2009
    France
    Not so far
    matsurisan, what you want to do is possible but only with a DS lite. Here is a part of an e-mail i received from the website i bought my Acekard:

     
  14. Apache Thunder

    Apache Thunder I have cameras in your head!

    Member
    4,102
    4,033
    Oct 7, 2007
    United States
    Levelland, Texas
    Remember that you can't do this on a DSi. I've been told that the DSi will reset to menu the moment you pop out the DS cart. So it will always reset if you try to swap DS carts. That's why this only works on a DS/DSLite (the cart swapping that is).
     
  15. mercluke

    mercluke ‮҉

    Member
    3,163
    172
    Dec 2, 2007
    Perth
    strange...
    doesn't reset with mine..
     
  16. SpaceJump

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,672
    213
    Aug 18, 2005
    Gambia, The
    Zebes
    So mercluke, you say this worked for you on DSi?
     
  17. matsurisan
    OP

    matsurisan Member

    Newcomer
    33
    0
    Aug 18, 2009
    Interesting.

    If it resets or not when removing the card will be easy to test I guess [​IMG].
     
  18. SpaceJump

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,672
    213
    Aug 18, 2005
    Gambia, The
    Zebes
    Just tested it and as soon as I remove the EZ5i from the DSi, the app freezes (no reset). So it doesn't seem to work on DSi.