1.3 vs 1.4 upgrade path

Discussion in 'R4 DS' started by garp99, Sep 6, 2009.

Sep 6, 2009

1.3 vs 1.4 upgrade path by garp99 at 11:55 PM (1,280 Views / 0 Likes) 4 replies

  1. garp99
    OP

    Newcomer garp99 Newbie

    Joined:
    Sep 1, 2009
    Messages:
    9
    Country:
    Canada
    I found out my niece has 1.3u firmware on her 4-week old DSi.

    I've read other posts about not working after 1.3e, but is 1.3u still avoiding the 1.4 problems?

    Does using a non-1.4 fixed flashcart on a DSi cause damage to the DSi itself (bricked)?

    Not having a DSi myself, how do you upgrade to 1.4... I mean does a user have to download
    and install a new firmware themselves, does the DSi auto-check for new firmware when connected
    to internet via wireless mode and then asks user to auto-update to v1.4?
     
  2. injected11

    Member injected11 Crescent Freshâ„¢

    Joined:
    Jul 17, 2009
    Messages:
    1,776
    Country:
    United States
    1.3 is fine. 1.4 is the blocker. The DSi has to manually be updated by the user; it doesn't auto-update. It forces an update if you try to enter the DSi shop.
     
  3. antonkan

    Member antonkan GBAtemp Maniac

    Joined:
    Jun 13, 2009
    Messages:
    1,063
    Location:
    Burlington, ON
    Country:
    Canada
    Sorry about that someone has already answered above.
     
  4. josephbloseph

    Newcomer josephbloseph Member

    Joined:
    Sep 2, 2009
    Messages:
    24
    Country:
    United States
    My understanding about the firmware suffixes e and u (and j) refer to the region (Europe, US, Japan), as opposed to lineal updates to the firmware. As others have posted, 1.3 works, 1.4 requires an updated flash cartridge (either the card can have it's software updated, or the card itself has to be replaced).
     
  5. garp99
    OP

    Newcomer garp99 Newbie

    Joined:
    Sep 1, 2009
    Messages:
    9
    Country:
    Canada
    Thanks, great answers.
    Makes sense now that 1.3u refers to USA (or Canada).

    Great to know that 1.3 flash cards work and it's the user's problem if they update
    (of course some didn't know until it was too late!).

    It means that I can get a 1.3 card locally (if I choose) and tell my niece to never update.
    Although I will probably go and get the AceKard 2, based on info from other threads.

    Thanks again.
     

Share This Page