yet another dios mios not working thread

Discussion in 'Wii - Backup Loaders' started by ZackHolmes, Feb 1, 2014.

  1. ZackHolmes
    OP

    ZackHolmes Member

    Newcomer
    13
    0
    Nov 13, 2011
    So I've been pulling my hair out for a few months trying to get this to work. I had it working once.. booted a few games, played them, however no more. I'm running dios mios 2.10, with usbloader gx r1218 and/or wiiflow 4.2.1 r441 and a usb fat32 hdd. heres what happens:

    usbloadergx: no dios mios splash, just black screen or return to HBC
    Wiiflow with disc: shows splash screen then boots the disc in the drive regardless of what iso i choose
    wiiflow without disc: fatal error app loader size is zero (or something along those lines)

    Ive searched forums and google high and low trying to figure out what settings to switch, what folders things need to be in, what format the drive needs to be in, what versions of each are compatible with one another... i just can't find the right combination. I know its not the drive because i had them working once with SOME right combination of software

    What gives?? Anyone got any ideas? Should i try devolution or nintendont and throw in the towel on dios mios?

    FWIW, id prefer to get it working with USBLoaderGX, however ill take what i can get at this point

    Heres my syscheck gx log:

    Code:
    sysCheck GX v1.0.0 by Erik Spyder
     
    sysCheck GX is running under IOS61 (rev 5662).
     
    Console ID: 46002052.
    Region: NTSC-U.
    Hollywood v0x11.
    Boot2 v2.
    System Menu v449 (4.1U).
    BC v5.
    MIOS v10.
     
     
    Found 135 titles.
    Found 30 IOS and 8 IOS Stubs on this console.
     
    Priiloader is installed.
     
     
    IOS  4 (rev 65280): Stub
    IOS  9 (rev  521)
    IOS 10 (rev  768): Stub
    IOS 11 (rev  256): Stub
    IOS 12 (rev    12)
    IOS 13 (rev    16)
    IOS 14 (rev  263)
    IOS 15 (rev  266)
    IOS 16 (rev  512): Stub
    IOS 17 (rev  518)
    IOS 20 (rev  256): Stub
    IOS 21 (rev  525)
    IOS 22 (rev  780)
    IOS 28 (rev  1293)
    IOS 30 (rev  2816): Stub
    IOS 31 (rev  3092)
    IOS 33 (rev  2834)
    IOS 34 (rev  3091)
    IOS 35 (rev  3092)
    IOS 36 (rev  3094): Trucha Bug, ES_Identify, NAND Access
    IOS 37 (rev  3612)
    IOS 38 (rev  3610)
    IOS 50 (rev  5120): Stub
    IOS 51 (rev  4864): Stub
    IOS 53 (rev  5149)
    IOS 55 (rev  5149)
    IOS 56 (rev  5662)
    IOS 60 (rev  6174): Trucha Bug, ES_Identify, NAND Access
    IOS 61 (rev  5662)
    IOS236 (rev 65535): Trucha Bug, ES_Identify, NAND Access
    IOS245 (rev 21007): Trucha Bug, ES_Identify, NAND Access
    IOS246 (rev 21007): Trucha Bug, ES_Identify, NAND Access
    IOS247 (rev 21007): Trucha Bug, ES_Identify, NAND Access
    IOS248 (rev 21007): Trucha Bug, ES_Identify, NAND Access
    IOS249 (rev 21007): Trucha Bug, ES_Identify, NAND Access
    IOS250 (rev 21007): Trucha Bug, ES_Identify, NAND Access
    IOS251 (rev 21007): Trucha Bug, ES_Identify, NAND Access
    IOS254 (rev 65281)
     
    Report generated on 2014-02-01.
    
     
  2. ZackHolmes
    OP

    ZackHolmes Member

    Newcomer
    13
    0
    Nov 13, 2011
    anyone got any thoughts/suggestions?
     
  3. TheChield

    TheChield Ugly Troll

    Member
    210
    29
    Jul 10, 2013
    France
    Hello Are you sure DM is installed ?
    My wii is in it's box but I remerber that when DM is installed syscheck doesn't repport "MIOS v10" but some kind of cMIOS (maybe I'm mistaken...)
    And I had to use DM 2.9 and was working fine with most games (pal)
    Maybe try to rebackup your game with clean rip or check de MD5 on redump : http://redump.org/discs/system/gc/
     
  4. ZackHolmes
    OP

    ZackHolmes Member

    Newcomer
    13
    0
    Nov 13, 2011
    well, DM is properly reported in the credits in usbloader gx, and it does show the splash screen and load the disc in the drive with wiiflow.. i think that means its installed, but i do recall seeing the syscheck thing you mention from other folks. hmm..
     
  5. Nicholas Kosner

    Nicholas Kosner Member

    Newcomer
    29
    0
    Feb 14, 2013
    United States
    I have syscheck updated to v2.1.0b19 (updated from inside the app) and it reports my MIOS as "MIOS v10 (DIOS MIOS 2.2.2+)" and I have DM v2.10

    I'm no expert on this so proceed with caution, but your syscheck didn't report any cIOS like d2x in IOS249. I also noted it says you have BC v5, but I believe most guides say you need BC v6.

    Hopefully someone with more knowledge can comment further, and link you to the stuff I mentioned if it's right.
     
  6. Nicholas Kosner

    Nicholas Kosner Member

    Newcomer
    29
    0
    Feb 14, 2013
    United States
    I have syscheck updated to v2.1.0b19 (updated from inside the app) and it reports my MIOS as "MIOS v10 (DIOS MIOS 2.2.2+)" and I have DM v2.10

    I'm no expert on this so proceed with caution, but your syscheck didn't report any cIOS like d2x in IOS249. I also noted it says you have BC v5, but I believe most guides say you need BC v6.

    Hopefully someone with more knowledge can comment further, and link you to the stuff I mentioned if it's right.
     
  7. TheChield

    TheChield Ugly Troll

    Member
    210
    29
    Jul 10, 2013
    France
    cIOS seems to be installed,but we don't know if it's only patched IOS with nand access etc... or real cIOS. ZackHolmes, can you try to use a more recent syscheck version ?
    I stopped reading when I so the bad DM installation but it's only due to an old version of syscheck that doesn't show details, but I think there are other "mistakes"...

    A common good report should show something like "IOS249[56] (rev 21010, Info: d2x-v10beta53-al): Acces NAND, USB 2.0"

    I also see that IOS60 is patched, it's dangerous to patch the IOS use by system menu. (this has nothing to deal with your problem, it's only not recommended)
    You don't have the IOS used for based cIOS (56 yes, but not 57), what IOS did you use to make cIOS236 => 251 ? (think 236 is from old 36...)

    Maybe you should do an official update => 4.3, this would clean you nand and then reinstall HBC and cIOS 249, 250 (d2x) and DM

    In the end your hack just seems to be too old to make DM works fine.
     
  8. Jayro

    Jayro MediCat DVD and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,855
    2,587
    Jul 23, 2012
    United States
    Octo Canyon
    Can anyone point me in the right direction for the RVL-BC-V6.wad to download? Google is failing me. :shit:
     
  9. ZackHolmes
    OP

    ZackHolmes Member

    Newcomer
    13
    0
    Nov 13, 2011
    Ah.. sorry folks. heres one with 2.1.0 b19, instead of GX. It shows all the info you mentioned.

    Good thoughts on basically, starting over. that hadn't occurred to me. I did hack this a while ago, as you see with system menu 4.1 (4.3 came out 4 years ago, so thats at least how old this hack is). I got it working and just sorta left it and updated it when things broke. i don't even remember what iOS i used to make 236-51 for example since it was so long ago

    i'll probably look into doing that, unless someone sees some easy glaring mistake from the new log

    Code:
    sysCheck v2.1.0b19 by Double_A and R2-D2199, Nano
    ...runs on IOS61 (rev 5662).
     
    Region: NTSC-U
    System Menu 4.1U (v449)
    Priiloader installed
    Drive date: 2006.09.07
    Homebrew Channel 1.1.0 running on IOS61
    HomebrewFilter ist nicht installiert
    Hollywood v0x11
    Console ID: 46002052
    Boot2 v2
    Found 135 titles.
    Found 38 IOS on this console. 8 of them are stub.
     
    IOS4 (rev 65280): Stub
    IOS9 (rev 521): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 256): Stub
    IOS12 (rev 12): No Patches
    IOS13 (rev 16): No Patches
    IOS14 (rev 263): No Patches
    IOS15 (rev 266): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 518): No Patches
    IOS20 (rev 256): Stub
    IOS21 (rev 525): No Patches
    IOS22 (rev 780): No Patches
    IOS28 (rev 1293): No Patches
    IOS30 (rev 2816): Stub
    IOS31 (rev 3092): No Patches
    IOS33 (rev 2834): No Patches
    IOS34 (rev 3091): No Patches
    IOS35 (rev 3092): No Patches
    IOS36 (rev 3094): Trucha Bug, ES Identify, NAND Access
    IOS37 (rev 3612): No Patches
    IOS38 (rev 3610): No Patches
    IOS50 (rev 5120): Stub
    IOS51 (rev 4864): Stub
    IOS53 (rev 5149): No Patches
    IOS55 (rev 5149): No Patches
    IOS56 (rev 5662): No Patches
    IOS60 (rev 6174): Trucha Bug
    IOS61 (rev 5662): No Patches
    IOS236[36] (rev 65535, Info: rev 3351): Trucha Bug, ES Identify, NAND Access
    IOS245[37] (rev 21007, Info: d2x-v7beta1d): Trucha Bug, NAND Access, USB 2.0
    IOS246[38] (rev 21007, Info: d2x-v7beta1d): Trucha Bug, ES Identify, NAND Access
    IOS247[53] (rev 21007, Info: d2x-v7beta1d): Trucha Bug, NAND Access, USB 2.0
    IOS248[55] (rev 21007, Info: d2x-v7beta1d): Trucha Bug, NAND Access, USB 2.0
    IOS249[56] (rev 21007, Info: d2x-v7beta1d): Trucha Bug, NAND Access, USB 2.0
    IOS250[57] (rev 21007, Info: d2x-v7beta1d): Trucha Bug, NAND Access, USB 2.0
    IOS251[58] (rev 21007, Info: d2x-v7beta1d): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65281): BootMii
    BC v5
    MIOS v10 (DIOS MIOS 2.6.1+)
     
    Report generated on 2014/02/05.
    
     
  10. TheChield

    TheChield Ugly Troll

    Member
    210
    29
    Jul 10, 2013
    France
    Your cIOS configuration should work even if really not clean.
    Maybe loaders are configured to use IOS222 that is not install ?
    Some patch applied ?
    Emunand without nand on SD ?
    Did you try to run the loader with no configuration files (back up and remove them) ?
     
  11. TheChield

    TheChield Ugly Troll

    Member
    210
    29
    Jul 10, 2013
    France
    Try NUS downloader It will download it from Nintendo servers.
     
  12. ZackHolmes
    OP

    ZackHolmes Member

    Newcomer
    13
    0
    Nov 13, 2011
    Hmm. ok did a bit more work. updated to 4.3u, but that didn't remove hbc or change anything really. But i went and properly updated coos to v10 with d2x and the recommended base ios's as well as removed stubs from 249 and 250 and properly updated those as well. wiped out the config directory, redownloaded and reinstalled dm, redownloaded current versions of usbloader gx and wiiflow.... not using any emunand btw

    and... no change. still no splash with usbloader gx at all, still booting the disc inserted in the drive instead of off the usb drive with wiiflow. without a disc I'm getting that app loader size is zero error and I've seen that a few times mentioned around the board. i also saw a pretty in depth DM install guide here that ill run through again.

    It might also be worth noting that wii backups load from the usb device perfectly fine.

    heres updated sys check for what its worth, if anyone happens to have any thoughts.

    Code:
    sysCheck v2.1.0b19 by Double_A and R2-D2199, Nano
    ...runs on IOS58 (rev 6176).
     
    Region: NTSC-U
    System Menu 4.3U (v513)
     
    Drive date: 2006.09.07
    Homebrew Channel 1.1.0 running on IOS61
    HomebrewFilter ist nicht installiert
    Hollywood v0x11
    Console ID: 46002052
    Boot2 v4
    Found 147 titles.
    Found 50 IOS on this console. 12 of them are stub.
     
    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 256): Stub
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 1032): No Patches
    IOS20 (rev 256): Stub
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 2816): Stub
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 3072): Stub
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 5120): Stub
    IOS51 (rev 4864): Stub
    IOS52 (rev 5888): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 6400): Stub
    IOS61 (rev 5662): No Patches
    IOS62 (rev 6430): No Patches
    IOS70 (rev 6912): Stub
    IOS80 (rev 6944): No Patches
    IOS236[36] (rev 65535, Info: rev 3351): Trucha Bug, ES Identify, NAND Access
    IOS245[37] (rev 21010, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
    IOS246[38] (rev 21010, Info: d2x-v10beta52): Trucha Bug, ES Identify, NAND Access
    IOS247[53] (rev 21010, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
    IOS248[55] (rev 21010, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
    IOS249[56] (rev 21010, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
    IOS250[57] (rev 21010, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
    IOS251[58] (rev 21010, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v10 (DIOS MIOS 2.6.1+)
     
    Report generated on 2014/02/09.
    
     
  13. Nicholas Kosner

    Nicholas Kosner Member

    Newcomer
    29
    0
    Feb 14, 2013
    United States
    I could be wrong but when I first ordered my external hard drive they sent me the wrong one (same brand, similar appearance but the wrong model) and no matter what I could not get the DM splash either. I tried to check the hard drive compatibility list which is when I noticed they sent me the wrong one, and when I finally got the correct one it worked great.

    I would try googling around and checking different compatibility lists and see if yours is mentioned anywhere.
     
  14. ZackHolmes
    OP

    ZackHolmes Member

    Newcomer
    13
    0
    Nov 13, 2011
    i would expect it to be the drive by now if it weren't for the fact that at one point in time, i had it working great. i actually loaded backups off this drive with usbloader gx. i updated and things broke. and didn't note which versions of things i had where it was successfully running. double-checking my drive though to see if its on the list...
     
  15. Nicholas Kosner

    Nicholas Kosner Member

    Newcomer
    29
    0
    Feb 14, 2013
    United States

    If that's the case then keep trying, I had the same problem as you (I know it worked in the past but just doesn't work now) on a few things and eventually I got them to start working again.

    You could try following the directions in this thread http://gbatemp.net/threads/how-to-solve-dios-mios-errors-apploader-size-is-zero-ans-others.360692/ (making sure to backup your files first) and maybe it'll help. It doesn't specifically mention your problem but it did fix my HDD that worked in the past like yours.
     
  16. ZackHolmes
    OP

    ZackHolmes Member

    Newcomer
    13
    0
    Nov 13, 2011
    GOT IT. it was folder structure

    Ok, so i tried ripping a new game, with usbloader gx and it immediately disappears. i double-check folder structure and realized that somewhere along the way my folder structure got fucked up. i had just the games in the games folder, with no subfolder. i fixed this, so that they were /games/game [id]/game.iso and still couldn't get them to appear in usbloader gx. figured id try wiiflow with the newly ripped game, and viola, it worked like a charm. so back to usbloader gx, i couldn't figure out why no gamecube games were showing. what i did in the past was just dump them into the wbfs folder. they'd show up and then they wouldn't load. so i moved them to the games folder and they wouldn't show up at all. i checked and double-check the settings, custom paths etc when it dawned on me that i vaguely remember seeing a checkbox somewhere... low and behold in one of the boxes along the top, it was selected to only show wii games, not gamecube games.

    as such, wiiflow was crashing cuz the folder structure was fucked up and usbloader gx was crashing and not showing the dios mios logo at all because it was trying to load gamecube games as wii games.

    fix folder structure and enable gc games in usbloader gx and both loaders work perfectly at loading gamecube games
     
  17. Nicholas Kosner

    Nicholas Kosner Member

    Newcomer
    29
    0
    Feb 14, 2013
    United States
    I'm glad you got everything working correctly! Sometimes it's the littlest things we overlook that screw everything up haha
     
  18. ZackHolmes
    OP

    ZackHolmes Member

    Newcomer
    13
    0
    Nov 13, 2011
    exactly. and theres like 50 billion threads about hard drive incompatibilities and such (hard things that should go wrong) and like one line in a guide about folder structure (easy things that shouldn't) :P
     
  19. Goatsie666

    Goatsie666 Head Smithy

    Member
    150
    5
    Oct 26, 2014
    United States
    Portland, Oregon
    can anyone please help me? im having this identicle problem