Wrong IOS Version for D2X?

Discussion in 'Wii - Hacking' started by TehOfficialWiiz, Dec 8, 2014.

  1. TehOfficialWiiz
    OP

    TehOfficialWiiz Newbie

    Newcomer
    1
    0
    Dec 8, 2014
    United States
    Hello everyone, tehofficialwiizard here. Soooo, I have been trying to use usb loader gx... and then I found out that - in order to play games off a flash drive - I need to update my 249 ios slot to D2X. When trying to solve this issue through D2X installer 2.2, I found that I required an ios that my system did not have. its strange.
    My (main) ios versions are:
    IOS36 v3608
    IOS56 v5662
    IOS58 v6172


    I am currently on IOS58 v6172. Any help with the fact that I do not have the right IOSes?
    (P.S. I am a forum noob)
     
  2. Snowmanne

    Snowmanne GBAtemp Regular

    Member
    125
    6
    Jan 5, 2012
    United States
    Elgin, Illinois
    Do a system check with sysCheck v2.1.0 b19 then use ModMii's syscheck updater with the file syscheck made on the sd card, the download and install the updated ios/cios.
     
  3. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,625
    8,204
    Oct 27, 2002
    France
    Engine room, learning
    You don't need any IOS to install d2x cIOS.
    I don't know which version you found, nor where you found it.
    The installer shouldn't ask you any IOS in order to install cIOS : they are downloaded directly from the official nintendo servers, unless you found the "2.2mod" version by Fix94 which use your own IOS instead of downloading them.
    The "2.2mod" version is intended for WiiU, as everybody has the IOS already installed and users can't download the encrypted IOS from nintendo's servers for WiiU.

    On Wii, the IOS 56 and 57 on the servers can be downloaded and used to create patched IOS (custom IOS, cIOS) and the result is installed on your Wii.


    1. use this pack : d2x-cios-installer-3.1-v6-v7-v8-v10-wii
    2. extract it to your apps folder so you can launch it with the homebrew channel.

    Now launch it and it shouldn't ask you to have any IOS to use it.

    select to install :
    What : d2x v8 (or v10, but v8 is enough)
    where : slot 249
    base : IOS 56
    version : 21008

    and

    What : d2x v8 (or v10, but v8 is enough)
    where : slot 250
    base : IOS 57
    version : 21008