Wrong game_region set

Discussion in 'Wii U - Hacking & Backup Loaders' started by semac, Feb 13, 2018.

  1. semac
    OP

    semac Newbie

    Newcomer
    1
    Feb 13, 2018
    United States
    While making my Wii U region free my modifying the sys_prod.xml game_region field I accidentally put the wrong game_region (2 instead of the original 4). This is pretty stupid of me but anyway I'm now stuck because the Wii U won't let me access the Settings app (nor the web browser) and says that those apps come from the wrong region.
    Is there any way to force a factory reset without accessing the Settings app? Or anything I could try?

    Thanks!
     
  2. godreborn

    godreborn GBAtemp Psycho!

    Member
    8
    Oct 10, 2009
    United States
    do you have the homebrew launcher or haxchi installed? I suppose that issue might happen. I made my system region free by modifying that file, and I never had those issues, so maybe changing the region incorrectly caused that. I backed up the original file just in case I needed it. that modification is no longer needed though since haxchi/cbhc is region free anyway. I'm using cbhc, and I just left the modified file. btw, if you make a new profile, the wii channel and the wii u disc icon will disappear. I've never actually done this since I'm the only one using my wii u.
     
  3. semac
    OP

    semac Newbie

    Newcomer
    1
    Feb 13, 2018
    United States
    Hi, thanks for your help. No I don't have the homebrew launcher nor haxchi installed (I relied on the browser exploit). So there's no way to factory reset apart from the settings app? This whole region-lock is making me crazy.
     
  4. godreborn

    godreborn GBAtemp Psycho!

    Member
    8
    Oct 10, 2009
    United States
    tbh, I don't know. @Kafluke might know. the only thing I can think of is making a NNiD. that may make things worse though as I don't know what might happen. normally, the wii channel and virtual wii channel will disappear which is why I'm hesitant to suggest it. it's either a new NNiD or a new profile that causes that to happen. I've never personally experienced it, and I've had that mod for over a year.
     
  5. Marko76

    Marko76 GBAtemp Psycho!

    Member
    10
    Aug 19, 2015
    United Kingdom
    Clydebank
    The Internet browser and settings app are both region coded if you set the wrong region you are basically fucked as they wont work. If you had haxchi then this could be fixed but as you dont you have a semi brick that cant be fixed. Also why did you do region hax when you could have just used mocha/haxchi as both are region free and don't fuck uo the system like you have done.


    Creating a NNID wont achieve anything as the browser and system app will still not work due to being region locked.
     
  6. Ryccardo

    Ryccardo WiiUaboo

    Member
    10
    Feb 13, 2015
    Italy
    Imola
    You will need a hardmod to restore your SLC backup, then...
     
  7. Marko76

    Marko76 GBAtemp Psycho!

    Member
    10
    Aug 19, 2015
    United Kingdom
    Clydebank
    Oh so i forgot to add in my previous post even if you could do a factory reset (which you cant) this would not achieve anything as the region would not be reset and you would still be in the exact same situation as now.
     
    Last edited by Marko76, Feb 13, 2018
    Ryccardo likes this.
  8. godreborn

    godreborn GBAtemp Psycho!

    Member
    8
    Oct 10, 2009
    United States
    you need the otp as well to decrypt the slc. otherwise, you need a NAND backup of before the change was made. I think those are the only two possible solutions to your issue. both require a hard mod. you can, however, alter the NAND backup on your pc with eyekey's tools. you'll need your otp for that.
     
  9. Kafluke

    Kafluke GBAtemp Psycho!

    Member
    11
    May 6, 2006
    United States
    Do you have any nand backups?
     
  10. semac
    OP

    semac Newbie

    Newcomer
    1
    Feb 13, 2018
    United States
    This makes sense. To be honest I wanted to use just mocha/haxchi without doing the region hax but I couldn't understand how to make this setup work. I tried loading mocha, then going back to the menu but the discs were still erroring as out of region. There's probably something that I'm missing as I'm still unclear what "using mocha" even means apart from going to HBL and loading it.

    Thanks for the replies though!

    — Posts automatically merged - Please don't double post! —

    Nope, I don't have any NAND backup. Any way to flash the firmware of the Wii U to a factory image?
     
  11. bootmonster

    bootmonster GBAtemp Fan

    Member
    4
    Oct 26, 2002
    United States
    Nope your Wii u is for the bin.
     
    semac likes this.
  12. godreborn

    godreborn GBAtemp Psycho!

    Member
    8
    Oct 10, 2009
    United States
    I think discs require ourloader to work. that's what it's intended for. I'm not sure if region hax affects this though

    always, make sure to have a NAND backup for any console just in case something happens. I'm sure Kafluke mentions this in his guide. that's in his siz.
     
  13. semac
    OP

    semac Newbie

    Newcomer
    1
    Feb 13, 2018
    United States
    Just out of curiosity, what could I have done if I had a NAND backup? And why can I not use a backup from someone else?
     
  14. godreborn

    godreborn GBAtemp Psycho!

    Member
    8
    Oct 10, 2009
    United States
    NAND is encrypted. you need the otp to decrypt it. you could've reflashed the system before the edit. btw, the region free number is three digits, not one iirc.
     
  15. semac
    OP

    semac Newbie

    Newcomer
    1
    Feb 13, 2018
    United States
    Ah, so the OTP is specific to the machine and therefore that's why I cannot use a NAND + OTP from another console?

    I know the region free number is 119. For some reason I wanted to put it back to its original value and messed up since I forgot this was a EU wii u.
     
  16. godreborn

    godreborn GBAtemp Psycho!

    Member
    8
    Oct 10, 2009
    United States
    I think so. I've decrypted the NAND before, and it needed my otp. though, I heard somewhere that the otp was the same for all consoles, so I'm not really sure. I think it's due to the common key which is the same for all consoles. I've not investigated further.

    that could be the issue. with region free, it should boot anything without issue. maybe your problems needs to be a warning for anyone who tries region hax. I have the original one of those files backed up.
     
  17. kornychaos

    kornychaos Organized.

    Member
    3
    Jul 7, 2007
    United States
  18. godreborn

    godreborn GBAtemp Psycho!

    Member
    8
    Oct 10, 2009
    United States
    there may be an unknown button combination. the 3ds has one that will install the latest firmware directly from Nintendo's servers. the ps3 has a built in one which I do use sometimes since I fiddle with the firmware sometimes or rather I did. the 360 has xell which is the first fifty blocks of the NAND. I don't know about the wii u, but it's possible. though, it tends to install titles, so something specific like that might be skipped over. I'm not really sure. I'm just making a possible scenario.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice