Working Wii64/WiiSX forwarders :)

Discussion in 'Wii - Emulation and Homebrew' started by qwertymodo, Dec 28, 2010.

Dec 28, 2010
  1. qwertymodo
    OP

    Member qwertymodo GBAtemp Advanced Fan

    Joined:
    Feb 1, 2010
    Messages:
    769
    Country:
    United States
    Since the release of the latest betas of Wii64 and WiiSX, I (as well as many of you), have been very frustrated with the fact that they do not work with forwarders. Thanks to giantpune's work with PunEmu, I am happy to present to you Wii64 and WiiSX patched for forwarders, as well as IOS58+AHBPROT forwarders to accompany them. Credit goes to giantpune for the patch, and CountZeroWad for the N64 banner.

    Changes:
    -Both emulators now load and exit properly from forwarders without crashing.
    -USB2.0 support via IOS58 (credit to matguitarist and Tantric).
    -The Home Button is now available as a return-to-menu button in Wii64 for Classic Controller and Wiimote/Nunchuck, and WiiSX for Wiimote/Nunchuck (it was already added for CC in WiiSX).

    Forwarders are based on Tantric's WiiMC forwarder.

    Wii64 banner by CountZeroWad, modified by me.
    -IOS58+AHBPROT enabled
    -Smoothed the rotation of the N by speeding it up a bit
    -New sound.bin (from Super Mario 64)

    WiiSX banner by me.
    -IOS58+AHBPROT enabled

    NOTE: You DO have to use the Wii64/WiiSX binaries provided (and if you want DVD access be sure to copy the meta.xml as well), the channels will not work with the official releases.
    Download:
    Wii64
    WiiSX
     


  2. whoomph

    Member whoomph GBAtemp Regular

    Joined:
    Mar 5, 2010
    Messages:
    191
    Location:
    South Coast of England
    Country:
    United Kingdom
    Nice. Does your Wii64 include the libOGC/analogue fix like matguitarist's?
     
  3. qwertymodo
    OP

    Member qwertymodo GBAtemp Advanced Fan

    Joined:
    Feb 1, 2010
    Messages:
    769
    Country:
    United States
    I'm using the latest official libogc, not his patched libogc, so I'm pretty sure that means no analog fix or additional 3rd party controller support (other than any support that may have been added to libogc since February).
     
  4. giantpune

    Member giantpune GBAtemp Addict

    Joined:
    Apr 10, 2009
    Messages:
    2,860
    Country:
    United States
    try this instead http://www.multiupload.com/AE9N0HQ0FZ . its just the wiimc forwarder channel with 3 or 4 magic lines of code added. i used it to boot the latest svn versions of wii64 and wiisx. wii64 started up as expected, and exited back to the system menu when i told it to leave.

    wiisx started up as expected, but i didnt have the PSXISOS folder so after i clicked a few buttons it crashed, gave me the code dump, and then exited back to the system menu. i created that folder and now it start correctly, but IDK what button to press to make it exit [​IMG] . but im sure if i did know the button, it would exit gracefully to the system menu
     
  5. qwertymodo
    OP

    Member qwertymodo GBAtemp Advanced Fan

    Joined:
    Feb 1, 2010
    Messages:
    769
    Country:
    United States
    I was wanting to go that route, but I couldn't figure out how to load the SM from the stub... guess I shoulda just asked and saved myself the trouble [​IMG] I'll give this a try, but if this works the way I'm thinking it does, then giantpune's forwarders should work with ANY release of Wii64/SX (official, matguitarist mods, mine, etc.). I'll post back with results, and if it works, I'll reupload my AHBPROT channels with giantpune's forwarders.
     
  6. qwertymodo
    OP

    Member qwertymodo GBAtemp Advanced Fan

    Joined:
    Feb 1, 2010
    Messages:
    769
    Country:
    United States
    Well, giantpune's forwarders load and exit the emulators properly, but it can't find my roms/isos on USB. So something's still not playing nice. My modded version works, so I'll leave it up for now.
     
  7. qwertymodo
    OP

    Member qwertymodo GBAtemp Advanced Fan

    Joined:
    Feb 1, 2010
    Messages:
    769
    Country:
    United States
    umm... WiiSX2.1 uses /wiisx/isos not PSXISOS, and there's a gui very similar to Wii64's that has a big "quit" button. Are you sure you had the latest version? It sounds like you're using the old no-gui 1.x version...
     
  8. giantpune

    Member giantpune GBAtemp Addict

    Joined:
    Apr 10, 2009
    Messages:
    2,860
    Country:
    United States
    yeah, i was building it from svn source which was making an older version. i just grabbed the source from the downloads section and its up-to-date. and it also exits back to the system menu without crashing. i dont have any games to test out.

    anyways, heres a version that writes the return-state stuff before it loads the emulator. so, it should start the system menu without showing the "press a" screen. http://pastie.org/1412237

    also should probably be noted that wii64/wiisx check argv[ 0 ] to see where they were started from ( usb or sd ). from that it determines where to load settings and save them and all this mumbojumbo. and they expect the same syntax that HBC uses for paths... "usb:/" or "sd:/". if these forwarder channels are using paths like "ntfs:/", "USB:/", or anything else that is not like HBC's then the emulator will not correctly determine where it was started from and default to saving/loading using the sd card.
     
  9. Skater4599

    Member Skater4599 GBAtemp Advanced Fan

    Joined:
    May 29, 2008
    Messages:
    939
    Location:
    United States
    Country:
    United States
    Thanks for these I like the changes you made! Just for clarification, when you say USB 2.0 enabled via IOS58, does that mean the forwarders are USB 2.0 or you made the emulators with USB 2.0 now as well?

    If the emu's are not USB 2.0 speeds, any chance you can incorporate your fix into matguitarists usb 2.0 mods? [​IMG] again, thank you and nice work!
     
  10. qwertymodo
    OP

    Member qwertymodo GBAtemp Advanced Fan

    Joined:
    Feb 1, 2010
    Messages:
    769
    Country:
    United States
    The emulators are based on matguitarist's IOS58 mod (fixed one of them to only reload IOS58 if AHBPROT was not enabled, the other one already had it). The forwarders are also USB2.0 via IOS58, and the channels have AHBPROT set in the tmd, so if you use the whole package, you get USB2.0 speed for the forwarder, the forwarder properly loads the emulator, and the emulator had USB2.0 speed and DVD access without the need for DVDX.

    @giantpune I looked into the forwarder a bit and it uses sdX:/ and usbX:/ where X is the partition number. I fixed that so it uses sd:/ and usb:/, but it doesn't seem to make any difference in regards to the rom directories not being found when loaded from your version of the forwarder (with that path fix) and the official releases of the emulators. The emulators will load and exit fine, but you can't actually USE them because it can't find the roms. Any thoughts? o_0
     
  11. dantemugiwara

    Newcomer dantemugiwara Advanced Member

    Joined:
    Jul 6, 2009
    Messages:
    83
    Country:
    Spain
    Does it work in wiisx beta 2.1???
    sure?
     
  12. qwertymodo
    OP

    Member qwertymodo GBAtemp Advanced Fan

    Joined:
    Feb 1, 2010
    Messages:
    769
    Country:
    United States
    Not with the official release (I'm going to optimistically insert a *yet* here...), but yes, these are the latest versions of the emulators (Wii64 1.1 "Honey" and WiiSX 2.1). The fixes involved patching the emulators themselves, and the patched versions are included in the packages. giantpune is helping me try to properly fix the forwarder so we can get it to load the official releases, but for now, this is the way it is. On the bright side, the patched emulators also include USB2.0 support and a minor button mapping improvement (you can now select the Home Button as the "Return to Menu" button for Wiimote/Nunchuck and Classic Controller).
     
  13. giantpune

    Member giantpune GBAtemp Addict

    Joined:
    Apr 10, 2009
    Messages:
    2,860
    Country:
    United States
    did you try to start the emulators with the official wiimc forwarder? i have only taken that and added a couple things to it. but nothing that should mess with the usb stuff at all.
     
  14. Skater4599

    Member Skater4599 GBAtemp Advanced Fan

    Joined:
    May 29, 2008
    Messages:
    939
    Location:
    United States
    Country:
    United States

    Thanks for the info, I tried this out and it works great, IMO everyone should be using the USB 2.0 mod anyway there is nothing to lose, only things to gain [​IMG]

    P.S. I compiled my own Nforwarder58 version forwarder and splash to test and it worked no problems (I could care less about DVD access)
     
  15. SuperTrever

    Member SuperTrever GBAtemp Regular

    Joined:
    Sep 20, 2010
    Messages:
    255
    Country:
    United States
    What do I do with the sources folder? [​IMG]
     
  16. qwertymodo
    OP

    Member qwertymodo GBAtemp Advanced Fan

    Joined:
    Feb 1, 2010
    Messages:
    769
    Country:
    United States
    Unless you want to try compiling it, you can ignore the sources folder. It's only there because of the licensing requirements of the GPL.
     
  17. Skater4599

    Member Skater4599 GBAtemp Advanced Fan

    Joined:
    May 29, 2008
    Messages:
    939
    Location:
    United States
    Country:
    United States
    Yeah i know most the work was done in the prog itself, was just letting you know it does work with other forwarders.
    Nforwarder58 is not an old version of wiimc forwarder, Narolez done a lot, they are infact very different, made for different things, nforwarder does not have AHBPROT flags, but it is faster to load stuff than WiiMC's is i've noticed, and smaller size .dol files, just a matter of preference I believe [​IMG]
     
  18. qwertymodo
    OP

    Member qwertymodo GBAtemp Advanced Fan

    Joined:
    Feb 1, 2010
    Messages:
    769
    Country:
    United States
    I know, it's really weird. Have you tried and/or succeeded in loading ROMs? Also, I'm not sure if it's just USB, it might just be having troubles loading directories, period. I'll have to throw some ROMs on my SD card and try it out to see if I get the same error.
     
  19. SuperTrever

    Member SuperTrever GBAtemp Regular

    Joined:
    Sep 20, 2010
    Messages:
    255
    Country:
    United States
    Okay. Also I downloaded a Playstation game and I got 3 different kinds of files, a CCD, ECM, and SUB. I can't get the game to work. Any tips?
     
  20. Skater4599

    Member Skater4599 GBAtemp Advanced Fan

    Joined:
    May 29, 2008
    Messages:
    939
    Location:
    United States
    Country:
    United States
    Ahh, actually that mforwarder is the source of 2 or 3 different forwarders with some small modifications on each, but includes all 3, one of which is WiiMC's old forwarder, but nforwarders is different

    at any rate, nice work man appreciate you sharing this [​IMG]
     

Share This Page