Windows 7 has terrible update system.

Discussion in 'Computer Games and General Discussion' started by Westside, Mar 30, 2011.

  1. Westside
    OP

    Westside Sogdiana

    Member
    2,905
    61
    Dec 18, 2004
    Uzbekistan
    Guantanamo bay
    My Windows 7 downloaded service pack which took 3 hours on my fire walled school server, and when it tried to install after the download it failed at 99%, now it is starting all over again. I can even stop the download... [​IMG]
     
  2. Dangy

    Dangy GBAtemp Maniac

    Member
    1,406
    15
    Apr 5, 2009
    United States
    Did you pirate Windows?
     
  3. Westside
    OP

    Westside Sogdiana

    Member
    2,905
    61
    Dec 18, 2004
    Uzbekistan
    Guantanamo bay
    I never pirate Windows.
     
  4. shadowkillerdrag

    shadowkillerdrag GBAtemp Regular

    Member
    171
    0
    Sep 27, 2007
    United States
    really o.o it updated fine on my pirated
    then again i wouldnt really do it with the school server -.- school server is annoying for blocking stupid crap
     
  5. twiztidsinz

    twiztidsinz Taiju Yamada Fan

    Member
    4,981
    5
    Dec 23, 2008
    United States
    I'd be more pissed that your schools internet is absolute SHIT than anything...


    Windows 7 SP1 is at most 533.1MB (44.0~533.1MB according to Windows update).

    My crappy connection downloads at a maximum of 180KB/s, though realistically I get ~150KB/s.
    533.1MB x 1024 = 545,894.4KB / 150KB/s = 3,639s or 60.65 minutes for my download.

    3hrs x 60 = 180min x 60 = 10,800sec. 545,894.4KB / 10,800 sec = 50.54KB/s is your download speed.
     
  6. TwinRetro

    TwinRetro Don't start nothin', Won't be nothin'

    Global Moderator
    6,181
    4,802
    Aug 29, 2008
    United States
    Las Vegas, NV
    Sounds like a connection problem. Windows 7 is not to blame here.
     
  7. Westside
    OP

    Westside Sogdiana

    Member
    2,905
    61
    Dec 18, 2004
    Uzbekistan
    Guantanamo bay
    Again, it downloaded 100%, it fucked up on 99% on the installation part. Instead of keeping the 900+MB setup files, it decided to re-download the mofo making me wait another 3 hours. It worked this time though. I'm just wondering why they can't let us use the already downloaded setup file...
     
  8. twiztidsinz

    twiztidsinz Taiju Yamada Fan

    Member
    4,981
    5
    Dec 23, 2008
    United States
    Usually when an installer fails, it's because the file is corrupted.
    Standard HTTP downloading has no verification so the whole thing had to be redownloaded.
     
  9. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,103
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters