Hacking WiiFlow + Excite Truck problem

twig123

Well-Known Member
OP
Member
Joined
Apr 4, 2009
Messages
261
Trophies
0
XP
246
Country
United States
Hey all,

I was just wondering if anyone else was having this issue, or if it is just me (or my configuration).
I had dx2 v7 and WiiFlow (v2 something) and every time I try to launch Excite Truck, it just goes to a black screen and freezes.
I used ModMii and re-updated everything. I now have dx2 v8 and the latest WiiFlow (v3), but I still get a black screen trying to load Excite Truck.

This was working previously, but I haven't played this game in a while.
I have updated my Wii once or twice since the last time I played, so I don't know when it stopped working...

For the heck of it, I installed Configurable USB Loader for the heck of testing... and whoosh! Excite Truck works!

I would really prefer to use WiiFlow.
Is this a bug with WiiFlow (anyone else having this problem?)?
or is there something botched in my settings somewhere?

Thanks
 

Kittymat

Well-Known Member
Member
Joined
Oct 16, 2008
Messages
589
Trophies
0
Location
UK
Website
Visit site
XP
181
Country
Do you use emu nand

If so turn it off on this game and try again

Put your emu nand on the usb device not on the sd and it should work#

See the d2x code.google page as I had this issue and both the above worked for me (using GX loader)
 

FIX94

Former Staff
Former Staff
Joined
Dec 3, 2009
Messages
7,284
Trophies
0
Age
28
Location
???
XP
11,224
Country
Germany
This game should run fine, but as the guy above said, turn of emulated saves, the game doesnt work otherwise. Also make sure you use a wiiflow mod rev, just look into the wiiflow help to check that.
 

twig123

Well-Known Member
OP
Member
Joined
Apr 4, 2009
Messages
261
Trophies
0
XP
246
Country
United States
I do have emunand for WiiFlow but that is only loading up my WiiWare/VC games from my USB drive.
I checked and I'm currently using WiiFlow v3.0a2 r425 (IOS249 base 56v8).
I looked at my general WiiFlow settings and "Emulation" setting is set to "Off" and the settings for the game itself is set to "Savegame Emulation" as "Default".

Any other ideas?
 

twig123

Well-Known Member
OP
Member
Joined
Apr 4, 2009
Messages
261
Trophies
0
XP
246
Country
United States
Heh, thats the regular wiiflow, here is a link to the mod rev.
Good lookin out man! That worked! (I had no idea there was a different version of WiiFlow out there)
I had to manually edit the ini file to pull the covers from usb1: instead of sd:
but hey, now I can play Excite Truck again! =)

Next thing...
How do I get my emu-nand with my Wiiware/VC that is on my usb back now?
(I recall having to change something in the config file... but I don't remember what)
 

twig123

Well-Known Member
OP
Member
Joined
Apr 4, 2009
Messages
261
Trophies
0
XP
246
Country
United States
How do I get my emu-nand with my Wiiware/VC that is on my usb back now?
(I recall having to change something in the config file... but I don't remember what)
Still looking for this.
I press B on the lower 2nd from right icon and it switches through a few things, but when it goes to USB1 NAND it appears to be just pulling up my Actual NAND. I have a lot more WiiWare/VC titles on my Emu-NAND, but the items displayed represent only the items installed on my actual nand.

USB Emu-NAND for WiiWare/VC works with the original WiiFlow that I had, but I can't figure out what setting I need to change for this to work the same way in WiiFlow MOD.

Also, I seem to be missing some of my save game data when I switched to WiiFlow Mod.
I assume that the missing saves are on my emu-nand, but is there a way to confirm this? what tool should I use to move them to the regular nand?
I found SaveGame Manager GX and was able to determine the saves were on my SD card instead of USB.
 

twig123

Well-Known Member
OP
Member
Joined
Apr 4, 2009
Messages
261
Trophies
0
XP
246
Country
United States
Thanks for the info. I have Excite Truck working from Actual Nand, but I can't figure out how to get access to my Wiiware/VC on my USB Emu-Nand. When I select the Emu-Nand on USB it only shows my actualy nand titles. Testing with the old original WiiFlow, it reads the correct titles on the USB emu-nand but I can only get WiiFlow Mod to load Actual Nand titles.
 

Ape8000

Well-Known Member
Member
Joined
Feb 26, 2011
Messages
295
Trophies
1
XP
837
Country
United States
Looks like you just can't use an existing save to make Excite Truck work. It will crash if you try to go further then the last save point. :(

Both NTSC & PAL need emuNAND saves turned off.
 

twig123

Well-Known Member
OP
Member
Joined
Apr 4, 2009
Messages
261
Trophies
0
XP
246
Country
United States
Looks like you just can't use an existing save to make Excite Truck work. It will crash if you try to go further then the last save point. :(
Not sure if you are trying to get it working for yourself, but mine is back to working:
I have Excite Truck working from Actual Nand, but I can't figure out how to get access to my Wiiware/VC on my USB Emu-Nand.
My current issue is getting WiiWare/VC on my USB drive to be seen by WiiFlow Mod...
 

twig123

Well-Known Member
OP
Member
Joined
Apr 4, 2009
Messages
261
Trophies
0
XP
246
Country
United States
I can't figure out how to get access to my Wiiware/VC on my USB Emu-Nand. When I select the Emu-Nand on USB it only shows my actualy nand titles. Testing with the old original WiiFlow, it reads the correct titles on the USB emu-nand but I can only get WiiFlow Mod to load Actual Nand titles.
Came back to follow up with this issue.
Good news and bad news...

Good news, I figured out what the problem was and fixed it
Bad news, it no longer works... because my hard drive died from all of the pluggin/unplugging of it *sigh*

Anyways, I found the issue to my Emu-Nand not loading properly to be an issue with the Wiiflow.ini file.
The solution was as missing "/" under the [NAND] heading in the Wiiflow.ini file.
my "path" listing was set to: "path=/wiiflow/nandemu" (without the quotes)
With this setting, my Emu-Nand seemed to redirect to the Actual-Nand.

To resolve the issue add a trailing "/" to the "path":
"path=/wiiflow/nandemu/" (without the quotes)
Doing this let wiiflow load up all of my Emu-Nand goodies like it should.

I'm not quite sure why the "/" was missing in the first place, but now you know... and knowing is half the battle!
 

FIX94

Former Staff
Former Staff
Joined
Dec 3, 2009
Messages
7,284
Trophies
0
Age
28
Location
???
XP
11,224
Country
Germany
Thats a known thing that it sometimes with with and sometimes without, we need some wiki that people know it :P
 

twig123

Well-Known Member
OP
Member
Joined
Apr 4, 2009
Messages
261
Trophies
0
XP
246
Country
United States
I'm not sure, but I think that path was created as the default in the ini (back on r215 when i installed it).
...but either way, know I know exactly what the problem is ;)
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
  • K3N1 @ K3N1:
    Alot of users just want it for attention tbh
    +1
  • K3N1 @ K3N1:
    I know a forum that said if you're good and don't ask you usually get it
    +1
  • DinohScene @ DinohScene:
    you mean this forum?
    +1
  • K3N1 @ K3N1:
    Nah others
    +1
  • M4x1mumReZ @ M4x1mumReZ:
    You know what they say, I want never gets.
  • K3N1 @ K3N1:
    Iirc temp usually votes people in or holds an application every once in a blue moon
    +1
  • DinohScene @ DinohScene:
    ^ that
    +1
  • K3N1 @ K3N1:
    They're pretty good at hiring the sexy ones
    +1
  • M4x1mumReZ @ M4x1mumReZ:
    Inc. Dinoh
  • K3N1 @ K3N1:
    550k members and only about a dozen staff they hold their own pretty well
    +1
  • K3N1 @ K3N1:
    Stupid region locked digital keys are the dumbest thing next gen consoles have come up with
    +1
  • K3N1 @ K3N1:
    @DinohScene, that Xbox code ever work?
    +1
  • DinohScene @ DinohScene:
    yeh it was the PC version of 76
    +1
  • DinohScene @ DinohScene:
    regardless, the hubby took it : D
    +1
  • K3N1 @ K3N1:
    lawl the site said xbox
    +1
  • M4x1mumReZ @ M4x1mumReZ:
    Was given a PC Game Pass key for free on Temp, didn't work because region locking. :(
  • M4x1mumReZ @ M4x1mumReZ:
    Or as I like to call it, RACISM.
  • x65943 @ x65943:
    Now for someone to hack that thing and make pixel pr0n
    +1
  • M4x1mumReZ @ M4x1mumReZ:
    It maybe possible.
  • K3N1 @ K3N1:
    Will be perfect for onlyfans links
    +1
  • K3N1 @ K3N1:
    Gamers: I bet your 4k oled ain't a jump rop
    +1
  • Shape @ Shape:
    No, but I can take my OLED jump rope for a 4k
  • Shape @ Shape:
    That's a race.
  • Psionic Roshambo @ Psionic Roshambo:
    Someone needs to take over a hundred or two of my Facebook girls lol
    Psionic Roshambo @ Psionic Roshambo: Someone needs to take over a hundred or two of my Facebook girls lol