Wii WBFS Backups aren't working on any loader?

Discussion in 'Wii - Backup Loaders' started by Evan177, Jul 13, 2015.

  1. Evan177
    OP

    Evan177 Member

    Newcomer
    14
    1
    Aug 4, 2014
    United States
    I didnt play my backups for about a year and now I cant remember how to get them to work?
    I usually use USB Loader GX and it isnt working.
    I also tried Wii Flow and the same thing happened.

    The problem is when I select a game I either just get a black screen or usually I get a green screen that is glitching out and there is a very loud "Buzzing, malfunctioning, high pitch sound" that doesnt go away and I have to restart the wii.

    I recently tried to update USB Loader GX and also download the latest Wii Flow but it made it worse.
    I think it has something to do with an outdated version of homebrew or USBLoader GX.
    And yes, I have perfect backups that are installed correctly onto my USB.

    Wii version: 4.3u
    Homebrew version: IOS58 v24.32
    USB Loader Version: Rev1239 IOS249 (Rev 20) . AHB

    And help would be greatly appreciated!
    Thanks to who ever helps, and thanks GBATEMP for all the info I need to find!
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,094
    8,591
    Oct 27, 2002
    France
    Engine room, learning
    first, to be sure what you mean, your HDD partition is WBFS?
    or FAT32 with wbfs files on it?


    WBFS partition cannot have "perfect backups that are installed correctly onto my USB" because that partition format corrupts itself.... yeah, that's really bad but adding a game has the bad habit to corrupt already present games on that partition.
    You can be only sure that the last added game is "perfect backup" (or better "perfectly copied", as it can still be a bad backup you copied).
    So, Don't rely on thinking it's perfect because it was. It was only, it's not necessarily still good.


    You have :
    USBLoaderGX revision 1239 (that's fine)
    cIOS rev 20 (that's old, and this version is bad)
    WBFS partition (that's semi-bad. It works, but don't rely on it)

    What you should do:
    1. update your softmod
    Download d2x installer for Wii (complete package)
    Extract it to your apps/ folder. You can create a new subfolder, you need this layout:

    sd:/apps/d2x_installer/boot.dol
    sd:/apps/d2x_installer/meta.xml
    sd:/apps/d2x_installer/icon.png
    sd:/apps/d2x_installer/ciosmaps.xml
    sd:/apps/d2x_installer/a folder for d2x v8
    sd:/apps/d2x_installer/a folder for d2x v10
    sd:/apps/d2x_installer/more folders
    Launch the installer from HBC, and install this:
    (press dPad to select the following options, then press A to install)

    what: d2x v8 final
    where: 249
    base: 56
    version: 21008

    and

    what: d2x v8 final
    where: 250
    base: 57
    version: 21008
    Done.

    2. verify your drive
    At this state, you can try your HDD again.
    not all games should be corrupted if you use WBFS partition. A lot of them should still work.
    if none of them work, then you should try a different drive, or format this one if you can.

    Format it to FAT32 ! (not WBFS)
    you can use WiiBackupManager program to format to FAT32 (windows will refuse to format a partition bigger than 32GB)
    Then use that same program to install your ISO to the HDD. the program will convert the ISO to the wbfs file format, and will automatically split in two parts any games bigger than 4GB.

    Launch the loader again, reset the settings or force a partition remount (settings>hdd menu>first option)
     
  3. Evan177
    OP

    Evan177 Member

    Newcomer
    14
    1
    Aug 4, 2014
    United States

     
  4. Evan177
    OP

    Evan177 Member

    Newcomer
    14
    1
    Aug 4, 2014
    United States
    I did all the steps and also formatted a new USB to the FAT32 and used Wii Backup Manager to add the games.
    Do I need to change any setting in USB Loader GX? The games still load into a black screen?
     
  5. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    3,970
    769
    Mar 2, 2015
    United States
    Try re-ripping one of the games that isn't working. If you copied them off of the WBFS partition they will still be corrupted.
     
  6. Evan177
    OP

    Evan177 Member

    Newcomer
    14
    1
    Aug 4, 2014
    United States
    I have all my ISO's saved on my computers hard drive so that shouldnt be the case. I have tried formating and using a different USB, cant figure it out?
     
  7. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,094
    8,591
    Oct 27, 2002
    France
    Engine room, learning
    you installed cIOS d2x?
    it's strange that it's still not working.
    Maybe you connected the drive to the wrong USB port? (but the loader shouldn't list games at all)
    Or your drive doesn't have enough power (try external power ? or YCable?)

    you can also try to format in NTFS and copy the ISO instead of converting to wbfs files. (but the partition format or file format shouldn't matter)
     
  8. Evan177
    OP

    Evan177 Member

    Newcomer
    14
    1
    Aug 4, 2014
    United States
    Where would I check that I installed it correct? And

    Yeah I installed everything just with the exact variables like you said to do. Does it have to do with the way I set up the folders?

    You had
    sd:/apps/d2x_installer/boot.dol
    sd:/apps/d2x_installer/meta.xml
    sd:/apps/d2x_installer/icon.png
    sd:/apps/d2x_installer/ciosmaps.xml
    sd:/apps/d2x_installer/a folder for d2x v8
    sd:/apps/d2x_installer/a folder for d2x v10
    sd:/apps/d2x_installer/more folders

    And I set up my like this:
    sd:/apps/d2x_installer/boot.dol
    sd:/apps/d2x_installer/meta.xml
    sd:/apps/d2x_installer/icon.png
    sd:/apps/d2x_installer/ciosmaps.xml
    sd:/apps/d2x_installer/V8
    sd:/apps/d2x_installer/V10
    sd:/apps/d2x_installer/V7

    Would that all still work right? The program opened on the Wii and everything seemed to install correctly, no errors.


    Also

    — Posts automatically merged - Please don't double post! —

    BTW, when I try to load the games it is either a green Screen with that buzzing sound or recently its been a black screen with white code. And it says "restarting in 20 seconds".
     
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,094
    8,591
    Oct 27, 2002
    France
    Engine room, learning
    yes that's file (I just didn't remember the correct folder names).
    If you installed the correct cIOS version and base I told you into the correct slots, then the loader should display it.

    Launch USBLoaderGX > settings > Credit
    look at the top right, it should now tell you that you are using IOS249, than inside that slot you have d2x v8 base 56.
    If it still tells you "cIOS 249 rev20" then you didn't install it into your Wii, or in the wrong slots.


    What's happening is strange. there's no indication of what could be the issue.
    try updating the loader too, I released r1253 today.
     
  10. Evan177
    OP

    Evan177 Member

    Newcomer
    14
    1
    Aug 4, 2014
    United States
    I'll let you know if it works when I get home from work and update that Loader, thanks for the help guys!
     
  11. Evan177
    OP

    Evan177 Member

    Newcomer
    14
    1
    Aug 4, 2014
    United States
    I tried everything and still can't seem to get it to work? Do you have any other ideas? USB Loader is updated and everything is on the version you said (I looked on the credits)
    The games in USB Loader GX have a black preview before I hit play and then takes me to a black screen.
     
  12. Evan177
    OP

    Evan177 Member

    Newcomer
    14
    1
    Aug 4, 2014
    United States
    Nevermind I think I figured it out! I used all the same setting but I used WBFS manager to transfer the games onto the USB and all the games started working! THANKS CYAN!
     
  13. tswntk

    tswntk GBAtemp Advanced Fan

    Member
    648
    136
    Aug 6, 2012
    Switzerland
    WBFS manager? so you are using a WBFS partition which is not recommended? You will get into problems sooner or later if you keep adding games to it like Cyan explained.
    use wbfs2fat (link at Cyan's signature) to convert it to FAT32 partition.

    I know you have tried FAT32 partition before but there must be something wrong in your setup if it didn't worked.

    Post a syscheck log (again link at Cyan's signature) and copy the exact wording in USB Loader GX's credit page for further help unless you are really satisfied with WBFS partition.
     
  14. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,094
    8,591
    Oct 27, 2002
    France
    Engine room, learning
    if you really want to keep using WBFS partition format, please don't use WBFS Manager!
    Use WiiBackupManager, it works with WBFS partition too, not only FAT32/NTFS, and doesn't have the "corrupt already installed game" bug.

    Black banner is usually a symptom of corrupted/badly installed games, the ISO couldn't be mounted to extract the banner from it.
     
  15. Cmjsmith10

    Cmjsmith10 Advanced Member

    Newcomer
    71
    2
    Jul 16, 2015
    United States
    i hacked my wii and installed usb uploader, cfg uploader ,and wii flow. i can play all of my backups just fine except WarioWars and Mario Kart. When I push to play it returns me back to the Main system screen. But thats the only games it does it on. Not sure how to do a system check i'm really new to this. Did I not do something right when I set it up. I followed techman on youtubes tutorial. this address:
    Right now all of my games run off of a 16gb flashdrive my harddrive arrives next week and i want to convert over. Can I do this and not lose my games. I have some I downloaded but when i put them on a different usb because the other one is full they want show up at all in any of the uploaders. My system is 4.1U. I thought the games were bad copies at first so I borrowed my friends copy and same issue still returns to main system screen. Please Help.
     
  16. Evan177
    OP

    Evan177 Member

    Newcomer
    14
    1
    Aug 4, 2014
    United States
    You won't need to lose any of your games, just plug your new USB and old USB in to the computer at the same time and transfer the games over with Wii Backup Manager.

    As for warioware smooth moves I can't seem to get that one game to load either

    And you can check the version on USB Loader GX if you are using that.
    Setting > far right > credits > top right of credits. Type that stuff out
     
  17. Cmjsmith10

    Cmjsmith10 Advanced Member

    Newcomer
    71
    2
    Jul 16, 2015
    United States
    I have Rev 1253 IOS 249 (Rev19).