1. mitchjn

    OP mitchjn Newbie
    Newcomer

    Joined:
    Jan 24, 2011
    Messages:
    6
    Country:
    United States
    I'm curios if anyone has had any similar issues to this.

    My wii u gamepads X button doesn't respond. The rubber pads were in good shape so I ordered the Conductive Film Key Button Ribbon replaced it and I am still having the same problem. I also noticed that when I play mario kart 8 it is still somehow being triggered automatically because when the race starts it switches to the reverse camera and I am unable to switch it back (X is the button for reverse camera).

    My next guess is to make sure all the connections inside the controller are in good order otherwise I'm guessing I need to replace the mainboard but figured I would post a message here to see if anyone has ever had a similar experience.

    Thanks
     
  2. victorhidalgo

    victorhidalgo Member
    Newcomer

    Joined:
    Nov 30, 2016
    Messages:
    26
    Country:
    Dear mitchjn

    I inform you that I have the same problem and that I can solve it. There are games that require that key and failed to play it. When I run the Homebrew Launcher it returns and it does not run.


    And to run Loadiine I should turn off the gamepad and use the wii U pro controller.


    I do the same with the mario kart 8.
    I connected the game with PC with UsendMii and the key X is pressed constantly.

    If you find any solutions please let me know.
     
    Last edited by victorhidalgo, Apr 27, 2017
  3. Deleted User

    Deleted User Newbie

    Unscrew your Wii U, something got below your button.
    I once had it but it fixed itself because i spilled champagne over it.
     
  4. mitchjn

    OP mitchjn Newbie
    Newcomer

    Joined:
    Jan 24, 2011
    Messages:
    6
    Country:
    United States

    Thats initially what I was thinking all it was. But have determined its more than this. I have even had the controller torn apart with the Conductive Film Key Button Ribbon disconnected and it still does it. So I'm thinking its something with the motherboard on the gamepad.
     
    Last edited by mitchjn, Apr 27, 2017
  5. victorhidalgo

    victorhidalgo Member
    Newcomer

    Joined:
    Nov 30, 2016
    Messages:
    26
    Country:
    Already disarmed and cleaned. Everything looks good but still the same.
     
  6. Deleted User

    Deleted User Newbie

    Check X button plate. If it's kinda mashed down then that's your issue.
     
  7. mitchjn

    OP mitchjn Newbie
    Newcomer

    Joined:
    Jan 24, 2011
    Messages:
    6
    Country:
    United States
    No, its nothing to do with the buttons or the rubber pads behind them or the sensors behind them they are all clean. And I have even tested the controller with the ribbon cable disconnected from the part shown below for the buttons and somehow the X button is still being triggered.
     

    Attached Files:

    • film.jpg
      film.jpg
      File size:
      40.3 KB
      Views:
      227
  8. victorhidalgo

    victorhidalgo Member
    Newcomer

    Joined:
    Nov 30, 2016
    Messages:
    26
    Country:
    Dear mitchjn:
    I want to inform you of the problem, it is a false contact on the ribbon of the buttons.

    [​IMG]

    I used soldering paste on the terminals and reconnected them to the gamepad and solved the problem.

    I hope this helps other people.
    [​IMG]
     
  9. mitchjn

    OP mitchjn Newbie
    Newcomer

    Joined:
    Jan 24, 2011
    Messages:
    6
    Country:
    United States
    Im unsure if its the same for my case. Ive replaced the entire button ribbon and it still does it. I've even had the ribbon completely disconnected and turned the controller on and its like the X button is still being held down at all times.
     
  10. hyper2088

    hyper2088 Newbie
    Newcomer

    Joined:
    May 25, 2017
    Messages:
    1
    Country:
    United States
    i have the same probleme..i install batman orgin and failed to install..(wupinstaller) ..now my R trigger is stuck..i restard the wiiU and is working..now i install injustice (wupinstaller) install complete..R trigger is stuck..restart the wiiU 1000 times still stuck..reset wiiU delete all content still stuck..i think is a software problem..maybe mine console is brick..is update automatic..can someone help..
     
  11. victorhidalgo

    victorhidalgo Member
    Newcomer

    Joined:
    Nov 30, 2016
    Messages:
    26
    Country:
    I heard, but I do not remember where, that when the console is updated the gamepad does not, it still has the original version of the software installed. But there is the console has inside the gamepad firmware.

    There is a way to force the console to update the gamepad firmware, but I do not know how to do that.

    This may be a solution.
     
  12. Trylk248

    Trylk248 Honest helper and custom content creator.
    Member

    Joined:
    Oct 31, 2012
    Messages:
    295
    Country:
    Canada
    Wait... Champagne?!
     
  13. Zhero

    Zhero Newbie
    Newcomer

    Joined:
    Jul 18, 2020
    Messages:
    1
    Country:
    Ecuador
    @mithjn I have exactly the same problem. Did you solve it?
     
  14. victorhidalgo

    victorhidalgo Member
    Newcomer

    Joined:
    Nov 30, 2016
    Messages:
    26
    Country:
    No.
     
  15. wickedweed

    wickedweed Newbie
    Newcomer

    Joined:
    Aug 10, 2020
    Messages:
    1
    Country:
    Singapore
    I have the exact problem with the Z button which seems to be pressed all the time. I tested the button with a multimeter and it is working fine. Seems to be a software issue that likely happened after i started installing gamecube games. Havent found a solution to the problem though...
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - gamepad, button, weird