Hacking Question Why won't Switch boot SX OS?

Dan_2845

New Member
OP
Newbie
Joined
Aug 4, 2020
Messages
3
Trophies
0
Age
40
XP
22
Country
United States
I have 2 Switches, and 2 SX Pro dongles, one boots as it should into SX OS and shows the correct functionality in the album section. The other boots to the boot loader but when I select "custom FW" the screen just goes black and nothing happens. Both SD cards were formatted the same and both licenses are for the correct devices but it just won't boot. Anything that might cause this?
 

MasterJ360

Well-Known Member
Member
Joined
Jan 10, 2016
Messages
2,330
Trophies
1
Age
32
XP
2,360
Country
United States
Gonna need more history info what you did with the switch thats getting a blackscreen. A blackscreen can be caused by many things
 

Dan_2845

New Member
OP
Newbie
Joined
Aug 4, 2020
Messages
3
Trophies
0
Age
40
XP
22
Country
United States
I've tried a different SD card with the same result.

The one getting the black screen was setup in exactly the same way as the other one, what history would be relevant?

Firmware, I'm not sure, I did consider that but if it was firmware that was the problem it wouldn't boot to the FW selection screen would it? I don't have them here to check but could the firmware allow boot to the selection screen but not the actual firmware?

SX OS is running the latest version as at 8 weeks ago, downloaded from the site. Again, both running identical versions. (I don't have the Switch here to tell you exactly but I can check when I get home if this may be the problem)
 

MasterJ360

Well-Known Member
Member
Joined
Jan 10, 2016
Messages
2,330
Trophies
1
Age
32
XP
2,360
Country
United States
If you want ppl to help you, you need to list as much information as possible so that they can be relevant in solving the problem. Firmware definitely matters b/c the sxos bin file may not be compatible to the said firmware and the latest sxos was not distributed 8 weeks ago.
 

Dan_2845

New Member
OP
Newbie
Joined
Aug 4, 2020
Messages
3
Trophies
0
Age
40
XP
22
Country
United States
I realise that, as I said I don't have it here and can get that information later. I also meant I downloaded it 8 weeks ago, not that it was released 8 weeks ago.

My question in the last post was is it possible that it could boot to the firmware selection screen but not the custom firmware if the device firmware is the issue? My understanding is that it would not boot to the selection screen?
 

MasterJ360

Well-Known Member
Member
Joined
Jan 10, 2016
Messages
2,330
Trophies
1
Age
32
XP
2,360
Country
United States
Firmware selection screen is a rcm payload using the dongle, the boot file isn't loaded till you hit cfw or emunand.
You do need the boot file when using the sxos payload b/c it auto scans for it thus getting you into the firmware selection
 

Reecey

Mario 64 (favorite game of all time)
Member
Joined
Mar 7, 2010
Messages
5,866
Trophies
0
Location
At Home :)
XP
3,545
Country
Sounds like to me you’re Firmware is not compatible with the boot file. Have you got the latest sxos beta file on your SD Card you’re not using the stable version that’s very old now and won’t work
 

T3chni

Member
Newcomer
Joined
Jul 6, 2020
Messages
12
Trophies
0
Age
35
XP
44
Country
United Kingdom
Sounds like to me you’re Firmware is not compatible with the boot file. Have you got the latest sxos beta file on your SD Card you’re not using the stable version that’s very old now and won’t work
Omg I actually love you! I've just installed a core myself and have been facing the glorious angry boot.dat screen, searching the forums made me think I had a half faulty sd slot! Ive tried all sorts including swapping SDs, re-installing the nand into the normal slot to boot and check the SD functions in non-hack mode. Ensuring the SD doesn't have any odd partitions, I was this close to trying the "beta sxos" but really thought the "stable release" sounded like the right stuff to use! :wacko:

Anyways thanks for posting this Im so glad I didn't have to play the SD slot find, replace and pray game!
 
  • Like
Reactions: Reecey

Reecey

Mario 64 (favorite game of all time)
Member
Joined
Mar 7, 2010
Messages
5,866
Trophies
0
Location
At Home :)
XP
3,545
Country
Omg I actually love you! I've just installed a core myself and have been facing the glorious angry boot.dat screen, searching the forums made me think I had a half faulty sd slot! Ive tried all sorts including swapping SDs, re-installing the nand into the normal slot to boot and check the SD functions in non-hack mode. Ensuring the SD doesn't have any odd partitions, I was this close to trying the "beta sxos" but really thought the "stable release" sounded like the right stuff to use! :wacko:

Anyways thanks for posting this Im so glad I didn't have to play the SD slot find, replace and pray game!
I’m so pleased you got your switch working and your reply made every bit worth while, worded beautifully!
 
  • Like
Reactions: T3chni
General chit-chat
Help Users
    Julie_Pilgrim @ Julie_Pilgrim: install gentoo instead