Why do we need backup launcher version .1?

Discussion in 'Wii - Hacking' started by mikej3131, Nov 6, 2008.

  1. mikej3131
    OP

    mikej3131 Advanced Member

    Newcomer
    56
    0
    Mar 31, 2008
    United States
    i see that djtaz has a howto section to get .1 loaded so we can now run both versions. Whats the benefit of this?

    Also what is softchip backuplauncher? and do i have to wait for version .4 for warioland shake it to work?
     
  2. BIG MOE

    BIG MOE ๔*๖ LORD BIG MOE ™

    Member
    1,253
    0
    Oct 19, 2008
    Syria
    Wiiland Hills
    some games that worked with v0.1 and didn't work with v0.3 is the reason to have both loaders up and running at least til Wiigators new release get ready , the softchip one is a bugfix kind of and it still in beta as well , warioland is working according to a post somewhere on the softchip thread just look for it , I don't have it on hand so I cann't tell you .
     
  3. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    At the moment you don't need it. You don't ever need any backuploader. There are some games not working with 0.3b, but working with 0.1. If you want to use a 0.1 loader try my mod. You can find it here: http://gbatemp.net/index.php?showtopic=112885

    SoftChip is another loader using the same cios and dip module as Wiigator's 0.3(should be an exact match which games work and which not, but this is just a suggestion). It only has 1:1 compatibility, but is very promising.
     
  4. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    SoftChip isn't a bugfix! It's a completely new written loader!

    There's a bugfix for the 0.3b loader, which solves many issues which appear in the middle of the games.
     
  5. djtaz

    djtaz PM's Full - Wadder Me

    Member
    2,997
    2
    Sep 21, 2008
    As above , all credit for that goes to WiiPower.

    My system is slightly different but its based on the same idea and i think WiiPowers works for more people and more games
     
  6. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Sorry, but i had just a simple idea and coded something(very simple) together. The only things really worth credit are Wiigator's loader and cios on the one side and the bugfix by requiem4d on the other side.
     
  7. mikej3131
    OP

    mikej3131 Advanced Member

    Newcomer
    56
    0
    Mar 31, 2008
    United States
    hmm ok so many diff answers. let me ask a more simple question. I used djtaz's howto to get backuplauncher .3 on my wii about a week ago. Now what would be the best thing for me to do in terms of compatibility with games? Is the softchip going to give me a much better compatibility if i use that? I want to backup my warioland shake it for sure

    and what is this bugfix you keep mentioning. what was the bug?
     
  8. BIG MOE

    BIG MOE ๔*๖ LORD BIG MOE ™

    Member
    1,253
    0
    Oct 19, 2008
    Syria
    Wiiland Hills
    sorry I thought v0.3b the one he was talking about , thanks for correcting me .
     
  9. mikej3131
    OP

    mikej3131 Advanced Member

    Newcomer
    56
    0
    Mar 31, 2008
    United States
    oops i think i instaklled the .3 alpha. how do i check which version i have?


    i think this because when i used djtaz's setup, this is what i clicked on to get the files
    Oct 23rd UPDATE FIX : (new) Here
    Filename : 3.3u_Update_Fix_____WITH_out______IOS16.zip
     
  10. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Best compatibilty would be achived when you use 0.3 cIOS for Wiigator 0.3b and cios_fix(0.1 cIOS) for Wiigator 0.1. Just make sure your loader "points" to the right IOS.

    I recommend the setup as i described it here:
    http://gbatemp.net/index.php?showtopic=112885

    Be sure to grab an Wiigator 0.3b entryholder fix version for 0.3b.

    With "my setup" you would also have the advantage to use Waninkoko's loader and SoftChip(if you are able to compile it by yourself to use IOS247) too.
     
  11. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
  12. mikej3131
    OP

    mikej3131 Advanced Member

    Newcomer
    56
    0
    Mar 31, 2008
    United States
    well i think i have the alpha .3. How can i check?

    this is what i used...
     
  13. Meowayne

    Meowayne GBAtemp Regular

    Member
    270
    0
    Sep 22, 2008
    Gambia, The
    What exactly is this entryholder fix?
     
  14. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    The entryholder stored the entrypoint for the loader in the memory with this:
    memcpy((void*)0x817f0000, entryholder, 4); // entrypoint

    The fix is to remove it completely, because it's not needed. It fixes several issues with many games. For example Disaster:Day of Crisis stage 8 crash and some others in other games appearing somewhere during gameplay.
     
  15. knowitall599

    knowitall599 Banned

    Banned
    213
    0
    Oct 1, 2008
    United States
    This is a misunderstanding and it is not necessarily the complete truth. This is understandable, but I believe someone is overlooking something of why this works; some games like SSX Blur still do not work. My fix may, in time, answer this question this question and many more as they emerge.
     
  16. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Not this thread, too. Do you want fish? What's your favorite?
     
  17. mikej3131
    OP

    mikej3131 Advanced Member

    Newcomer
    56
    0
    Mar 31, 2008
    United States
    hmm no reply/answer for me [​IMG]
     
  18. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Just stick to my guide if you want both 0.1 and 0.3b:
    http://gbatemp.net/index.php?showtopic=112885

    IOS247 for 0.3b and IOS249 for 0.1. This way you can use Waninkoko's loader too. If you can compile it yourself or you can get somebody doing it for you, you could persue SoftChip to use IOS247(works fo me) and this will work, too.