what psp?

Discussion in 'PSP - Games & Content' started by fice3717, Aug 31, 2010.

  1. fice3717
    OP

    fice3717 Advanced Member

    Newcomer
    58
    0
    Jul 7, 2009
    United States
    hey guys i was just wondering what is the best psp model to get if i want to use the Pandora battery? i know all the old phat models work but i herd the newest custom firmware doesn't work in the phat models? and im to frightened to get a slim model because it might not be the hackable one? and also what do i need to know about if i want to play psp iso's on it
     
  2. FlashX007

    FlashX007 GBAtemp Maniac

    Newcomer
    1,295
    5
    May 3, 2009
    United States
    I am currently running PSP 1000 w/Pandora Battery + 5.50 Prometheus CFW which is the latest. Either that or 5.00 M33. Depends on the user. Anyways I have had no problems so far except for cheats and ISO/CSO. I recommend you getting a 1000 because they are cheaper and have a 100% hack guarantee and they are strong. By that I mean if you drop it or do something along those lines by accident of course then you won't have any problems. The thing is like a brick. On the other hand a PSP 2000 has a new design as in it is slim and more comfortable but if you do something then I doubt it will have the same durability.
     
  3. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Pandora battery works with every fat model.

    The firmware thing is for a different exploit that doesn't involve the battery.
     
  4. fice3717
    OP

    fice3717 Advanced Member

    Newcomer
    58
    0
    Jul 7, 2009
    United States
    so is there any compatibility difference with the iso's/hombrew between the psp 1000 or and the 2000 because iv herd that the old 1000 models cant get the latest custom firmware
     
  5. Jolan

    Jolan Unlimited Bear Works

    Member
    1,385
    7
    Mar 20, 2010
    Netherlands, currently
    WEll you heard wrong.
     
  6. thedicemaster

    thedicemaster GBAtemp Addict

    Member
    2,428
    15
    Apr 26, 2008
    Netherlands
    it's rather the opposite.
    newer 2000's and all 3000's are unable to get the latest cfw(they are stuck on 5.03 based semi-cfw's that are reverted to ofw when turned off, and only work on ofw5.03)
    only "incompatibility" i know of regarding 1000's is that some emulators are slower because of less RAM, and no multitasking option with irshell.