What firmware should I update to?

Discussion in 'PSP - Hacking & Homebrew' started by naved.islam14, Nov 27, 2011.

Nov 27, 2011
  1. naved.islam14
    OP

    Member naved.islam14 Gbatemp's Official Dark Knight™

    Joined:
    Sep 12, 2009
    Messages:
    968
    Location:
    Gotham
    Country:
    Sri Lanka
    Well it's been a long time since I updated my PSP (it's currently on 5.50 GEN-D3), so is there any firmware I should update to, because some of the new games I want to play don't run on my PSP (I play a few new games and many many old PSP game).
    I was thinking of updating to 6.60 Pro-B10 so should I?
     
  2. kevan

    Member kevan Imagination rules the world

    Joined:
    Dec 4, 2009
    Messages:
    1,378
    Location:
    Place
    Country:
    Australia
    Well I got 6.20 PRO B-9 and it works like a charm. But might aswell go a high as you can ;)
     
  3. naved.islam14
    OP

    Member naved.islam14 Gbatemp's Official Dark Knight™

    Joined:
    Sep 12, 2009
    Messages:
    968
    Location:
    Gotham
    Country:
    Sri Lanka
    Thanks I'll update to 6.20 PRO B-9 and if it doesn't work I'll update to 6.60 Pro-B10.
     
  4. MadHouse38

    Member MadHouse38 GBAtemp Regular

    Joined:
    Nov 23, 2011
    Messages:
    243
    Location:
    Gaming room.
    Country:
    Yugoslavia
    I first got 6.60 pro b9 but i updated to 6.60 pro b10 and its cool,they fixed some bugs i think.
     
  5. Alex658

    Member Alex658 GBAtemp Advanced Fan

    Joined:
    Jun 4, 2010
    Messages:
    669
    Location:
    Venezuela
    Country:
    Venezuela
    You may as well go for the Perma solution to all psp's...

    Which is 6.20 PRO B10. (Permanent Patch)
    No need to use fast recovery and works for ALL psp's regardless of model.
     
  6. naved.islam14
    OP

    Member naved.islam14 Gbatemp's Official Dark Knight™

    Joined:
    Sep 12, 2009
    Messages:
    968
    Location:
    Gotham
    Country:
    Sri Lanka
    Now I have another problem, whenever I try to update to 6.20 OFW it says I'm already on the latest version when I am not (It says I'm on 9.90, when I'm on 5.50), so what can I do?
     
  7. ars25

    Member ars25 I like tacos and pie

    Joined:
    Oct 21, 2010
    Messages:
    800
    Location:
    the world that never was
    Country:
    United States
    you need to flash a ofw
     
  8. naved.islam14
    OP

    Member naved.islam14 Gbatemp's Official Dark Knight™

    Joined:
    Sep 12, 2009
    Messages:
    968
    Location:
    Gotham
    Country:
    Sri Lanka
    How to do that?
     
  9. zygie

    Member zygie GBAtemp Regular

    Joined:
    Apr 16, 2009
    Messages:
    180
    Country:
    Philippines
    I'm taking you're already trying to update to 6.20 but can't?

    Disable all plugins first, to be safe.
    Disable version.txt in your CFW. Try to update to 620 OFW.
    If that doesn't work, you have to access flash0 and edit version.txt yourself, make "9.90" to your real version, "5.50". Don't touch anything else and be careful around flash0, bricks come from meddling with those files.
    If that doesn't work, well, beats me.
     
  10. naved.islam14
    OP

    Member naved.islam14 Gbatemp's Official Dark Knight™

    Joined:
    Sep 12, 2009
    Messages:
    968
    Location:
    Gotham
    Country:
    Sri Lanka
    Can't I just use my pandora battery to downgrade to another OFW?

    EDIT: Nevermind, your method worked zygie, thanks!
     

Share This Page