Discussion Well, I have another problem.

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by mikechris33, May 20, 2018.

  1. Centergaming

    Centergaming GBAtemp Advanced Fan

    Member
    6
    Apr 17, 2016
    United States
    Wait until they have a User-friendly guide.
     
  2. mikechris33
    OP

    mikechris33 Advanced Member

    Newcomer
    2
    Jan 31, 2018
    United States
    ok.
     
  3. mikechris33
    OP

    mikechris33 Advanced Member

    Newcomer
    2
    Jan 31, 2018
    United States
    Im now using this website on chrome and the result is a bit different.

    "Requesting access to device...
    Failed to get a device. Did you chose one?"
     
    Last edited by mikechris33, Jun 16, 2018
  4. saneatsu

    saneatsu Advanced Member

    Newcomer
    2
    Apr 28, 2018
    United States
    For the pip3 run in terminal

    Pip3 install package-name-here

    Chrome you have to go into settings under advanced and specifically allow access.
     
  5. mikechris33
    OP

    mikechris33 Advanced Member

    Newcomer
    2
    Jan 31, 2018
    United States
    Thank you! I will try that. Also just a question but is it under USB devices?
     
    Last edited by mikechris33, Jun 17, 2018
  6. mikechris33
    OP

    mikechris33 Advanced Member

    Newcomer
    2
    Jan 31, 2018
    United States
    bumping this just too see if other people can help me. Sorry for all the bumps but I just really want to home-brew my switch.
     
  7. mikechris33
    OP

    mikechris33 Advanced Member

    Newcomer
    2
    Jan 31, 2018
    United States
    Same thing I just posted yesterday. Also im not plugging it into an usb 3.0 slot but I could.
     
    Last edited by mikechris33, Jun 20, 2018
  8. mikechris33
    OP

    mikechris33 Advanced Member

    Newcomer
    2
    Jan 31, 2018
    United States
    So I somehow was able to install the dependences and now I get this:

    "Traceback (most recent call last):

    File "fusee-launcher.py", line 424, in <module>

    switch = RCMHax(wait_for_device=arguments.wait, vid=arguments.vid, pid=arguments.pid)

    File "fusee-launcher.py", line 286, in __init__

    self.dev = self._find_device(vid, pid)

    File "fusee-launcher.py", line 326, in _find_device

    return usb.core.find(idVendor=vid, idProduct=pid)

    File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/usb/core.py", line 1263, in find

    raise NoBackendError('No backend available')

    usb.core.NoBackendError: No backend available

    Traceback (most recent call last):

    File "fusee-launcher.py", line 424, in <module>

    switch = RCMHax(wait_for_device=arguments.wait, vid=arguments.vid, pid=arguments.pid)

    File "fusee-launcher.py", line 286, in __init__

    self.dev = self._find_device(vid, pid)

    File "fusee-launcher.py", line 326, in _find_device

    return usb.core.find(idVendor=vid, idProduct=pid)

    File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/usb/core.py", line 1263, in find

    raise NoBackendError('No backend available')

    usb.core.NoBackendError: No backend available" what is backbend?
     
  9. mikechris33
    OP

    mikechris33 Advanced Member

    Newcomer
    2
    Jan 31, 2018
    United States
    I'll try and bump again.
     
  10. trainboy2019

    trainboy2019 Well-Known Member

    Member
    6
    GBAtemp Patron
    trainboy2019 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Oct 6, 2015
    United States
    GA
    And you did this?

    brew install libusb
    python3 -mpip -install pyusb
     
  11. mikechris33
    OP

    mikechris33 Advanced Member

    Newcomer
    2
    Jan 31, 2018
    United States
    yep
     
  12. trainboy2019

    trainboy2019 Well-Known Member

    Member
    6
    GBAtemp Patron
    trainboy2019 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Oct 6, 2015
    United States
    GA
    I'm sorry, but I don't know what to say. Maybe try running it as admin with the sudo command?
     
  13. trOublie

    trOublie Advanced Member

    Newcomer
    4
    Oct 11, 2007
    Brazil
    Had a problem recently and I could not solve it for myself. Got lucky actually. It was like yours, I had 2 tablets in RCM, one mine and the other from a friend. I've started with his tablet on https://elijahzawesome.github.io/web-cfw-loader/ (mac+chrome) but APX did not appeared.

    So we've switched cables (mine was working for sure) but no luck. Then I tried with my tablet which I have never seen this problem. And again, not working. Tried with android S8+, multiple cables, nothing worked. They enter RCM but no device can detect it.

    Then I connected both switches one at a time in windows 10 with tegraGUI and did not worked again. Disconnected the device, reconnected it and a windows window popup like it was "installing" some driver, and suddenly both tablets were detected in any device (S8+, win10, mac).

    I can't understand why and what was that since my win10+tegraGUI was working the day before.
     
  14. mikechris33
    OP

    mikechris33 Advanced Member

    Newcomer
    2
    Jan 31, 2018
    United States
    Guess we are screwed.
     
  15. mikechris33
    OP

    mikechris33 Advanced Member

    Newcomer
    2
    Jan 31, 2018
    United States
    I DID IT! I just had to find all 7 chaos emeralds to run the payload in my switch. Thank you all so much for helping me!
     
Quick Reply
Draft saved Draft deleted
Loading...