Hacking Weird Battery Issue

TR_mahmutpek

medic
OP
Member
Joined
Jul 28, 2015
Messages
1,425
Trophies
0
Age
23
XP
1,980
Country
Turkey
Lets get straight. Atmosphere 0.9.2, system 8.1.0, exfat sd card.
Switch charges 100, play until charge goes to 50~ and switch turns of itself (also battery low warning) Btw this happens on normal gameplay with 2.5h-3h. Never used lakka or anything like that. I think we need battery resetter like on android.

Edit: After 2 years, I got a notification that says this thread viewed over 1000 times so I remembered this existed. Here is the solution, just send this payload via tegrarcm, dont forget to unrar! I found this on gba.temp but cant remember where.
 

Attachments

  • fusee-linux-battery-fix.rar
    14.3 KB · Views: 16
Last edited by TR_mahmutpek, , Reason: fix found
  • Like
Reactions: NoNAND

Kubas_inko

"Something funny goes here."
Member
Joined
Feb 3, 2017
Messages
6,318
Trophies
1
Age
22
Location
I gues on earth.
XP
4,997
Country
Czech Republic
Something very similar happend to my friend.
He tild me that this is what happened to him: https://en-americas-support.nintend...-instructions-to-fix-battery-indicator-issues
He never used linux, yet his switch wouldn't even boot without a charger at first (but battery was at 100%). Then it would boot, but turn of at arround 44% (and hekate also reported that the battery was actually at 60%).
What he did: Calibrate baterry via hekate factory reset the switch, calibrate the battery. Apparently that helped him as he was able to go to 20% before he decided to charge it again.
 
  • Like
Reactions: TR_mahmutpek

TR_mahmutpek

medic
OP
Member
Joined
Jul 28, 2015
Messages
1,425
Trophies
0
Age
23
XP
1,980
Country
Turkey
Something very similar happend to my friend.
He tild me that this is what happened to him: https://en-americas-support.nintend...-instructions-to-fix-battery-indicator-issues
He never used linux, yet his switch wouldn't even boot without a charger at first (but battery was at 100%). Then it would boot, but turn of at arround 44% (and hekate also reported that the battery was actually at 60%).
What he did: Calibrate baterry via hekate factory reset the switch, calibrate the battery. Apparently that helped him as he was able to go to 20% before he decided to charge it again.
Thx for answer but how can I factory reset via hekate, or calobrate battery?
I read that instructions but it seems too long procedure.
 

NoNAND

Give me back my legions!
Member
Joined
Aug 22, 2015
Messages
2,280
Trophies
1
Location
Somewhere
XP
4,953
Country
Albania
It's a common occurrence with Switch batteries. They tend to go bonkers sometimes.
Usually Hekate provides a quick fix for that by re-calibrating the desynced battery.
Alternatively you might have to unplug and re-plug the battery back in if hekate didn't solve your issue.
Factory resetting can be done in the system settings menu or by accessing Recovery Mode.
 

The Real Jdbye

*is birb*
Member
Joined
Mar 17, 2010
Messages
22,206
Trophies
4
Location
Space
XP
11,699
Country
Norway
Lets get straight. Atmosphere 0.9.2, system 8.1.0, exfat sd card.
Switch charges 100, play until charge goes to 50~ and switch turns of itself (also battery low warning) Btw this happens on normal gameplay with 2.5h-3h. Never used lakka or anything like that. I think we need battery resetter like on android.
Actually, deleting batterystats on Android just wipes the battery usage history. It has nothing to do with calibration. Common myth that's been debunked for a long time.
This was a common issue on older Switch FW and has supposedly been fixed (I certainly haven't seen any reports of the issue in a long time, until now)
The official instructions to fix the issue once it occurs it are a bit of a pain but they should work.
 
  • Like
Reactions: TR_mahmutpek

TR_mahmutpek

medic
OP
Member
Joined
Jul 28, 2015
Messages
1,425
Trophies
0
Age
23
XP
1,980
Country
Turkey
Thx for all answers guys. I will try to go with this issue for now. Time will tell if it will be solved by itself eventually or need to do solutions..
 

Canna

Bad Ass Poisonous Mushroom
Member
Joined
Jul 14, 2018
Messages
1,396
Trophies
0
Age
34
Location
AZ
XP
1,514
Country
United States
had battery issue myself lately after letting the switch die whilst i was away on vacation. come home charged, went to use the switch and the battery % would drop in seconds. so 100% gone in 1 minute but would never turn off on 1%.

used old hekate version to see or use battery fix... made no difference...

So .. i knew what to do , unplug the battery plug it back in.. works fine now..
 
  • Like
Reactions: TR_mahmutpek

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: Don't forget to like them +1