vWii Neek2o issues

Discussion in 'Wii U - Hacking & Backup Loaders' started by balteck, Sep 11, 2015.

  1. balteck
    OP

    balteck Advanced Member

    Newcomer
    85
    10
    Mar 6, 2015
    Italy
    I've recently discovered the Neek2o r96 Beta 9.6 and I setup sneek for my Wii U.

    I've used this pack: https://copy.com/ywz8y9YeI0aEhdtv

    The 7z file has:
    * 4 wads (2 for Wii and 2 for vWii) for nSwitch Channel v4.2 (2 for Real nand and 2 for Emunand)
    * a sneek folder with the new wii and vwii kernels
    * app folder with nswitch app (for hbc users)

    From USB Loader GX I can see all my channels installed in emunand and I can start them with Neek2o correctly.
    If I set "Return to OFF", when I close the game I come back to Neek2o System Menu, If I set "Return to ON", when I close the game I come back to Wii U System Menu (not the vWii one)

    Also if I use nswitch app and USB Loader GX->Feature->Boot Neek2o System Menu I can go in emulated nand with sneek.

    Here there are the issues that I have:

    In Neek2o system menu I can see the channel dumped from the RealNand (Disc Channel, Mii Channel, Wii Transfer Channel, Manual Channal, Back to WIIU Channel. Wii Shop Channel, Homebrew Channel and USB Loader Channel), but not the others channels installed (about 15 games + Back2nand Channel) while in USB Loader GX I can see all emuNand channels correctly+Back2Nand.

    If I press 1 I can see the overlay menu with all Wii and GC Titles I have (I didn't try them) and also the Channel Titles as well.

    Why I can see the channel titles only on overlay menu and not on system menu?

    I've installed them with both showmiiwads and USB Loader GX->Feature>Install WAD on Emunand.
    I can understand that system channels are different, but HomeBrew channel and USB Loader GX Channel are different from regular wads and Back2Nand wad?

    With overlay menu I've tried to start some channels and they works very well (no more hangs on World of Goo finally), but if I start Back2Nand the WiiU freezes and I must unplug the power cable to power off. If Back2nand channel exists to switch to RealNand, what I did wrong?

    TIA!
     


  2. worm28

    worm28 GBAtemp Advanced Fan

    Member
    686
    128
    Jun 2, 2013
    United States
    I have the same problem with Neek2o r96 Beta 9.6 but none of my channels show up i have like 65 wads installed not even official channels show. I hope someone has a fix maybe its a bug or something.
     
  3. balteck
    OP

    balteck Advanced Member

    Newcomer
    85
    10
    Mar 6, 2015
    Italy
    Which app you've used to create emuNand? Are you on vWii?
     
  4. worm28

    worm28 GBAtemp Advanced Fan

    Member
    686
    128
    Jun 2, 2013
    United States
    I used fs toolbox mod for vWii to create my emunand and showmiiwads mod to install my wads and yes im on vWii. But the same nand dump works just fine with usbloader gx and wiiflow.
     
    Last edited by worm28, Sep 11, 2015
  5. balteck
    OP

    balteck Advanced Member

    Newcomer
    85
    10
    Mar 6, 2015
    Italy
    If you wish, you can dump your RealNand with USB Loader gx - feature - dump nand to emunand over yours.

    I did it many times without issues and you only need to be sure not having the same savegame, because the process will overwrite it.

    After that, start need2o and look if the channels on your realnand will show in system menu
     
  6. xfcrowman

    xfcrowman GBAtemp Fan

    Member
    431
    13
    Mar 14, 2009
    United States
    I have tested this beta on vWii and I can confirm that there are problems with displaying and running channels. I can also report that this is probably due to bugs in this neek2o beta, as I have tested my emuNANDs with r202 of UNEEK and the channels work without issue.

    If you are planning to use neek for loading Wiiware/Virtual Console, then I would suggest using r202 of UNEEK for now. JoostinOnline has posted a guide on compiling/setting up SNEEK/UNEEK, and this worked well for me.

    The neek2o beta you and I have tried is quite old (Feb 2015), and I'm sure there have been many improvements in newer betas since then. I'm a big fan of neek2o, and hopefully a new revision will be released in the future!
     
  7. Farowe

    Farowe GBAtemp Regular

    Member
    113
    63
    Feb 16, 2014
    Mexico
    Mexico City, Mexico
    Displaying of channels in emunand (sneek) system menu is not working properly on vWii neek2o. But thats ok, we are all having that issue with the latest beta. I don´t think the issue relies on the wad itself but in how it is installed, perhaps the current methods to install wads on emunand aren´t properly updating the channel list. But that´s a minor issue since you can launch these channels you installed from either usbloader gx (with sneek) or from the overlay menu.

    In other to return to sysnand, the wii console simply has to restart but since we are on a vwii console this ain´t that simple. Since vWii booting hasn´t been fully deciphered (due to wii u hacking not progressing further enough) its currently impossible to directly return to sysnand from emunand on vwii; wii version of nswitch simply restarts your console if you launch it from emunand. Restarting the wii u while on vWii will return you to wii u mode, thats as far as you will get. Thankfully "return to wii u" channel does the same as nswitch and works properly on emunand so i would suggest you to hook the "return to" option to this channel as it will do the same as the current nswitch channel (restarting the console).

    Hopefully someone will further update vWii neek2o soon.
     
  8. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,273
    8,748
    Oct 27, 2002
    France
    Engine room, learning
    I have the same issue, if going to neek system menu, no installed channels are displayed. but they are listed in the hidden menu>autoboot drop down.
    I didn't find why, it's probably a bug.

    just remember that the vWii version of Neek2o is only a preview/beta/unreleased officially.

    At least, you can auto-boot them from USBGX, and return to works fine.
    on vWii return to is annoying as it reboots the WiiU and not vWii only, but it's the only solution we have currently.
    OverJoy is working on neek2o when he can, and plan to release a "final" version. no more update anymore after that release. So, he will not release multiple version and will wait that everything is tested and working.
    no idea when it will be.
     
  9. balteck
    OP

    balteck Advanced Member

    Newcomer
    85
    10
    Mar 6, 2015
    Italy
    Thank you very much for the technical detail about this beta.

    I was worried about I did something wrong to setup neek2o or my vwii doesnt work in right way.

    I'm very happy that I can use it with USB Loader GX and finally play with Castlevania Rebirth and World of Goo without hangs.

    I wish to thank Cyan for his efforts to implement neek2o (also if the beta is not perfect) and I can use it from his loader
     
    Last edited by balteck, Sep 11, 2015
    Cyan likes this.
  10. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,273
    8,748
    Oct 27, 2002
    France
    Engine room, learning
    I planed to do more, better integration and more options (like autoboot Wii disc based games, or Ocarina support) but I didn't had time. I decided to release what I did already.
    I still had some strange behavior and bugs while testing vWii version (game not booting, NAND not found, etc.)

    If I have time, I'll come back to neek2o integration to add the missing features.
    For now, I think it has the most used feature : booting channels.
    for booting wii games, launching neek from the settings>features is possible.
    Sorry that there's no ocarina support yet.

    About the WiiU beta version, I have anoher (more recent) beta, and it has the same bug.
    It even have more bug : I never could launch a channel :P
    its worse, so using r96 beta9.6 is the best you can do on vWii for the moment.

    USBLoaderGX automatically set the "return to" to that channel on vWii. it doesn't use the "NK2O" titleID.

    if you enable return to, on Wii it loads "NK2O" channel and on vWii it loads the "return to WiiU" channel.
     
  11. balteck
    OP

    balteck Advanced Member

    Newcomer
    85
    10
    Mar 6, 2015
    Italy
    Before posting here, I've done many tests and I discovered that Neek2o system menu works better if the nand is a subfolder inside of usb1:/vwiinands folder instead of root (I mean usb1:/vwiinands/nand instead of usb1:/nand).

    In this way nswitch app loads out of the box as many nand you wish (usb1:/vwiinands/nand1, usb1:/vwiinands/nand2, etc) selectable in the overlay menu of neek2o system menu. And I can change any options in overlay menu without issues at all.

    But in this way, if I set in USB Loader GX the path of emunand in usb1:/vwiinands/nands, the loader not show up the banner of any channel.

    The channel works, the covers works, but not banners, only blank channels (if the banner is in cache, the loader show it, but if I clear cache no banner at all for every enunand channels)

    I think that USB Loader GX have a bug that not extract banner from a channel if the emunand is in a subfolder.

    Maybe this information could be important for develop more options, because working with nand folder instead of vwiinands/nand folder (/nands/nand on regular wii) adds more instable variables.
     
  12. balteck
    OP

    balteck Advanced Member

    Newcomer
    85
    10
    Mar 6, 2015
    Italy
    I think Farowe is right. So I've opened my nand with Dolphin and I have the same problem of Neek2o: it shows up only the same channels as vWii.
    After that I've installed a wad from Dolphin on my emunand and both Dolphin and Neek2o shows up the channel just installed.

    I've investigated about what Dolphin does for installing and I've discovered that it extracts the wad in title and ticket folders and it updates the file /sys/uid.sys with the new channel TitleID and UID.

    I think that Showmiiwads and "Install wad to emunand" in USB Loader GX don't update this file, but only extract wad in title and ticket folders

    Anyone can confirm this?
     
  13. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,273
    8,748
    Oct 27, 2002
    France
    Engine room, learning
    I did all my tests and development with emunand in subfolders :
    usb1:/nands/PAL32/
    usb1:/nands/nand42E/
    etc.
    I had the choice to switch NANDs directly frim the hidden menu. but the loader is regenerating the nandconf.bin file used by the hidden menu, and whatever the path detected by USBGX can be switch from neek too. (if you edit the nand path in usbgx, it adds it to the known paths)

    the animated banners worked fine.


    USBLoaderGX update sys/uid.sys file when installing wad file from the feature menu.
    maybe there's a difference with vWii because channels are correctly displayed on Wii.

    I remember JoostinOnline found that SYSCONF file had been updated to use a different linefeed (I think it was that) and it required an update of libOGC to be able to read/write configs for his SettingGUI Editor homebrew.
    I suspect that vWii uis.sys had the same update and needs a fix.
    I will have a look (or you can take a look at the difference of the uid.sys file when installed from the loader or from dolphin).
     
  14. balteck
    OP

    balteck Advanced Member

    Newcomer
    85
    10
    Mar 6, 2015
    Italy
    I don't have the tool to browse uid.sys. I've only seen with an hex editor that the codes of not showing channels are missing.

    I've also test with two fresh versions of USB loader GX (1244 and 1256) and if I set the path of emunand as USB1:/nand it shows channels banner correctly and it write them as bnr in cache folder.
    If I set the path of emunand as USB1:/vwiinands/nand, the loader doesn't show banners for channels and there are no entries in cache folder.
    I've done the tests always with banner cache folder empty, because if banner is present in cache, the Loader shows channels with banner.

    I think that USB loader fails to extract banner and to put the bnr in cache when the emunand is in a subfolder. But It shows up correctly the banner if it finds the related bnr in cache.

    My console is a WII U 5.4.0 PAL
     
  15. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,273
    8,748
    Oct 27, 2002
    France
    Engine room, learning
    ah, that's probably why it worked for me.
    I'm using banner caching, so it probably loaded them from my SD card's cache folder.

    it's maybe related to an old bug report : is emuNAND path as "-" in the name, it doesn't play banners.
    for example usb:/emu-nand/

    Thanks for the report, I'll add it to my bug list.
     
  16. 1ird

    1ird Newbie

    Newcomer
    2
    0
    May 15, 2017
    United States
    Is it still possible to find this Neek2o vwii beta anywhere?
     
  17. balteck
    OP

    balteck Advanced Member

    Newcomer
    85
    10
    Mar 6, 2015
    Italy
  18. nerubii

    nerubii Advanced Member

    Newcomer
    70
    1
    Jul 22, 2007
    Zimbabwe
  19. Robertuxo
    This message by Robertuxo has been removed from public view by Cyan, Sep 3, 2017, Reason: offtopic, multiple post in different threads.
    Sep 3, 2017
  20. nerubii

    nerubii Advanced Member

    Newcomer
    70
    1
    Jul 22, 2007
    Zimbabwe
    so anyone managed to find an update for this? a newer version?

    or is there a fix on the neek wii storage limit >=512MB?
     
  21. balteck
    OP

    balteck Advanced Member

    Newcomer
    85
    10
    Mar 6, 2015
    Italy
    My nand folder is 64 GB and any wiiware works correctly

    Inviato dal mio HTC One M9 utilizzando Tapatalk
     
    nerubii likes this.