Visual Boy Advance on PC

Discussion in 'GBA - Game Development, ROM Hacks and Translations' started by ACWWFAN, Dec 6, 2011.

  1. ACWWFAN
    OP

    ACWWFAN HERP DERP

    Member
    510
    0
    May 13, 2009
    United States
    Arizona
    It seems to be running too fast. The video seems like it is on fast forward, what can I do to fix this?
     
  2. Satangel

    Satangel BEAST

    Member
    10,255
    555
    Nov 27, 2006
    Belgium
    Bruges, Belgium
    Are you holding spacebar, perhaps? That's the turbo button.
     
  3. Hyro-Sama

    Hyro-Sama I'm from the fucking future.

    Member
    4,257
    3,015
    Oct 25, 2009
    After Earth
    Turn the sound on. If you turn the sound off it goes super fast. Just mute the game if you don;t want music.
     
  4. Vinnymac

    Vinnymac GBAtemp Regular

    Member
    246
    26
    May 15, 2005
    United States
    NY
    Turning the sound off makes it go super fast? Is that a bug or done on purpose?

    VBA is probably one of the best emulators ever made IMP
     
  5. Clydefrosch

    Clydefrosch GBAtemp Psycho!

    Member
    4,068
    1,143
    Jan 2, 2009
    Gambia, The
    is sound on? if you turn sound off, it might switch to speed mode too

    its meant to do that, for people who have a bad pc. there should be an option to toggle speed at 100% though, look for it, its called toggle i think
     
  6. Ammako

    Ammako GBAtemp Guru

    Member
    6,400
    3,530
    Dec 22, 2009
    Canada
    I myself prefer NO$GBA for my GBA emulation needs.
    Link cable emulation worked better than VBA-Link's, last I tried.
     
  7. Psyfira

    Psyfira Credit: 0ml. Insert tea to continue

    Member
    3,887
    15
    Dec 31, 2003
    England
    Look in the options for a speed throttle setting (It might depend which version of VBA you're using, is Options > Speed > Throttle. on VBAM). Set to 100% and that should prevent the game running faster than it's supposed to.
     
  8. Ammako

    Ammako GBAtemp Guru

    Member
    6,400
    3,530
    Dec 22, 2009
    Canada
    You should also turn off the frame skip, it makes the games run a bit laggy.
    I have no idea why, but VBA has frame skip set to 1 or 2 by default.
     
  9. DanTheManMS

    DanTheManMS aka Ricochet Otter

    Member
    4,329
    105
    Jun 2, 2007
    United States
    Georgia
    If it's both the audio and video going too fast, then the key reason is the "Syncronize" option. Options - Emulator - Synchronize. Note that I have the throttle option mentioned earlier set to "none" which might also have an effect.