USB Loader microphone issues

Discussion in 'Wii - Hacking' started by darkten, Apr 4, 2009.

Apr 4, 2009

USB Loader microphone issues by darkten at 9:25 AM (6,017 Views / 0 Likes) 22 replies

  1. darkten
    OP

    Newcomer darkten Advanced Member

    Joined:
    Mar 31, 2009
    Messages:
    61
    Country:
    United States
    Help me...as I have a little girl that is going to hurt me bad if you cannot [​IMG]

    We're on a 4.0U Wii that has HBC, USB Backup Loader and the USB (Disk based) Loader installed.

    Everything seems to work ok, however our USB microphones are no longer recognized by *any* game..backups or originals.

    Our WiiSpeak however works fine.

    What do I need to do? My daughter is SERIOUSLY pissed because all of her singing games that she bought with her own money (b-day, etc) no longer work (her brother seems to...not mind at all, heheh) but I think the child is gonna push me down a flight of stairs or something.

    Help please.

    I'd do it for you!

    Thanks,

    -d10 Fear of Falling
     


  2. koji2009

    Member koji2009 GBAtemp Maniac

    Joined:
    Mar 13, 2009
    Messages:
    1,193
    Country:
    United States
    The latest cIOS (Revision 9) doesn't support a lot of USB devices because of how it's been modified. That said, it shouldn't effect originals at all because originals shouldn't be using the cIOS. Backups through the backup loaders both use the cIOS and will both be effected.

    You should be able to install cIOScorps and run backups through the disc channel unaffected. If you want to get even more specialized you can find out what IOS the microphone games use and just install that/those cIOS and use softchip.


    The only other solution is to reinstall cIOS_R8 and lose USB loader support until an update fixes this.
     
  3. face56

    Newcomer face56 Member

    Joined:
    Feb 9, 2009
    Messages:
    19
    Location:
    chicago
    Country:
    United States
    same thing with me. mics not recognized. help.
     
  4. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba

    then if you bought it, play with the original game
    as said above, the USB2 module added in cIOS rev9 broke USB device like the microphone
    cIOS is loaded when you use USB Loader or Backup Launcher so don't use them
     
  5. AdamBrunt

    Member AdamBrunt GBAtemp Advanced Fan

    Joined:
    Jun 24, 2003
    Messages:
    688
    Country:
    Interesting that it was working in rev8 but not in rev9 ... wouldn't rev9 just have additional code to rev8 ie be backward compatible ?

    Once (or should that be if ?) the USB2 module is fixed, will that also solve the issues with GH instruments and the LAN adapter ?
     
  6. takuya

    Newcomer takuya Advanced Member

    Joined:
    May 7, 2006
    Messages:
    56
    Country:
    France
    i confirm !
    my usb mic (AC one) don't work with cios 36 rev 9 (specially with apps who use rev9 like usb launcher)

    i have uninstall rev9 and install rev7 and it works now
     
  7. Rambytes

    Member Rambytes GBAtemp Regular

    Joined:
    Aug 4, 2008
    Messages:
    157
    Country:
    Canada
    But if you install the rev7, you will lose the usb loader?
     
  8. takuya

    Newcomer takuya Advanced Member

    Joined:
    May 7, 2006
    Messages:
    56
    Country:
    France
    yes ...
    i'll launch my game via the backup loader
     
  9. TjW1072

    Newcomer TjW1072 Member

    Joined:
    Mar 14, 2009
    Messages:
    16
    Country:
    United Kingdom
    I noticed this problem as well with my disney sing it back up but I found that if I loaded it through my rock band channel by Mrkinator, It worked fine.

    Rock Band Channel
     
  10. darkten
    OP

    Newcomer darkten Advanced Member

    Joined:
    Mar 31, 2009
    Messages:
    61
    Country:
    United States
    I'm not sure if this was meant to infer or imply that I did not buy it. If it was, you are both an ass and lack reading comprehension skills as I clearly state more than once in the original post that neither the original nor the backups recognize the microphone anymore...including the part you quoted.

    +2d10 Posting of Irritation
     
  11. darkten
    OP

    Newcomer darkten Advanced Member

    Joined:
    Mar 31, 2009
    Messages:
    61
    Country:
    United States
  12. darkten
    OP

    Newcomer darkten Advanced Member

    Joined:
    Mar 31, 2009
    Messages:
    61
    Country:
    United States

    Thank you. I'll give this a look see. The instructions mention something about needing to setup a folder on the SD...is this required with the channel provided?

    Thanks again for your helpful, relevant reply [​IMG]

    d10
     
  13. darkten
    OP

    Newcomer darkten Advanced Member

    Joined:
    Mar 31, 2009
    Messages:
    61
    Country:
    United States
    I thought this too, which is why it doesn't make any sense. I do not remember running the update off the DVD, but even if this was the case if whatever was installed was modified then the result would be the same since the games don't load the updates every time you run them.

    So the idea here is to uninstall whatever it was the USB2 cIOS installed, and re-run the disc's update, is that it? I'm a bit confused about the CIOSCORP thing; I've not heard of it. Any info to elaborate on this would be very helpful; I'll be wanting to do this tonite after I mess with the wbfs code a bit more (adding write buffering for MacOS X) and BEFORE I pick up my DSi [​IMG]

    Thanks again!

    +d10
     
  14. sectionboy

    Newcomer sectionboy Member

    Joined:
    Apr 4, 2009
    Messages:
    39
    Country:
    United States
    I installed cios rev8, and my lan adaptor returned to work. I'am very convinced it's the cios rev9. You may want to give it a try.
     
  15. darkten
    OP

    Newcomer darkten Advanced Member

    Joined:
    Mar 31, 2009
    Messages:
    61
    Country:
    United States

    are rev8 and rev9 mutually exclusive?

    d10
     
  16. Tashi

    Newcomer Tashi Member

    Joined:
    Apr 3, 2009
    Messages:
    21
    Country:
    United States
    is there any special way to revert to rev8? or do i just run the installer?
     
  17. sectionboy

    Newcomer sectionboy Member

    Joined:
    Apr 4, 2009
    Messages:
    39
    Country:
    United States

    No idea, I think they overwrite each other. I just re-ran the rev8's installer.
     
  18. TroyTheZombie

    Member TroyTheZombie GBAtemp Advanced Maniac

    Joined:
    Mar 3, 2009
    Messages:
    1,631
    Location:
    Calgary, Canada
    Country:
    Canada
    Yeah, they just overwrite each other.
     
  19. takuya

    Newcomer takuya Advanced Member

    Joined:
    May 7, 2006
    Messages:
    56
    Country:
    France
    i hope this will be fixed in rev10 [​IMG]
     
  20. zapu

    Member zapu GBAtemp Regular

    Joined:
    Jul 27, 2006
    Messages:
    182
    Country:
    Poland
    You have to install older CIOS (or Wiigator's cios) on other slot that USB CIOS. USB Microphones don't work on USB 2.0 CIOS.

    http://www.sendspace.com/file/pti2yv Use that to install ios with dip module as lets say ios232 (use dpad on wiimote to set it to something like "ios 36 with dip module as ios232").
    use softchip to load your backups using ios232 you have installed in step 1.

    This way you can use usb backup loader that uses usb 2.0 cios and softchip to play dvd backups like guitar hero [​IMG]
     

Share This Page