USB Loader GX

By cyrex, Apr 19, 2009 5,935,961 26,922 39

  1. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    11,205
    Country:
    United States
    make it with usb loader gx
     
  2. Sneethan

    Sneethan GBAtemp Regular
    Member

    Joined:
    Apr 17, 2020
    Messages:
    157
    Country:
    Australia
    But how do i link sneek or uneek? i made one with ulgx and all the channel previews were blank, the names were weird (like NPUP) but the apps did load, well at least world of goo did.
     
  3. blackb0x

    blackb0x GBAtemp Regular
    Member

    Joined:
    Apr 22, 2019
    Messages:
    122
    Country:
    United Kingdom
    I've uploaded a new release :)
    • Added AltWFC and BenFi as private server options
    • Added the ability to edit the cover and banner URLs
    • Added the builds Git commit ID to the boot screen
    • Fixed Japanese descriptions not being displayed correctly
    • Fixed an issue that would cause the storage details to not be shown
    • Updated the networking code to achieve faster downloads
    • Updated WiinnerTag to RiiTag
    • Updated the meta.xml information
    • Updated Portuguese and Korean translations thanks to Codemastershock & DDinghoya
    • Removed some unnecessary files
    • Removed an extra forward slash from the language path
    Download @ https://gbatemp.net/posts/8856063

    I've also uploaded a version with tabs, although my version includes a few changes. For example, you might notice that it no longer has overlapping buttons, the storage details are always displayed correctly and it'll also display the number of games for each tab.
     
    Last edited by blackb0x, Jul 11, 2020
  4. Sneethan

    Sneethan GBAtemp Regular
    Member

    Joined:
    Apr 17, 2020
    Messages:
    157
    Country:
    Australia
    Soi eventually found a guide online and generated a new nand without sneek with modmii classic. But when i made an empty folder and tried using the GUI Installer, it just kept saying "error while downloading, file not found"?
     
  5. skite2001

    skite2001 Member
    Newcomer

    Joined:
    Jul 13, 2012
    Messages:
    13
    Country:
    Gambia, The
    Got a gamecube settings problem... If i clicked a gamecube game in usb loader gx it runned directly via Nintendont. Now, maybe because of an Update it dont run directly. It loads up Nintendont loader and i had to select the game in it again. How can i fix that?
     
  6. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    11,205
    Country:
    United States
    that's what it's supposed to do. it can't be changed.
     
  7. skite2001

    skite2001 Member
    Newcomer

    Joined:
    Jul 13, 2012
    Messages:
    13
    Country:
    Gambia, The
    Sure it can be changed. I used Nintendont the whole time but it loaded directly without goining into the separate loader!
     
    Last edited by skite2001, Jul 19, 2020
  8. Porga

    Porga Newbie
    Newcomer

    Joined:
    Mar 12, 2018
    Messages:
    9
    Country:
    Croatia
    Fetching codes from https://geckocodes.org/ does not work, USBloader GX us trying to get http link version instead of https.
    Is there a way to fix this?
     
  9. blackb0x

    blackb0x GBAtemp Regular
    Member

    Joined:
    Apr 22, 2019
    Messages:
    122
    Country:
    United Kingdom
    @Porga They've recently started to redirect all traffic to HTTPS, so you'll need to use my enhanced version of USB Loader GX instead.

    https://gbatemp.net/posts/8856063

    I'll probably release another update in a few days as I want to make adjustments to how custom servers work, patch a known MKW vulnerability and make a few games with dedicated servers playable again.
     
    Last edited by blackb0x, Jul 20, 2020
  10. geoGolem

    geoGolem GBAtemp Regular
    Member

    Joined:
    Feb 18, 2012
    Messages:
    134
    Country:
    Canada
    I was into the WII scene with usbloader/wiiflow/cfgloader etc. way back in the day in like 2011 or 2012... with the regular WII but havent touched a wii or wii u since that time. I now have a WIIU - is it possible to somehow leave 2 HDD plugged in simultaneously. I know about ustealth and I can get around the WIIU nagging screen - WIIU mode doesnt seem to be an issue for me - it is the vWII mode that has the issue.

    To be clear my WIIU is properly oriented with the front having the WIIU logo properly shown horizontally. Hopefully this makes it clear which usb port I am referring to, if I say front/left port. or back/top port. etc.

    Here is my situation:

    vWII HDD (wbfs and games folders only for WII and GC games respectively)
    WIIU HDD (a bunch of games installed using WUPINSTALLER).
    Also have an SD Card.
    I also have a usb ethernet adapter which seems to work in both WIIU and vWII mode no matter which usb port I plug it into.

    I have Y adapters for the HDDs, I plug the data usb plugs into WIIU and extra power usbs into a usb power wall adapter.

    I followed the guide and hacked my WIIU and vWII. I am using Mocha on WIIU. I have lastest r1272 version of usbloadergx on the sd card and can launch from vWii Homebrew Channel.

    usbloadergx will detect my vWII HDD if I plug it any of the 4 usb ports but when launching a wii game it will either black screen freeze or black screen return to WII system menu UNLESS the vWII HDD is plugged into the back/top USB port.

    This will work as long as the vWII HDD is plugged into the back/top usb port. Along with the vWII HDD I can plug in my ethernet adapter and all is fine. The ethernet adapter seems to have no effect on anything so from now on I'll just eliminate it from the discussion altogether.
    If the WIIU HDD is plugged into the WIIU in any usb port (regardless of whether the ethernet adapter is plugged in) usbloadergx says "USB DEVICE is not initialized --> switching to channel mode" and I cannot even see the WII/GC games on vWII HDD.

    in other words, everything works fine if when I launch to vWII mode, I disconnect the WIIU HDD before launching usbloadergx. Is there a way to avoid having to constantly connect/reconnect the WIIU HDD. I read that usbloadergx is supposed to skip over the WIIU HDD, but its not working for me.

    Everything works perfectly except for the need to unplug the WIIU HDD before launching usbloadergx.

    This happens with or without ustealth being used on the vWII HDD.. Of course without ustealth the vWII HDD needs to be unplugged in WIIU mode. With ustealth, I can leave it in while in WIIU mode. but upon entering vWII mode I need to unplug the WIIU HDD before running usbloader gx.

    hopefully my issue makes sense. I would appreciate any help/feedback anybody can provide. if you need more information - please let me know. I would be happy to provide as much info as I can. It would be nice to not have to unplug/replug the usb often.. though at least everything is mostly functional ... aside from that.

    EDIT1: I tried moving the WIIU HDD around to other USB ports on the WIIU but it has no impact... Also no point in moving the vWII HDD since it only works successfully if it is plugged into the back/upper port anyway.

    EDIT2: I have been searching around for other posts with the issue and found a post from January 2020 where someone has an almost identical setup and is complaining of the same issue. I am still reading that thread, but here is the link: https://gbatemp.net/threads/ustealth-wii-u-format-disk-nag-workaround.352786/page-29

    The posted solved his issue by changing the vWII HDD to MBR from GPT. Unfortunately mine is already MBR...

    EDIT3: I found a post by Cyan that describes some relevant information. https://gbatemp.net/threads/ustealth-wii-u-format-disk-nag-workaround.352786/page-28#post-8654211

    I think the most recent version of usbloadergx is using IOS58 so maybe thats why. Im not sure --> if anybody can chime in I would appreciate it.

    FINAL EDIT: It seems this change works: https://gbatemp.net/threads/ustealth-wii-u-format-disk-nag-workaround.352786/page-29#post-8915634

    inside usbloadergx settings, I changed loader ios from 58 to 249. I left game ios at 249.

    Now it works with both HDD plugged in at the same time! :)
     
    Last edited by geoGolem, Jul 20, 2020
    blackb0x and jeannotte like this.
  11. geoGolem

    geoGolem GBAtemp Regular
    Member

    Joined:
    Feb 18, 2012
    Messages:
    134
    Country:
    Canada
    @blackb0x : Once i got the official 1272 version working with both HDD attached (see previous message) I ended up trying with your enhanced version... Works great! Look forward to the next update!

    Out of curiousity --> how difficult would it be to add another button on the individual game settings page for "Flash save to Nand"... Right now there is one for "Extract Save to EmuNand" ... it would be nice to have one go the other way.

    I realize you probably have a ton of other stuff you are working on etc.. I might *try* and look at the code, since maybe I can find what happens when you click extract save to emunand and perhaps create another button and implement the reverse process... though last time I tried to work on a wii homebrew thing, I really couldnt figure out what was going on...

    EDIT: I think wiiflow has this feature... but neither the extract save or flash save option are available for WiiWare titles... which is where I want to use this..
     
    Last edited by geoGolem, Jul 20, 2020
  12. almmiron

    almmiron GBAtemp Regular
    Member

    Joined:
    Jan 9, 2012
    Messages:
    251
    Country:
    Brazil
    @blackb0x Its possible to autoboot your usbloaderGX with priiloader?
     
  13. alexander1970

    alexander1970 Paranoid and totally Insane.
    Member

    Joined:
    Nov 8, 2018
    Messages:
    10,408
    Country:
    Austria
    You only have to replace the boot.dol inside the apps/usbloader_gx Folder.:)
     
    blackb0x and jeannotte like this.
  14. docseuss

    docseuss Newbie
    Newcomer

    Joined:
    Jun 21, 2020
    Messages:
    7
    Country:
    United States
    Wii games are working fine but my gamecube games always freeze after a minute or two, usually in the main menu. Any idea what I'm doing wrong or what I can do to fix it? I get "An error has occurred" message.
     
  15. blackb0x

    blackb0x GBAtemp Regular
    Member

    Joined:
    Apr 22, 2019
    Messages:
    122
    Country:
    United Kingdom
    I guess your cIOS is setup as per this guide, but is your USB HDD using FAT32 with the cluster size set to 32KB?

    Either way, this is actually a Nintendont issue since that's what's booting your GC games.

    https://github.com/FIX94/Nintendont/issues/514


    I'm guessing it's difficult to safely write to the emunand, but I'll look into it.
     
    Last edited by blackb0x, Jul 20, 2020
    alexander1970 likes this.
  16. geoGolem

    geoGolem GBAtemp Regular
    Member

    Joined:
    Feb 18, 2012
    Messages:
    134
    Country:
    Canada
    i think you meant. it's difficult to safely write the *real nand*.... writing to the emunand is already handled..

    anyway just wanted to make sure.. I appreciate the response and your efforts! :)
     
    Last edited by geoGolem, Jul 20, 2020
  17. docseuss

    docseuss Newbie
    Newcomer

    Joined:
    Jun 21, 2020
    Messages:
    7
    Country:
    United States
    It's been a while since I set up my Wii for homebrew, but the other day, I ran the syscheck and installed the cioses that were missing. I think my HDD is formatted correctly, but I'm actually setting up a new USB to test that right now, as that was my next theory.

    I have the latest nintendont installed. The HDD used to work fine on my other Wii? I don't know if I can get a Y cable for this, but I'll look into that if the replacement flash drive I'm about to test doesn't work (figured I'd try flash drive before going back to HDD).
     
  18. geoGolem

    geoGolem GBAtemp Regular
    Member

    Joined:
    Feb 18, 2012
    Messages:
    134
    Country:
    Canada
    So I ended up getting a 2TB WD Passport for the vWII HDD.. (and identical model to the one I'm currently using for my WIIU HDD) .. I realize 2 2TB HDD are overkill, but they were cheaper than the 1TB counterparts, and I may eventually use them for something else, who knows..

    I was previously testing with a 32GB flash drive for the vWII HDD.

    if both drives are plugged in, usbloadergx freezes on "reinitializing devices" -- which occurrs because I am using loader IOS 249. I guess it first loads with 58, then reloads with 249 -- i needed to do this because if I was using just IOS 58, I had to unplug my WIIU HDD or else usbloader would load, but then say "usb device not initialized"..

    I have now switched back to IOS58, and just make sure to unplug the wiiU HDD before launching usbloader GX... I prefer, this to it freezing at reinitializing as seen with IOS249...
    ---------------------------------------------
    Prior to switching back to IOS58 I did discover the following interesting behaviour:

    If I turn on my WIIU with both HDD connected. Launch vWII mode. Unplug WiiU HDD, launch usbloader gx (IOS 249), it will run perfectly fine (same as with IOS58 with WIIU HDD unplugged). If I then press home button, exit to wii system menu, plug the wiiU HDD back in, and launch usbloader gX again, it will load fine even with the WIIU HDD plugged in.

    It would be so nice to be able to just leave both HDD plugged in, but for now I am using loader IOS58 and just unplugging the WIIU HDD prior to launching usbloadergx. With IOS58, if I forget to unplug the WIIU drive, it will launch and give message no device initialized, switching to channel mode, I can then just unplug wiiu HDD, exit and relaunch usbloadergx and all is well. This is preferred to the situation with IOS249 where it will freeze on "reinitializing devices" if i forget to unplug the wiiu hdd - this requires the wiiu to be unplugged and replugged which is not as simple as just exiting usbloader, unplugging the hdd and relaunching usbloadergx..
    ---------------------------------------------
    If anybody has any insight into why usbloadergx freezes on "reinitializing" hdd if the wiiu HDD is plugged in - it would be greatly appreciated.

    I tried also official usbloadergx 1271 (as opposed to 1272 or the enhanced version) - but this always freezes at "initializing device", so its worse IMO..but I did not test or fiddle with it as extensively as I could have..

    When it all works, it works well.. Just some issues with needing to plug/unplug the usb
     
  19. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    11,205
    Country:
    United States
    you could buy a toggle switch. though, I had one that was running well for a long time, then suddenly it would cut power without being flipped. I was using it with the wii u before I knew about ustealth.
     
  20. geoGolem

    geoGolem GBAtemp Regular
    Member

    Joined:
    Feb 18, 2012
    Messages:
    134
    Country:
    Canada
    Ive been kind of looking for something like that but it seems hard to find something that switches both data/power lines in the usb cable..
     
    Last edited by geoGolem, Jul 21, 2020
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Loader,