USB Loader GX

Discussion in 'Wii - Backup Loaders' started by cyrex, Apr 19, 2009.

  1. DaTank45

    DaTank45 GBAtemp Fan

    Member
    2
    Aug 18, 2017
    United States
    Thanks for your reply and help as usual. I just wanted to make sure I didnt miss anything. Thanks again always appreciated!
     
  2. Zonta85

    Zonta85 GBAtemp Fan

    Member
    3
    Nov 9, 2007
    Italy
    Ascoli Piceno
    Hi @Cyan problem with usb loader GX on WiiU here (tried both the ols 1265 and newest 1268)

    The same hard disk (obviously mounted in port 0) that works flawlessly both on Wii (USB LoaderGX/Nintendont) and on WiiU (Only Nintendont side) doesn't want to be mounted with cIOS 249, only with IOS58.
    If i use the IOS 58 the HDD is mounted correctly but once i try to load Wii games (doesn't matter the game) i have a black screen and the loader takes me back to the HBC, i've tried with both cIOS 249 base 56 beta 52 and cIOS 249 base 56 beta 53, and also cIOS 250 base 57 beta 52.

    Here's my syscheck:

     
    Last edited by Zonta85, May 17, 2018
  3. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    20
    Oct 27, 2002
    France
    Engine room, learning
    do you use Y-cable ? (might be obvious too, but just being sure it's not a power issue).

    Maybe your drive is just not compatible with the USB driver used by custom IOS, and only the official driver from IOS58 is working?
    you have an alternative, which is to install a cIOS based on 58 (d2x v10r52 base58), but a lot of game will not work.

    I recommend you find another device.
     
  4. Zonta85

    Zonta85 GBAtemp Fan

    Member
    3
    Nov 9, 2007
    Italy
    Ascoli Piceno
    I use that hard drive since the First day of the USB loader's era (ten years or so) and the same drive works perfectly on the Wii, i have this issue only in vWii.
    And It is a 3,5 drive with external power.
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    20
    Oct 27, 2002
    France
    Engine room, learning
    If it's externally powered, then you are fine.

    I don't why d2x v10 r52 wouldn't work with that drive.
    the only differences from v8 to vr52 is a drive init code. Maybe, instead of fixing detection, it creates issue for you ?

    If that drive works fine on Wii and cIOS, did you try r52 on Wii ?


    Attention : Port0 is the top port on WiiU, and the bottom port on Wii.
    maybe you didn't plug in port0, that's why it works with IOS58 only ?

    I don't recommend to keep r53, it has less compatibility than r52.
    the only use is support for both USB Port (but you need to enable an option in the loader)
     
    Last edited by Cyan, May 17, 2018
    Zonta85 likes this.
  6. Zonta85

    Zonta85 GBAtemp Fan

    Member
    3
    Nov 9, 2007
    Italy
    Ascoli Piceno
    WTF....
    I'm at work right now, but now i'm sure that i've plugged It in port 1 because i thought that port 0 was in the same spot in both Wii and wiiu, that Will explain because with Ios58 the hdd is mounted and the games are listed but not booted: iOS 249 beta 52 uses only One port.

    I know this and It explain why even with r53 games are non booted: due the less compatibility i never used It (except now for testing) and i never enabled the optional too.

    Later when at home i will Switch ports and i'm sure that everything Will be fine.
     
    Cyan likes this.
  7. Petrucci

    Petrucci Member

    Newcomer
    1
    Sep 18, 2016
    United States
    I've started using USB Loader GX recently, and although it can detect my USB drive, my ISO (Smash Bros. Brawl) doesn't appear in the games list. I made sure that "Wii Games" was checked in the fourth tab, and I installed cIOSes according to this guide: https://sites.google.com/site/completesg/backup-launchers/installation

    For reference, the drive I'm using is a 16GB SanDisk Cruzer Blade formatted in NTFS. I am also using Wii Backup Manager.
     
  8. DaTank45

    DaTank45 GBAtemp Fan

    Member
    2
    Aug 18, 2017
    United States
    Flash drive is most likely the problem
     
  9. Petrucci

    Petrucci Member

    Newcomer
    1
    Sep 18, 2016
    United States
    I'm not sure what about the flash drive is the issue. The loader detects it just fine, and I can browse the files in the loader, it's just that the game doesn't show up in the list.
     
  10. DaTank45

    DaTank45 GBAtemp Fan

    Member
    2
    Aug 18, 2017
    United States
    I would just eliminate the flash drive first before you try to figure it out so you aren’t running in circles
     
  11. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    20
    Oct 27, 2002
    France
    Engine room, learning
    how did you install the game to your device?
    Dumped the game disc directly from the loader? (I doubt you did, because it doesn't work with flash drives)
    manually copying the file with windows's explorer? (either the game is already in .wbfs, or your flash is using NTFS instead of FAT32)
    used WiiBackupManager ?

    edit: Sorry, I answered before reading your message, I answered based on user's replies.


    there are two ways to use Wii Backup Manager, a good, and wrong way.
    be sure you follow THIS method :
    https://gbatemp.net/posts/7592791

    If you use NTFS, you can either split the game, or keep it a single full .wbfs file, or use the full 9GB ISO file (waste of space, but I think it's the best solution for that game if you use WiiBackupManager.)

    Note that users reported that WiiBackupManager had issues with that game, because of extra game's partitions.
    but the game should at least display in the loader. will not work, but it will display.

    So, I'd suggest you just rename your iso : RSBP01.iso (or RSBE01.iso if it's USA version)
    then manually copy the file to :
    USB:/wbfs/RSBP01/ folder (or RSBE01)

    USB:/wbfs/RSBP01/RSBP01.iso <--- if it's European version
    USB:/wbfs/RSPE01/RSBE01.iso <--- if it's USA version
     
    Last edited by Cyan, May 19, 2018
  12. Petrucci

    Petrucci Member

    Newcomer
    1
    Sep 18, 2016
    United States
    Thank you for the detailed response. I'll try out this method when I have the chance.
     
  13. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    7
    Mar 2, 2015
    United States
    New devkitPro updates... annoying package manager, new errors and warnings. Patch in a few days. :P
     
  14. smf

    smf GBAtemp Maniac

    Member
    5
    Feb 23, 2009
    Years ago I made changes to wbfs_file to include all of the partitions in the .wbfs and it worked fine. I have since lost the changes, but they were pretty trivial from what I remember.
     
  15. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    7
    Mar 2, 2015
    United States
    If you're talking about the partition table in Smash Bros you're right, it's a fairly simple fix. Getting the fix into WBM is another matter without the source to it. :D
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice