USB Loader GX - USB device not initialised

Discussion in 'Wii - Emulation and Homebrew' started by ChrisTate-Davies, Jul 9, 2017.

  1. ChrisTate-Davies
    OP

    ChrisTate-Davies Newbie

    Newcomer
    5
    0
    Sep 4, 2012
    United Kingdom
    Hi there. I have a USB Stick formatted to FAT32 with 32bit cluster size.

    I have the USB Loader GX app on it, and when I load up the Homebrew Channel and plug in the USB, the application appears. When I open the app, it loads, goes through all the boot up. But then I get "Error: USB Device not initialized. Switching to channel list mode."

    The USB is working, as it boots the loader... What am I missing? Do I need to do something else to the disk? There is literally nothing on it apart from the usb loader (in an apps folder) and a wbfs file...

    Any help appreciated!
     
  2. TheThief

    TheThief Member

    Newcomer
    19
    2
    Mar 11, 2016
    United States
    First thing to check, are you using the USB 0 port? You should be. Its the one nearest the bottom of console if its laying flat (closes to edge of Wii).

    Second if you have another usb stick try that one instead.
     
  3. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,076
    8,586
    Oct 27, 2002
    France
    Engine room, learning
    USB Stick are known for having compatibility issues.
    So maybe your USB stick is not compatible with cIOS's ehci module (the USB driver inside the custom IOS).

    You could try to set the IOS to use inside the loader to 58 (settings>loader settings>loader's IOS), but then it will work only when you are inside the loader.
    launching a wii game will require the cIOS to be loaded in memory instead of 58, and you'll have the same issue : games won't be seen from your device.

    At least, you can use it to launch gamecube games with nintendont, which also require IOS8.

    note:
    The homebrew channel is also using IOS58, so it's working and listing all your application correctly.
    when loading USBLoaderGX, it's preparing the game launch by loading cIOS right away. you can delay this option by following what I said above (load cIOS only at game launch instead of doing it at loader's launch), but can't bypass it.
     
    Last edited by Cyan, Jul 10, 2017
  4. Morano

    Morano Newbie

    Newcomer
    2
    0
    Aug 6, 2017
    Austria
    Having similar issues with USB loader gx on my wii but my hdd worked before and now It won't load and says USB not initialized, tried narrowing down the problem and the Hdd shows up on Nintendont on said wii then tried usbloader Gx with my friends wii with my hdd and it works fine then I tried reinstalling cIOS 249 base 56 v10 beta53-alt cIOS 250 base 57 v10 beta52 and trec bug but still no luck any
    Help would be greatly appreciated.