USB Loader GX returning to Wii System menu when loading WiiWare

Discussion in 'Wii - Backup Loaders' started by st964p62, Oct 29, 2016.

  1. st964p62
    OP

    st964p62 Newbie

    Newcomer
    3
    1
    Oct 29, 2016
    United States
    Hello,

    Hopefully I'm not missing something simple as I've Googled around for this for some time now...

    I've got USB Loader GX 3.0 r1262 installed as well as the forwarder listed on the sourceforge page (and that's how I'm launching it).

    GX is up and running with backups I've made of Wii/Gamecube games stored on a USB drive. I've configured it to look at USB:/nand for Nand Emu Path/Nand Channel Path, and had it dump system nand there. I've installed a WiiWare wad via the integrated wad tool. USB Loader/Game IOS set to 249, Nand Chan. Emulation set to Full, Saves Emulation set to Partial. Not using neek.

    Whenever I try to run the WiiWare title (Alien Crush Pinball) the Wii returns from GX to the Wii System menu. I'm not sure what I'm missing. I do have d2x installed, perhaps not the right one? I've tried running the WiiWare title with 249/250/251, and no dice.

    Any thoughts? Let me know if there's any additional information you might need, I'm definitely new to this. Thanks for any assistance!

    Syscheck follows:


    SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline Double_A R2-D2199 and Nano
    ...runs on IOS58 (rev 6176).
    Region: NTSC-U
    System Menu 4.3U (v513)
    Drive date: 09.07.2006
    Homebrew Channel 1.1.2 running on IOS58
    Hollywood v0x11
    Console ID: 42898849
    Console Type: Wii
    Shop Channel Country: United States (49)
    Boot2 v4
    Found 66 titles.
    Found 47 IOS on this console. 15 of them are stubs.
    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 256): Stub
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 1032): No Patches
    IOS20 (rev 256): Stub
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 2816): Stub
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 3072): Stub
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 5120): Stub
    IOS51 (rev 4864): Stub
    IOS52 (rev 5888): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 6400): Stub
    IOS61 (rev 5662): No Patches
    IOS62 (rev 6430): No Patches
    IOS70 (rev 6912): Stub
    IOS80 (rev 6944): No Patches
    IOS222 (rev 65280): Stub
    IOS223 (rev 65280): Stub
    IOS249[56] (rev 65535 Info: d2x-v10beta53-alt): Trucha Bug NAND Access USB 2.0
    IOS250[57] (rev 65535 Info: d2x-v10beta52): Trucha Bug NAND Access USB 2.0
    IOS251[58] (rev 65535 Info: d2x-v10beta52): Trucha Bug NAND Access USB 2.0
    IOS254 (rev 65280): Stub
    BC v6
    MIOS v10
    Report generated on 10/29/2016.

    If there's anything askew in the syscheck, please let me know. Thanks again!
     
  2. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,005
    774
    Mar 2, 2015
    United States
    Try changing your d2x you have in slot 249 to d2x-v10-beta52 instead of beta53. (Use IOS 56 as base still.)

    beta53 has problems with EmuNAND.
     
  3. st964p62
    OP

    st964p62 Newbie

    Newcomer
    3
    1
    Oct 29, 2016
    United States
    Thanks for your response, I really appreciate it!

    Unfortunately still no luck. To install d2x I used the installer from this guide: https://sites.google.com/site/completesg/backup-launchers/installation. I didn't explicitly download any wad files though (the installer appears to this). Should I have?

    It's interesting that syscheck shows the IOS installs as USB rather than SD (where they were installed from). Is that due to the nand backup step? Do I need to run that dump from USB Loader GX every time I make a change to cios if I'm using nand on USB?

    I guess I can try keeping the nand directory on the SD Card and seeing if that works. Otherwise I'm not sure where to go from here.
     
  4. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,005
    774
    Mar 2, 2015
    United States
    The USB means that IOS has the USB module in it, not how it was installed.

    The soft mod guide's instructions are good, it just tells you to use beta53 for some reason and it's not good to use. If you follow the same instructions to install 249[56] but select beta52 instead it should be fine.

    Beta 53 allows you to use either USB port for hard drives but the changes made to it broke it's EmuNAND system somewhat. Beta 52 has normal EmuNAND compatibility but you must connect your HDD to port 0 only. EmuNAND also requires the hard drive be partitioned as MBR/FAT32 and I believe it has to be the first partition. I keep my VC/Wiiware on my SD card as well.
     
  5. st964p62
    OP

    st964p62 Newbie

    Newcomer
    3
    1
    Oct 29, 2016
    United States
    I moved the nand to the SD card and it's now working. Thanks again for your help!
     
    GreyWolf likes this.