Usb Loader Gx kicks me back to homebrew menu

Discussion in 'Wii - Backup Loaders' started by xXErrorXx, Aug 9, 2018.

  1. xXErrorXx
    OP

    xXErrorXx Member

    Newcomer
    1
    Aug 3, 2018
    Germany
    So I have this problem where when I try to load a game with Usb Loader Gx it just sends me back to the Homebrew Menu. It first happened with a Mario Kart Wii iso and now with a Kirby's Adventure wii (Or Return to Dreamland) iso.
    Other games seem to work fine.
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    reloading is a symptom of "game not found".

    it can be different things :
    wrong cIOS slot selected for these games (verify your individual game settings)
    wrong or corrupted ISO (verify with Wii Backup Manager > option > sha1)
    wrong filename or path (verify your file : /wbfs/game's Title [TitleID6]/TitleID6.wbfs, and if possible check this guide to properly rename all your games at once)

    I won't tell it could be the drive, as you said your other games are working.
     
    Last edited by Cyan, Aug 9, 2018
  3. xXErrorXx
    OP

    xXErrorXx Member

    Newcomer
    1
    Aug 3, 2018
    Germany
    Alright so I have renamed my games but how do I check if I selected the wrong cios?
    The weird thing is, it worked just fine a few days ago.
     
    Last edited by xXErrorXx, Aug 9, 2018
  4. FancyNintendoGamer567

    FancyNintendoGamer567 GBAtemp Advanced Fan

    Member
    3
    Feb 13, 2017
    United States
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    you always find old and weird urls not helping users.

    Don't look at that old, wrong and dangerous compatibility list, it's not giving you the answer to your question, it's even not helpful because it doesn't provide correct info.
    and Mario kart Wii is working fine, it's not a compatibility list which will reveal your problem.

    to verify the IOS slot :
    USBLoaderGX > select the game > Option > Game's Option > IOS Slot : verify it's set to "use global". If not, choose "reset" in the previous screen.

    then verif your USB Loader GX is properly set to use slot249 or 250.
    USBLoaderGX > Settings > Loader's settings > Game's IOS and Loader's IOS : 249 or 250

    then go to Settings > Credit > look at the top, it should tell you :
    USBLoaderGX r1268 (or 1260 or newer), slot249 or 250, d2x v8 final (or d2x v10 r52), base 56 or 57.
    If you have anything else, it's wrong.


    One of the Kirby games do have anti piracy check, but not mario kart.
    for kirby, disable all patches : be sure you play the game from the same region than your console, disable cheat code, disable "return to" (though it should work with it, you can disabled it to be sure), don't set any video mode or any patches.



    If it worked fine few days ago, maybe your device has a problem, your iso is corrupted?
    did you add new files to that device ?
     
    Last edited by Cyan, Aug 9, 2018
  6. FancyNintendoGamer567

    FancyNintendoGamer567 GBAtemp Advanced Fan

    Member
    3
    Feb 13, 2017
    United States
    I'm useless.
     
  7. xXErrorXx
    OP

    xXErrorXx Member

    Newcomer
    1
    Aug 3, 2018
    Germany
    So in the credits it says rev1262 (rev 65535) (d2x v10beta52 base57)
    Is that correct?
    Oh and no I didn't add any files to my drive, but I've played nsmbw with the regular disk channel.
     
  8. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    yes, it's good. it means :
    you have USBLoaderGX revision 1262 (current latest is 1268)
    it's using d2x v10 r52, based on IOS57 (the best).

    if you checked your individual game settings, and it's correctly set to "use global" then your settings are good.

    If the game doesn't launch, maybe the iso is corrupted.
    or maybe the USB really has power issue and disconnect, but it wouldn't do it only with this game.


    playing a game from disc channel could have replaced the cIOS slot, but in your case (based on how it's installed) it didn't. so it's not a problem to play from disc channel.
     
    Last edited by Cyan, Aug 10, 2018
  9. xXErrorXx
    OP

    xXErrorXx Member

    Newcomer
    1
    Aug 3, 2018
    Germany
    So basically my iso is corrupted? Because it still sends me back to the homebrew menu.
     
  10. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    you are sure your other games are working fine, right?

    Verify your ISO with WiiBackupManager > option > Sha1 tool.
    if the result is red, the ISO is bad. if it's green, then I don't know the reason, except a wrong setting maybe.
     
  11. xXErrorXx
    OP

    xXErrorXx Member

    Newcomer
    1
    Aug 3, 2018
    Germany
    What sha1 tool? I go to options and there isnt anythig like that.
     
  12. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    you are not in the game's option, you are in the program's option?

    Go to Drive1 tab, select a game first, then the "sub menu" (not the program's menu), there's an tools > sha1

    edit:
    sorry, apparently it's MD5, not sha1. I always thought it used sha1 to verify the games. Or maybe I have an old version without the sha1 option.
     
    Last edited by Cyan, Aug 10, 2018
  13. xXErrorXx
    OP

    xXErrorXx Member

    Newcomer
    1
    Aug 3, 2018
    Germany
    Ive already used sha1 to verify and all games are green except for kirby, that one's blue. Now i'm verifying it with md5.
    Edit: yup, kirby is still blue.
     
    Last edited by xXErrorXx, Aug 10, 2018
  14. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    blue? I thought it was only red or green.
    maybe it's corrupted and there's no color because it can't even open it to verify the content?

    That doesn't explain why mario kart is not working.
     
  15. xXErrorXx
    OP

    xXErrorXx Member

    Newcomer
    1
    Aug 3, 2018
    Germany
    Is there maybe another wy to find out if it s corrupted or not?
     
  16. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    with WIT (Wiimm ISO Tool), but it's a command line program.
    Maybe it's easier to delete and redump the game.
     
    Last edited by Cyan, Aug 10, 2018
  17. xXErrorXx
    OP

    xXErrorXx Member

    Newcomer
    1
    Aug 3, 2018
    Germany
    Huh. Probably. I just noticed, I think mario kart is not working because its a different region than my wii.
     
  18. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    I don't think, it should at least launches and at worst stay on a black screen because of incompatible video mode.
     
  19. xXErrorXx
    This message by xXErrorXx has been removed from public view by Cyan, Aug 10, 2018, Reason: asking for copyrighted games.
    Aug 10, 2018
  20. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    really ? Asking a moderator how to find pirated games?
    read the forum's rules again.
     
  21. xXErrorXx
    OP

    xXErrorXx Member

    Newcomer
    1
    Aug 3, 2018
    Germany
    Oops. I am really, REALLY sorry for this... I should've read the rules better.
    But my Usb loader gx now freezes on "reloading to config file's cIOS..." I've tried to delete the GXGlobal.cfg but it still doesn't work.
     
Loading...