1. jakebfb

    OP jakebfb Newbie
    Newcomer

    Joined:
    Jun 16, 2019
    Messages:
    8
    Country:
    Ireland
    Hey everyone. I used the crap program on my PC to create custom wads for my USB Loader GX games, but when I open them it says "Failed to load IOS58. USB Loader GX requires a cIOS or IOS58 with AHB Access."

    All games load regularly using USB Loader GX, but when trying to open the games through the forwarders it refuses to work. Any help on the issue?
     
  2. jeannotte

    jeannotte GBAtemp Maniac
    Member

    Joined:
    Jun 15, 2016
    Messages:
    1,288
    Country:
    France
    alexander1970 likes this.
  3. Cyan

    Cyan GBATemp's lurking knight
    Global Moderator

    Joined:
    Oct 27, 2002
    Messages:
    22,532
    Country:
    France
    It has nothing to do with syscheck or the softmod or IOS58 (no need to reinstall it either!)
    with missing AHB access provided by the channel, the loader can't run without a cIOS.

    change usbloader's IOS to 249 instead of 58.
    OR
    revert to 1271 instead of 1272 to NOT use 58 by default
    OR
    edit your CRAP(py) channel's TMD to add AHB access rights in order to allow USBLoaderGX to access hardware and NAND with IOS58.
    editing imply : unpacking the WAD on computer, edit the tmd on hex editor, repack the WAD, (re)install the channel.

    try using WiiGSC instead of CRAP, maybe the updated program version creates correct channels with full AHB access flag. but you need to test to see, it's still an old program so it might not do it.
    but the easier solution is the first one : DO NOT USE 58 !
    edit your loader's settings to use cIOS.
     
    Last edited: Aug 27, 2019
    alexander1970 likes this.
  4. jakebfb

    OP jakebfb Newbie
    Newcomer

    Joined:
    Jun 16, 2019
    Messages:
    8
    Country:
    Ireland
    Thanks for the reply! I tried changing the ISO to 249 but it won't work. WiiGSC doesn't seem to work for me too. I don't know how to edit the tmd in the wad, should I try reverting to 1271? If not, anything else I can do?
     
  5. Cyan

    Cyan GBATemp's lurking knight
    Global Moderator

    Joined:
    Oct 27, 2002
    Messages:
    22,532
    Country:
    France
    yes, try reverting to 1271
    but the only change is the default IOS used by the loader, you can set it back to 249 yourself instead of reverting the revision.
     
    Randyslim76 likes this.
  6. jakebfb

    OP jakebfb Newbie
    Newcomer

    Joined:
    Jun 16, 2019
    Messages:
    8
    Country:
    Ireland
    I reverted to 1271. The forwarder now shows no error but it just boots to the home menu. Also, cover art won't download now.
     
  7. Aria254

    Aria254 Newbie
    Newcomer

    Joined:
    Dec 5, 2018
    Messages:
    2
    Country:
    Finland
    Has anyone found a solution? It's 2019 why is launching games from the menu so hard? hacking 2ds and the switch was wayy easier than the wii
     
  8. GamerGirl190

    GamerGirl190 Newbie
    Newcomer

    Joined:
    Jan 23, 2020
    Messages:
    1
    Country:
    United States
    For loading game channels...Try installing USB loader GX r1260. I Was having the same problem and Tried multiple things. This worked for me !
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - channels, working, Loader