USB Loader GX - 30 Sec. Hangs

Discussion in 'Wii - Backup Loaders' started by MrWiggles, Dec 8, 2012.

Dec 8, 2012
  1. MrWiggles
    OP

    Newcomer MrWiggles Newbie

    Joined:
    Feb 18, 2011
    Messages:
    5
    Country:
    United States
    I have been using CFG USB Loader for years now but am wanting to switch over to GX since it separates the GC games from Wii games.

    The problem is, when you click any button in GX, it will freeze for about 30 sec where the button shows pushed but you can still move the hand around to highlight other buttons...then it will do whatever you told it to do.

    I have tried several updates for a few months now and it all seems to do it.

    Is there something I might need to do/change to fix this?


    Thanks,
     
  2. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,433
    Location:
    Engine room, learning
    Country:
    France
    Are these freeze also occuring when you don't have any HDD connected to USB?
    You can launch the loader without HDD, just press B at HDD detection screen, and it will work in Channel mode listing your installed channels on the Wii.

    if it does it too, could you try another SD card? (or no SD card at all, if you put all the necessary files on USB instead of SD).

    If it still doing it then it's neither the SD nor HDD.
    Are you using the channel version, or the forwarder/hbc version?

    Let's proceed by elimination when we don't know what the problem is.
     
  3. MrWiggles
    OP

    Newcomer MrWiggles Newbie

    Joined:
    Feb 18, 2011
    Messages:
    5
    Country:
    United States
    So after a quick test...it SEEMS to be Hdd related.
    GX uses a forwarder. I have all my apps on the Hdd with the games.

    I put GX on an SD card and loaded GX by it. It didn't give me freeze with no Hdd....so I plugged the Hdd in, while still using GX off SD and it didn't freeze that way either.

    So why would it be freezing off the hdd? I'm tempted to try the system channel instead of a forwarder.
     
  4. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,433
    Location:
    Engine room, learning
    Country:
    France
    So it's lagging only when you have the loader's folders on USB?
    interesting. I'll have to test that.

    If it's related to your HDD, there's high chance that it could be fixed with a simple option if your are using FAT32.
    Go to the loader > Settings > HDD menu > select the "Synch FAT32" option.
    It will fix the file's table of content (TOC).

    If this works, then it means that you used old homebrew with that drive.
    Old homebrew used an old fat library which didn't update the TOC correctly, making it slow to get the real used/free size of that partition.

    If it didn't fix the freezes, well, at least you tried something and we can put that possibility away.
     
  5. MrWiggles
    OP

    Newcomer MrWiggles Newbie

    Joined:
    Feb 18, 2011
    Messages:
    5
    Country:
    United States
    Ok, so I tried to sync but it just sits at 0% for about 2 mins, then window goes way. It never shows that it completed it by going to 100%.

    I tried it with both GX on Hdd and SD card, both do same thing.
     
  6. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,433
    Location:
    Engine room, learning
    Country:
    France
    So I suppose it didn't fix the problem, or else you would have noticed the speed improvement.

    You don't have another HDD to test?
    If all HDD are doing the same thing, there's a chance it's caused by the loader.

    Is the drive long to be detected when you boot the loader?
    Maybe your drive doesn't have a partition table. I've read someone else saying adding a table fixed his problem. But can't explain how to do it, if you don't know what you are doing it can be hard to explain.
     

Share This Page