USB loader black screen: "An error has occurred..."

Discussion in 'Wii - Hacking' started by Jourinho, Oct 17, 2016.

  1. Jourinho
    OP

    Jourinho Member

    Newcomer
    15
    1
    Dec 30, 2013
    Belgium
    Hi All


    A friend of mine just bought a Wii and asked me if I could hack it for him. I hacked alot of Wii's in the past using guides on this forum.
    It was obvious this Wii had been messed around with before. It has a SD card slot mounted on the side of the Wii... I don't know why.

    I followed all the steps in this guide:
    https://gbatemp.net/threads/beginne...g-wiiware-vc-vackups-gamecube-backups.400975/

    Everything went fine. Until i wanted to boot up a game from my HDD. The screen turns black and if i wait long enough an error appears:

    "An error has occurred. Press the eject button and remove the disc..."

    I've been searching for a while now, but i have no clue what I did wrong.
    I connected the Wii to the internet and used d2x cIOS to install the cIOS'es mentioned on this page:
    https://sites.google.com/site/completesg/backup-launchers/installation

    I noticed on the grid with installed cIOS'es the 222/223 were coloured. Does that mean a Hermes soft mod was installed? I have no clue. I have a Wii myself but barely touch it.

    I've tried multiple things:
    - Several USB loaders (confg. usb loader, usb loader gx,...)
    - Changing the IOS for the games to 249/250 even tried 222/223

    Results are all the same...
    I really hope someone can help me out.

    My SysCheck results:


    Region: PAL
    System Menu 4.3E (v514)
    Priiloader installed
    Could not detect the drive date!
    Homebrew Channel 1.1.2 running on IOS58

    Hollywood v0x11
    Console ID: 84160695
    Console Type: Wii
    Shop Channel Country: Albania (64)
    Boot2 v4
    Found 86 titles.
    Found 46 IOS on this console. 13 of them are stubs.

    IOS3 (rev 65280): Stub
    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 256): Stub
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 1032): No Patches
    IOS20 (rev 256): Stub
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 2816): Stub
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 3072): Stub
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 5120): Stub
    IOS51 (rev 4864): Stub
    IOS52 (rev 5888): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 6400): Stub
    IOS61 (rev 5662): No Patches
    IOS62 (rev 6430): No Patches
    IOS70 (rev 6912): Stub
    IOS80 (rev 6944): No Patches
    IOS223[38+37] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS249[56] (rev 65535, Info: d2x-v10beta53-alt): Trucha Bug, NAND Access, USB 2.0
    IOS250[57] (rev 65535, Info: d2x-v10beta53-alt): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v10


    EDIT:
    - The problem is not my HDD, on my own Wii it still works perfectly.
    - Could it be the drive on this Wii which is defective? Can i use a defective DVD drive when using an USB loader?


    Thanks in advance!
     
    Last edited by Jourinho, Oct 18, 2016
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,031
    Oct 27, 2002
    France
    Engine room, learning
    yes, it means the slot 222 and 223 is already used (usually, hermes cIOS are installed in these slots).
    Having them or not have no effect. they are passive files until you specifically choose to load them, so don't worry about it.


    Your cIOS install seems fine.
    There's no slot 222, you probably deleted it?

    What you can try is install v10 instead of v10-alt.
    In the usb loader, be sure it's using the slot 249 or 250 to launch the game.

    Do you know if that Wii has an issue with the disc drive?
    Having an additional SD card slot on the side is strange and feel like the user heavily modded his console, maybe he replace the drive ? maybe it's dead?
    did you try a retail disc launched from the System menu?
     
  3. Jourinho
    OP

    Jourinho Member

    Newcomer
    15
    1
    Dec 30, 2013
    Belgium
    Hi Cyan

    First of all: thanks for your answer. I have deleted the 222, when i was trying to figure out what was wrong with the Wii.
    I have no idea what the additional SD card slot mounted on the side does. It has a connector running from the additional slot in the back of the Wii...

    I have some retail discs, i'll try those first.
    If this doens't work, maybe I should open the case and look if the Wii is modded so the SD card slot on the side replaces the dvd drive in some way? If it does, I may be able to connect the drive the way it should be.

    I will try the retail disc tonight.
     
  4. Jourinho
    OP

    Jourinho Member

    Newcomer
    15
    1
    Dec 30, 2013
    Belgium
    I've tested with a retail disc.

    I noticed something strange... I put in a the retail disc and I was able to boot the game up.
    When i tried to launch a game after this with cfg loader, IT WORKED!

    I had no idea why it worked at that point, so I tried again. It kept working until i reboot the Wii and tried to launch a game with the USB loader again. It didn't work anymore...
    After some trial and error I came to the conclusion the USB loader works when there is a retail disc in the dvd drive.
    Anyone has a logical explanation for this? Is it possible the Wii has a modchip of some kind which triggers this?

    Thanks!
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,031
    Oct 27, 2002
    France
    Engine room, learning
    I don't remember any modchip which required a disc in the drive to enable it.
    the drive need to be present, or it will not work. There is the WODE which removes the drive entirely, but it replaces it with an external device.
    maybe the modchip is not properly soldered (I don't know what could happen if that's the case).

    Would you mind opening the console and seeing (or taking a picture) of the inside to know why it has an additional/external SD card slot?
    I'm just curious.

    well, if it works fine with any disc inserted, just keep one inside :)
     
  6. Jourinho
    OP

    Jourinho Member

    Newcomer
    15
    1
    Dec 30, 2013
    Belgium
    Hi Cyan


    Sure, i'll be home late tonight so I will post the photo's tomorrow evening :)