USB issues with USB Loader GX.

Discussion in 'Wii - Hacking' started by portugeek, Mar 4, 2014.

  1. portugeek
    OP

    portugeek GBAtemp Fan

    Member
    375
    67
    Apr 6, 2013
    United States
    I recently came across some issues with USB Loader GX (that I've never experienced before) while helping my friend troubleshoot his softmodded Wii.

    The first one happened while USB Loader was booting up. What originally happened was, we had a problem getting Dios Mios to work on his new hard drive. He was getting the same "black screen" issue, that a few people here have been experiencing recently. So I decided to format a USB flash drive to see if the issue was with his hard drive. I figured that it was, since his drive seemed to be working fine with Devolution.

    So I formatted the flash drive, loaded a couple GC and Wii ISO's onto it, started up the Wii and ran USB Loader GX. Once USB Loader GX got to the "reinitializing devices" stage, it would just hang there and not advance any further. I've never experienced this. I've used this USB flash drive before (for testing) and have never had issues. But yesterday I tried it with both r1218, and r1213, and it didn't get passed the reinitializing stage.

    I know that it used to work in the past, so my question is, was there something that changed on recent versions of USB Loader GX that effected compatibility with some USB flash drives?


    ---Eventually we came upon another hard drive, and Dios Mios worked on it, so we confirmed that the issue was with his original drive.---


    The second issue happened right after we had learned that one of the drives worked with Dios Mios but the other one didn't. The one that DIDN'T work with Dios Mios was larger in capacity. So he decided to use that drive for all of his Wii backups, and GC backups that ran on Devolution. On his smaller drive, he put the ISO's that required Dios Mios. I figured, that instead of him swapping out drives all the time, why not just try plugging them both in. So I did, but it didn't work.

    I thought, that if I went to USB Loader GX's "Hard Drive Settings" that I could switch the "USB Port" setting to "Both Ports". And then after that, I could go to "Custom Paths" and change the "Main GameCube Path" to "usb2:/games/". That way, he could access the other drives GameCube games without swapping drives. But that didn't work. And what's just become apparent to me, RIGHT NOW as I'm typing this, is that since I can't choose multiple paths for GameCube games, there will be no way for him to access two different GameCube folders that exist on seperate drives. The only way would be for him to put all GameCube games on one drive and all Wii games on the other.

    So anyway! Now that I've sort of walked myself through that tiny issue, it still doesn't solve the problem I was having last night. Which is, when I'd turn on both USB ports, USB Loader would only ever recognize one of the drives. More specifically, which ever drive happened to be plugged into USB Port 0. When I'd go to "Custom Paths" and change the "Main GameCube Path" it DID give me the option to switch between usb1:/ and usb2:/, but it didn't matter which one I chose, because it would only ever show me the folders from the one drive that was plugged into Port 0.

    Is this a problem with USB Loader GX? Or is this an IOS issue that doesn't allow both of the Wii's USB Ports to be compatible with USB loading? OR, did I make a mistake and overlook a setting that I should've changed?


    Sorry that my post was so long. I wanted to be clear on what happened.